1.0~rc3+svn20090426-1ubuntu16 don't install and use libfribidi-dev

Bug #565679 reported by aviramof on 2010-04-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mplayer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mplayer

it seem to be that the current version of mplayer in the repositories(1.0~rc3+svn20090426-1ubuntu16)don't install libfribidi-dev package and is not configure with libfribidi-dev so installing it doesn't help

my problem is that hebrew translation in software like smplayer are reverse and as such unusable.

i have compiled a new mplayer version from svn after installing libfribidi-dev so the problems is solved with gnome-mplayer and perhaps other mplayers clients that use the compile version by default(this is the version i get when i write mplayer in terminal) but not with smplayer.

the problem with smplayer is that i can't get it to use the compiled svn mplayer if i try
to change the path to the compiled mplayer version videos simply don't open in smplayer.

i compiled a new smplayer version to svn 3500 version but still i changing the path to the
compiled mplayer version in the new smplayer version doesn't work videos still don't work

basicly the problem is why mplayer 1.0~rc3+svn20090426-1ubuntu16 don't use libfribidi-dev and there for i can's see hebrew translation correctly while i'm using this version in smplayer, and perhaps other clients that don't use the compile version.

version that is installed by default in /usr/loacl/bin but the one that the repositories install in /usr/bin/.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: mplayer 2:1.0~rc3+svn20090426-1ubuntu16
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ofir 1297 F.... pulseaudio
 /dev/snd/controlC1: ofir 1297 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'V8237'/'VIA 8237 with ALC655 at 0xc800, irq 22'
   Mixer name : 'Realtek ALC655 rev 0'
   Components : 'AC97a:414c4760'
   Controls : 48
   Simple ctrls : 29
Card1.Amixer.info:
 Card hw:1 'camera'/'USB camera at usb-0000:00:10.1-1, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB045e:00f7'
   Controls : 3
   Simple ctrls : 2
Date: Sun Apr 18 02:52:20 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100410)
ProcEnviron:
 LANG=he_IL.utf8
 SHELL=/bin/bash
RelatedPackageVersions:
 libavcodec52 N/A
 libavcodec-extra-52 4:0.5.1-1ubuntu1+medibuntu1
SourcePackage: mplayer
UserConf:
 # Write your default config options here!

 [gnome-mplayer]
 msglevel=all=5
dmi.bios.date: 07/25/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: MS-7222
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.board.version: 2.00
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd07/25/2006:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-7222:pvr2.00:rvnMICRO-STARINTERNATIONALCO.,LTD:rnMS-7222:rvr2.00:cvn:ct3:cvr:
dmi.product.name: MS-7222
dmi.product.version: 2.00
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO., LTD
system: distro = Ubuntu, architecture = i686, kernel = 2.6.32-21-generic

aviramof (aviramof) wrote :
aviramof (aviramof) wrote :
Ofer Chen (oferchen) wrote :

I'm experiencing same difficulties... cp1255 is not working correctly

aviramof (aviramof) wrote :

try installing other mplayer like from coreavc ppa or rvm ppa and that it.

Ofer Chen (oferchen) wrote :

I still have the issue what I did what to use a fully unicode (e.g. arialuni.ttf) font and change mplayer encoding to ISO8859-8
it fixes most of the problem with subtitles but it's still not the proper way of fixing the issue, perhaps I will have a go at freebidi source code, because this is a long time issue for me not only on Ubuntu.

To post a comment you must log in.