Mplayer should not build-dep on nvidia-185-libvdpau-dev [i386 amd64],

Bug #532007 reported by John Vivirito
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mplayer (Ubuntu)
Fix Released

Bug Description

Binary package hint: mplayer

Mplayer should only use build-dep nvidia-185-libvdpau-dev [i386 amd64], for nvidia users.
At this time any user that installs mplayer it will install nvidia-current and should only use it for nvidia users.

Here is current debian/control build-dep list:
Build-Depends: debhelper (>= 7),
               libasound2-dev [!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386],
               libavcodec-dev (>= 0.svn20080206),
               libcdparanoia-dev | libcdparanoia0-dev,
               libpng12-dev | libpng-dev,
               libsdl1.2-dev | libsdl1.1-dev,
               libsvga1-dev [i386 amd64],
               libtheora-dev (>= 1.0~beta1),
               nvidia-185-libvdpau-dev [i386 amd64],

maybe we should also remove nvidia-libvdpau1 | nvidia-libvdpau from mplayer-nogui
As i understand it ffmpeg's code is preventing updating mplayer.
I'm not sure why we are using nvidia-libvdpau1 | nvidia-libvdpau for all 386 64bit users.
I am not going to have time to figure out why we are using that for all users this dev cycle, if it is going to be a while before we update to newer version than jun of 09 maybe this should get fixed?

ProblemType: Bug
Architecture: i386
Date: Thu Mar 4 11:20:52 2010
DistroRelease: Ubuntu 10.04
NonfreeKernelModules: nvidia
Package: mplayer (not installed)
 PATH=(custom, user)
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: mplayer
Uname: Linux 2.6.32-15-generic i686

Related branches

Revision history for this message
John Vivirito (gnomefreak) wrote :

should have just attached the file. here is the full control file

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mplayer - 2:1.0~rc3+svn20090426-1ubuntu14

mplayer (2:1.0~rc3+svn20090426-1ubuntu14) lucid; urgency=low

  * cleanup --configure flags
  * drop VDPAU build hacks, Closes: #566868, LP: #530481, #532007
  * enable musepack support
  * enable libaa support, LP: #502767, #455535
  * enable enca support, LP: #115519
  * remove DEB_BUILD_CONFIGURE override hack
  * fix weird permission bits for mplayer.desktop and mplayer.xpm
  * reorganize binary packages to no longer install the gui version by
  * refactor debian/rules to avoid sub makes
  * add patch to allow compilation with newer x264
  * use mp_msg instead of printf in debug help message
  * bump standards version
  * as no longer used, remove dependencies on debconf
  * Fix possible crashes with invalid SDPs, LP: #519579
  * add missing replaces
  * install manpages in the 'mplayer' package. and only there
 -- Reinhard Tartler <email address hidden> Thu, 11 Mar 2010 12:45:55 +0100

Changed in mplayer (Ubuntu):
status: New → Fix Released
Revision history for this message
vientito (billyleung336) wrote :

2:1.0~rc3+svn20090426-1ubuntu14 this version number is misquoted... the year is 2010 not 2009

I found this out after I force install this particular version instead of the default mplayer that comes with Lucid. There is an annoying upgrade demand because the software judges the version with later year to be a "newer" one so it will constantly ask me to upgrade to the "problematic" version.

I have since checked under medubuntu repository and their naming convention is screwed up as well the year is still stuck at 2009.

I hope someone would notify them to correct the situation

Revision history for this message
John Vivirito (gnomefreak) wrote :

Vientito that is done by LP.
Lp reads the changelog once the package is uploaded, the above is all changes made in that version

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.