mplayer: symbol lookup error: mplayer: undefined symbol: codec_wav_tags

Bug #461966 reported by Daniel Bair
70
This bug affects 15 people
Affects Status Importance Assigned to Milestone
mplayer (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Symptom:
mplayer: symbol lookup error: mplayer: undefined symbol: codec_wav_tags

Indication:
check the version string of the libavutil package. If it contains the string 'ppa', 'tj~ppa' or similar, or if you have the package libavutil50 (instead of libavutil49) installed, then you are affected.

Workaround:
remove libavutil50

Solution:
none, this problem is caused by 3rd part packages.

DO NOT REOPEN THIS BUG!

Original Report:
Binary package hint: mplayer

When I try to run mplayer all I get is...
mplayer: symbol lookup error: mplayer: undefined symbol: codec_wav_tags

This is on Kubuntu Karmic 9.10 AMD64 with openshot installed.

ProblemType: Bug
Architecture: amd64
Date: Tue Oct 27 10:11:41 2009
DistroRelease: Ubuntu 9.10
Package: mplayer 2:1.0~rc3+svn20090426-1ubuntu10
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 libavcodec52 N/A
 libavcodec-extra-52 4:0.5+svn20090926-0ubuntu3~tj~ppa1k
SourcePackage: mplayer
Uname: Linux 2.6.31-14-generic x86_64
UserConf: # Write your default config options here!
system: distro = Ubuntu, architecture = x86_64, kernel = 2.6.31-14-generic

Revision history for this message
Daniel Bair (danielbair) wrote :
Revision history for this message
Daniel Bair (danielbair) wrote :

dpkg -l vlc mplayer ffmpeg libavformat52
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-============================================-============================================-========================================================================================================
rc ffmpeg 4:0.5+svn20090706-2ubuntu2 multimedia player, server and encoder
rc libavformat52 4:0.5+svn20090706-2ubuntu2 ffmpeg file format library
ii mplayer 2:1.0~rc3+svn20090426-1ubuntu10 movie player for Unix-like systems

Revision history for this message
Daniel Bair (danielbair) wrote :

dpkg -l vlc mplayer ffmpeg libavformat52
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-============================================-============================================-========================================================================================================
rc ffmpeg 4:0.5+svn20090706-2ubuntu2 multimedia player, server and encoder
rc libavformat52 4:0.5+svn20090706-2ubuntu2 ffmpeg file format library
ii mplayer 2:1.0~rc3+svn20090426-1ubuntu10 movie player for Unix-like systems
ii vlc 1.0.2-1ubuntu2 multimedia player and streamer

Revision history for this message
Daniel Bair (danielbair) wrote :

dpkg -l openshot openshot-ffmpeg
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-============================================-============================================-========================================================================================================
ii openshot 0.9.52 OpenShot Video Editor is a free, open-source, non-linear video editor, based on Python, GTK, and MLT. I
ii openshot-ffmpeg git-2623d8f-1 Package created with checkinstall 1.6.1

Changed in mplayer (Ubuntu):
assignee: nobody → gnome-mplayer maintainers (gnome-mplayer)
Daniel Bair (danielbair)
Changed in mplayer (Ubuntu):
assignee: gnome-mplayer maintainers (gnome-mplayer) → nobody
Revision history for this message
Reinhard Tartler (siretart) wrote : Re: [Bug 461966] [NEW] mplayer: symbol lookup error: mplayer: undefined symbol: codec_wav_tags

Daniel Bair <email address hidden> writes:

> libavcodec-extra-52 4:0.5+svn20090926-0ubuntu3~tj~ppa1k

This package is breaking your mplayer package.

From which PPA did you get this package?

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Revision history for this message
Daniel Bair (danielbair) wrote : Re: [Bug 461966] [NEW] mplayer: symbol lookup error: mplayer: undefined symbol: codec_wav_tags

I expect that would be the openshot ppa, which I disabled earlier do to it
preventing me from upgrading.

-Daniel

On Tue, Oct 27, 2009 at 12:11 PM, Reinhard Tartler <email address hidden>wrote:

> Daniel Bair <email address hidden> writes:
>
> > libavcodec-extra-52 4:0.5+svn20090926-0ubuntu3~tj~ppa1k
>
> This package is breaking your mplayer package.
>
> >From which PPA did you get this package?
>
>
> --
> Gruesse/greetings,
> Reinhard Tartler, KeyID 945348A4
>
> --
> mplayer: symbol lookup error: mplayer: undefined symbol: codec_wav_tags
> https://bugs.launchpad.net/bugs/461966
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Reinhard Tartler (siretart) wrote :

ic. thanks for reporting back.

Changed in mplayer (Ubuntu):
status: New → Invalid
Revision history for this message
manuti (manuti) wrote :

Is Invalid or not confirmed.

I have the same bug when I try to run mplayer all I get is...
mplayer: symbol lookup error: mplayer: undefined symbol: codec_wav_tags

In my case is on Ubuntu Karmic 9.10 AMD64 without openshot installed.

Revision history for this message
Iago Laz (iarrovawo) wrote :

I have the same bug when I try to run mencoder.

mencoder: symbol lookup error: mencoder: undefined symbol: codec_wav_tags

I'm on Ubuntu Karmic 9.10 32bits.

I think this bug went after upgrading mplayer with Nvidia Vdpau PPA: https://launchpad.net/~nvidia-vdpau/+archive/ppa

Revision history for this message
larmahunter (charrah) wrote :

I have the same bug for- it happened when I made an upgrade 2 or 3 days ago. I have been using the nVidia VDPAU PPA version of mplayer for a long time without problems.

Revision history for this message
Jorge Suárez de Lis (ys) wrote :

I've suscribed the Nvidia Vdpau Team to this bug since it seems to be related to their PPA.

Revision history for this message
Reinhard Tartler (siretart) wrote :

the version number looks rather like the package from the openshot archive, not the nvidia vdpau team.

Revision history for this message
Iago Laz (iarrovawo) wrote :

Hello again, I don't have openshot installed and I have the same bug with mencoder. My versions:

iarrovawo@iarrovawo-portatil:~$ dpkg -l vlc mplayer ffmpeg libavformat52 mencoder
Deseado=Desconocido/Instalar/Eliminar/Purgar/Mantener
| Estado=No/Inst/Archivos Cfg/Desempaquetado/Cfg fallido/Medio-inst/Espera/Pediente
|/ Error?=(Nada)/Requiere reinstalación (Estado,Error: Mayúsculas=mal)
||/ Nombre Versión Descripción
+++-=======================================-=======================================-==============================================================================================
ii ffmpeg 5:0.5+svn20091116-0.4 audio/video encoder, streaming server & audio/video file converter
ii libavformat52 5:0.5+svn20091116-0.4 ffmpeg file format library
ii mencoder 2:1.0~rc3+svn20090620~karmic~ppa4 MPlayer's Movie Encoder
un mplayer <ninguna> (no hay ninguna descripción disponible)
ii vlc 1.0.3-1~ppa1 multimedia player and streamer

Revision history for this message
Reinhard Tartler (siretart) wrote : Re: [Bug 461966] Re: mplayer: symbol lookup error: mplayer: undefined symbol: codec_wav_tags

Iago Laz <email address hidden> writes:

> ii ffmpeg 5:0.5+svn20091116-0.4 audio/video encoder, streaming server & audio/video file converter

from where did you get that package? I guess that libavcodec52 comes
from the same package, which causes the issue you are experiencing..

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Revision history for this message
Iago Laz (iarrovawo) wrote :

iarrovawo@iarrovawo-portatil:~$ apt-cache policy ffmpeg
ffmpeg:
  Instalados: 5:0.5+svn20091116-0.4
  Candidato: 5:0.5+svn20091116-0.4
  Tabla de versión:
 *** 5:0.5+svn20091116-0.4 0
        500 http://ppa.launchpad.net karmic/main Packages
        100 /var/lib/dpkg/status
     4:0.5+svn20090706-2ubuntu2 0
        500 http://es.archive.ubuntu.com karmic/main Packages

Revision history for this message
Iago Laz (iarrovawo) wrote :

Fixed for me. I remove with ppa-purge (https://launchpad.net/~xorg-edgers/+archive/ppa/+files/ppa-purge_0.2.5_all.deb - sudo ppa-purge ppa:matthaeus123/mrw-gimp-svn) https://launchpad.net/~matthaeus123/+archive/mrw-gimp-svn and then I install mencoder for Ubuntu PPA (sudo apt-get install mencoder=2:1.0~rc3+svn20090426-1ubuntu10).

It works perfect now.

Revision history for this message
larmahunter (charrah) wrote :

I don't think it has anything to do with the nVidia PPA; I fixed it by removing all the other PPAs and reinstalling ffmpeg and mplayer related packages.

Revision history for this message
Benjamin Humphrey (humphreybc) wrote :

I've too got this problem. I had Openshot installed, but removed it completely and it still doesn't work. I tried reinstalling many times, and reinstalling the ffmpeg and gstreamer libraries - but no cigar.

Revision history for this message
Jorge Suárez de Lis (ys) wrote : Re: [Bug 461966] Re: mplayer: symbol lookup error: mplayer: undefined symbol: codec_wav_tags

Try using the ppa-purge tool Iago used to purge the openshot ppa.

--
Jorge Suárez de Lis

Revision history for this message
Reinhard Tartler (siretart) wrote : Re: [Bug 461966] Re: mplayer: symbol lookup error: mplayer: undefined symbol: codec_wav_tags

Jorge Suárez de Lis <email address hidden> writes:

> Try using the ppa-purge tool Iago used to purge the openshot ppa.

'apt-get remove libavutil50' should fix the mess as well.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Revision history for this message
Rafał Cieślak (rafalcieslak256) wrote :

I get this bug every time I run mplayer, but it happens only since I upgraded to 10.04 alpha 1.

Revision history for this message
Masiosare (luis-zaldivar) wrote :

I've got this error after upgrade to kde beta compilation 1

http://ppa.launchpad.net/kubuntu-ppa/beta/ubuntu

which installs libavcodec52 version 5.0.5

Revision history for this message
Kamil Páral (kamil.paral) wrote :

I never installed openshot, I don't use nvidia team repos, still I have this problem too. Setting to Confirmed.

Changed in mplayer (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Reinhard Tartler (siretart) wrote :

this is a typical symptom for having an updated ffmpeg package installed. this is *not* a bug in mplayer

Changed in mplayer (Ubuntu):
status: Confirmed → Invalid
description: updated
Revision history for this message
Kamil Páral (kamil.paral) wrote :

Oh, going through my conscience I realized I really had openshot installed some time in the past. After purging all the bit remaining from it in the system the mplayer works again. Sorry for confusions.

Revision history for this message
concord (frank-swflug) wrote :

This started happening to me after I installed OpenShot using packages from their website. I've since used Synaptic to "completely remove" anything with OpenShot in the name (one of the packages was openshot-ffmpeg) and the problem has disappeared.

works fine now

concord@Lenovo-Linux:~/Documents$ for i in *.WMA; do mplayer -vo null -vc dummy -af resample=44100 -ao pcm:waveheader:file="${i%.WMA}.wav" "$i" ; done
MPlayer UNKNOWN-4.4.1 (C) 2000-2009 MPlayer Team

Playing WS500136.WMA.
ASF file format detected.
[asfheader] Audio stream found, -aid 1
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16002->176400)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
[AO PCM] File: WS500136.wav (WAVE)
PCM: Samplerate: 44100Hz Channels: Stereo Format s16le
[AO PCM] Info: Faster dumping is achieved with -vc null -vo null -ao pcm:fast
[AO PCM] Info: To write WAVE files use -ao pcm:waveheader (default).
AO: [pcm] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:2201.7 (36:41.7) of 2201.0 (36:41.0) 0.5%

Exiting... (End of file)
concord@Lenovo-Linux:~/Documents$

Revision history for this message
Jonathan Lumb (jonolumb) wrote :

Iago Laz - thank you so much, your solution worked for me:

sudo ppa-purge ppa:matthaeus123/mrw-gimp-svn

Also - for good measure, I also used the above method to remove the Nvidia Vdpau PPA repository.

Revision history for this message
Nathan (lidzhu) wrote :

I have same problem with mplayer, i try reinstall all stuff for mplayer or somethings. but can't works.
The last way success, when i remove all ppa source list in my sources.list file, apt-get update, then reinstall mplayer and related stuff, it works for me.
hope can help others. :)

libswscale0 install
smplayer-themes install
smplayer-translations install
mplayer install
libpostproc51 install
gstreamer0.10-plugins-bad-multiverse install
mencoder install
libavformat52 install
gstreamer0.10-ffmpeg install
vlc-nox install
ffmpeg install
libavfilter0 install
smplayer install
vlc install
mozilla-mplayer install
libavcodec52 install
libmjpegtools-1.9 install
vlc-plugin-pulse install
libquicktime1 install
mplayer-nogui install
libavdevice52 install

store them in synaptic.txt file and load it from synaptic package manager then click apply button.

Revision history for this message
donn (lazer-wulf) wrote :

(am useing LinuxMint 9.10) had the same problem with ffmpeg + MPlayer not working with DeVeDe, don't know if this will help you guys but after I reinstall MPlayer from:

https://launchpad.net/~rvm/+archive/mplayer

all works now :)

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers