[AO_ALSA] Unable to find simple control 'PCM'

Bug #276957 reported by Khairul Aizat Kamarudzzaman on 2008-10-02
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mplayer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mplayer

MPlayer 1.0rc2-4.3.2 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU T7100 @ 1.80GHz (Family: 6, Model: 15, Stepping: 13)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
xscreensaver_disable: Could not find XScreenSaver window.
GNOME screensaver disabled
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing dvd://1.
There are 9 titles on this DVD.
There are 21 chapters in this DVD title.
There are 1 angles in this DVD title.
audio stream: 0 format: ac3 (5.1) language: en aid: 128.
number of audio channels on disk: 1.
subtitle ( sid ): 0 language: en
subtitle ( sid ): 1 language: es
subtitle ( sid ): 2 language: fr
subtitle ( sid ): 5 language: zh
subtitle ( sid ): 6 language: zh
subtitle ( sid ): 4 language: es
number of subtitles on disk: 6
MPEG-PS file format detected.
VIDEO: MPEG2 720x480 (aspect 3) 29.970 fps 9800.0 kbps (1225.0 kbyte/s)
xscreensaver_disable: Could not find XScreenSaver window.
GNOME screensaver disabled
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 480 (preferred colorspace: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
==========================================================================
Forced audio codec: mad
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
[AO_ALSA] Unable to find simple control 'PCM',0.
Starting playback...
VDec: vo config request - 720 x 480 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 720x480 => 854x480 Planar YV12
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 0 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 1 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 2 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 3 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 3 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 4 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 4 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 4 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 4 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 4 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 4 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 4 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 4 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 4 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 4 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 4 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 4 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 4 0
[AO_ALSA] Unable to find simple control 'PCM',0. ??% ??% ??,?% 4 0
GNOME screensaver enabled

Exiting... (Quit)

Related branches

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu intrepid (development branch)
Release: 8.10
Codename: intrepid

Tim Wright (timw) wrote :

Workaround:
mplayer -ao pulse
i.e. I bet you are running pulseaudio. I'm having way more fun because this machine is *only* hooked up via IEC958 (no analog hookup) and getting that to be the default is an exercise in frustration.

We have this same problem when updating files for Intrepid recently.

It turns out that using raw mplayer works so only gmplayer that has the issue. I temporarily solved it by editing the /usr/share/application/mplayer.desktop file to add in command line option -ao oss as mentioned here:

http://linuxwindows.org/2008/05/ao_alsa-unable-to-find-simple-control-pcm0.html

Brian Parma (bj0) wrote :

I am getting this problem. I have two sound cards and if I switch to pulse or oss, the incorrect soundcard is played, but for some reason alsa plays the correct one. This is why I would prefer to keep using alsa, but every fix for this problem simply says "use pulse" or "use oss".

I didn't have this problem in Hardy, only after upgrading to Ibex, and I don't get this problem in vlc, only in gmplayer.

Also, I don't get this problem if I sudo gmplayer. As root, everything works fine. Could it be a simple permission problem?

Bharat Varma (nbharatvarma) wrote :

I have an Audigy2 ZS card and an onboard VIA soundcard which is disabled at the BIOS. I didn't get this problem in Hardy either, but got it in Intrepid. My speakers are Z5500 from Logitech. AC3 passthrough is very important for me and MPlayer has been the only player that really does a good job in my case.

This is how I got things working with MPlayer with Intrepid. Pulseaudio configuration was somehow causing this issue.

1. ps -ef | grep pulseaudio and kill the processes
2. take a backup of /etc/X11/Xsession.d/70pulsexxxxx file and delete it from Xsession.d
3. sudo apt-get remove pulseaudio and then sudo apt-get install esound (this is very important. if esound is not installed, you may not be able to log on again)
4. System > Preferences > Sessions and disable + remove Pulse audio related service
5. System > Preferences > Sound - select ALSA devices all over. Test to make sure you get sounds
6. restart machine / log out and check that you can log in just fine. Hopefully you will be able to hear the Ubuntu startup sounds now.
7. Mplayer > Preferences > Audio - select ALSA (it is pulse by default)
8. In codecs, Audio family, select AC3 Passthrough.

This instructions have let us get things working as they were in Hardy. Any issues you have with VLC or any other player should also get sorted with this.

neogen22 (neogen556) wrote :

Bharat, I have the Z5500 too, on an ACER laptop, with HDA Intel Audio chipset, and AC3 passthrough worked like a charm with 8.04. I followed the steps, up to 5, where I can't get any sound from ALSA in any case. Only OSS seems to work. What's worse, 'aplay l' only sees one card, analog, and the digital is nowhere to be seen, where in 8.04 there were two devices!! So, I guess no SPDIF sound any time soon.
I installed the latest ALSA driver (1.0.18a) but nothing changed. This is really frustrating
No tricks with the alsa-base file worked either, the line "options snd-hda-intel model=acer" was already there.

So, what is so dramatically different about sound handling in the new version? In every new version I tend to take things that worked for granted.

J. Kary (jkary-98) on 2008-12-12
Changed in mplayer:
status: New → Confirmed
Jeffrey Borck (jborck) wrote :

This bug has to do with properly configuring ALSA in the /etc/mplayer/mplayer.conf file. An easy work-around for some computers is to use the setting:

ao = pulse

in the "Audio Settings" portion of the conf file.

MaksimKa (netvin) wrote :

Same problem here, Creative Live 5.1. Mplayer using ALSA driver for sound output

MaksimKa (netvin) wrote :

I solved this problem with choosing Master Mixer channel in ALSA driver properties

Chris Yereaztian (chrisooo) wrote :

I solved the problem by selecting "Enable Software Mixer" under the audio tab in Mplayer preferences. That solved the problem for me.

Reinhard Tartler (siretart) wrote :

Khariul, do the last few comments help on your machine as well?

Changed in mplayer (Ubuntu):
status: Confirmed → Incomplete
htaccess (linux-gamma) wrote :

After installing mplayer on 9.04 and trying to watch a movie I was geting this error message flashing continiously, I solved the problem by going to preferences, audio and changing it from "alsa" to "pulse".

Perhaps, given 9.04 is using pulse audio and that's the setting that makes mplayer behave, the default sound driver in mplayer in 9.04 should be changed to pulse??

htaccess <email address hidden> writes:

> Perhaps, given 9.04 is using pulse audio and that's the setting that
> makes mplayer behave, the default sound driver in mplayer in 9.04 should
> be changed to pulse??

that seems to me a good suggestion.

Let's either file a new bug on that or rename this one appropriately.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mplayer - 2:1.0~rc3+svn20090426-1ubuntu8

---------------
mplayer (2:1.0~rc3+svn20090426-1ubuntu8) karmic; urgency=low

  * build depend on nvidia-185-libvdpau-dev only on i386 and amd64
  * add ubuntu specific configuration file. LP: #276957, #440343

 -- Reinhard Tartler <email address hidden> Sat, 03 Oct 2009 10:45:23 +0200

Changed in mplayer (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers