mpg123 and mpg321 won't play audio preview in Nautilus (Gutsy)

Bug #125739 reported by NoahY on 2007-07-13
70
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-plugins (Ubuntu)
Undecided
Unassigned
mpg123 (Baltix)
Undecided
Unassigned
mpg321 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mpg321

The mouseover was working in Feisty, but when I upgraded to Gutsy, it stopped, and will not work either with mpg321 or mpg123 installed (or both)

Using mpg321, the terminal output when mouseover on an mp3 file:

Creating link /root/.kde/socket-yuttadhammo-laptop.
can't create mcop directory

Using mpg123, the terminal output is:

[../../../src/audio_oss.c:188] error: Can't open default sound device!
audio: No such file or directory
[../../../src/audio.c:269] error: Unable to set up output device! Constraints: 44100, 22050 or 11025Hz.

Audio device: <none>
Audio capabilities:
(matrix of [S]tereo or [M]ono support for sample format and rate in Hz)
        | s16 | u16 | u8 | s8 | ulaw | alaw |
 --------------------------------------------------------
  8000 | | | | | | |
 11025 | | | | | | |
 12000 | | | | | | |
 16000 | | | | | | |
 22050 | | | | | | |
 24000 | | | | | | |
 32000 | | | | | | |
 44100 | | | | | | |
 48000 | | | | | | |

Michael Stempin (mstempin) wrote :

Same Problem here with a up to date Ubuntu Gutsy (Sept. 3rd 2007).

That feature has got to come back.
It's so useful and I (and also my girlfriend) have gotten really used to it.

It would be highly appreciated if that could be fixed.

If you need any more information or any logs, just let me know.

Keep up the awesomeness of Ubuntu,

Michael

I managed to solve both those issues and mpg321 and mpg123 both work perfectly in the command line. But it still doesn't work on mouse-over.

Solved the bug.

You need to install esound from the repositories.

Stephen (sawjew) wrote :

same issue here, no audio preview and I think this is related to the lack of login/logout sounds. All the system sounds seem to rely on esound which is no longer installed by default. I think this is a fairly important bug as it appears to be system wide. I understand that esound is being phased out but if the replacement system is not ready by release date then I think esound needs to remain in a default install so that everything "just works".

Or else install pulseaudio-esound-compat from the repositories. That worked for me, at least.

webulator70 (webulator70) wrote :

Ok, ive almost found out exactly whats going on here and what needs to be done to fix this bug for the most part.

On a clean feisty install, I hovered over audio files and they did not play, BUT they do show a bubble, they worked after I installed mpg321 for .mp3, sox for .wav and vorbis-tools + sox for ogg files, (yes .ogg does need both vorbis-tool and sox to work on mouse-over.)

note: to anyone trying this, please go to nautilus, edit, preferences, then in the preview tab, set "preview sound files" to "always" or most long audio files like mp3s wont play on mouse-over.

Now enter gutsy problem, I did a fresh format for gutsy, still no sound previews like on feisty's default install but there is one big difference here, there is also no bubble popup on audio files on mouse-over. This is significant because if I install all those packages as mentioned above to play audio previews, it still doesnt play them because there seems to be nothing kicking in the preview mechanism at all, (no bubble no sound.) I then installed pulseaudio and pulseaudio-esound-compat just like jean azzopardi said to.... it works if you have both the files from above AND pulse installed.

Here is the real kicker that gave the problem away though. I purge uninstalled pulseaudio and pulseaudio-esound-compat but the sound previewing still works, I was told on #ubunut+1: "if I had to guess; I think that installing it probably creates a symlink somewhere to the necessary libs for nautilus, and uninstalling doesn't delete the symlink."

So basically all that needs to be done is for the devs to fix whatever pulseaudio fixes on its own and include those files from above in the default packages.

Bernd Schubart (sba) wrote :

I have tried that, but for me it does not seem to work. I am running Gutsy with latest updates.

So I first installed mpg123, then pulseaudio, then pulseaudio-esound-compat. I have now the bubble that you mentioned (which was not there before), but no sound output. Did I forget something? Oh, I also enabled "Always" in the Nautilus preview settings, like described.

How can I get the error output?

This should really be fixed because it is (ehm.. was...) a very cool feature.

webulator70 (webulator70) wrote :

Bernd Schubart did you try mpg321 instead of mpg123?

to show the output just type nautilus in the terminal and navigate to where your audio is, when you attempt to play it keep an eye on the terminal window for output.

if nothing else just try installing esound, i had that on here before getting it working too but i removed it.

webulator70 (webulator70) wrote :

After restarting I lost the ability to preview again, once I put both pulseaudio packages back on, it works again, so it appears I was only semi right there.

Keep the pulseaudio packages installed.

After install from the packages:
mpg321
ubuntu-restricted-extras
PulseAudio
PulseAudo-esound-compat
libasounds2-plugins
the mp3 preview works.

Bernd Schubart (sba) wrote :

Okay, that worked for me too.

Changed in mpg321:
status: New → Confirmed
Changed in mpg123:
status: New → Confirmed
Xoby (xoby) wrote :

Same problem but installing :
mpg321
ubuntu-restricted-extras
PulseAudio
PulseAudo-esound-compat
libasounds2-plugins
(or esound)

did not solve the problem : I have the icon change on mouseover but no sound

Martin Sander (forke) wrote :

I don't use gnome, so I have no problem with that mouseover stuff, yet I want to use mpg123 on the command line, and it failed with:

  Creating link /home/me/.kde/socket-mymachine.
  can't create mcop directory

So I found this bugreport here.
It seems that mpg123 wants to use arts, but since upgrade to gutsy my system starts oss instead.
Using
  $ mpg123 -o oss foo.mp3

Setting an alias would not work for frontends like cplay, but this workaround does:

  $ echo 'default_driver=oss' >> ~/.libao

See libao.conf (5).

Cam Cope (ccope) wrote :

Ok, I've found a fix similar to Martin Sander's.

In order to get everything working, I installed:
mpg321
ubuntu-restricted-extras
PulseAudio
PulseAudo-esound-compat
libasounds2-plugins

I then ran:
  $ echo 'default_driver=esd' >> ~/.libao
and restarted nautilus. I haven't checked if all those packages are necessary though.

MyR (myr-jedi) wrote :

the above solution did not work for me

ex-xp64 (ex-xp64) wrote :

My solution:

mpg123-esd
PulseAudo-esound-compat

But then I had to change the audio output prefs in media player (audacious and amarok) from Alsa to pulseaudio for normal playback.

MyR (myr-jedi) wrote :

Yay, finally working now!

Thank you ex-xp64!!!

C. Reis (reic) wrote :

My nautilus crashes upon opening a folder that contains audio files when the audio preview is activated. As I tried the above mentioned solution (mpg321 ubuntu-restricted-extras PulseAudio PulseAudo-esound-compat), GNOME crashed. After a reboot I could login with the xclient - script, and though the line in sound from my analog tv card kept playing (without having an tv - application running, of course), I could browse folders with audio files without a problem and I got my audio preview (hooray).
I now removed the pulseaudio packages and I could get GNOME back working. Nautilus runs fine when the audio preview is turned off.
Any further suggestions?

bojo42 (bojo42) wrote :

To summarize from http://ubuntuforums.org/showthread.php?p=3668053:

You need "esound" for generell preview capability in Nautilus.

"mpg123-esd" or "mpg321" for mp3 support (although the first has less cpu-usage)

"vorbis-tools" for ogg vorbis support

"sox" for wav support (aiff, voc, snd, au, gsm should also work, but i didn't test them)

Cheers

Kirk Bridger (kbridger) wrote :

It seems like PulseAudio-esound-compat is the fix here, as it resolved the problem for me. I haven't been brave enough to reboot or log out yet, as I'm afraid that my entire sound subsystem is going to be borked by installing this ... but at least I have the audio preview back!

lanzen (lanzen) wrote :

After a bit of struggling, and a reboot, I managed to have the preview working for wav and mp3, but no ogg at all and I _do_ have vorbis-tools installed.

Sander Smid (s-smid) wrote :

I installed esound mpg321 mpg123 and vorbis-tools and working like a charm after a nautilus restart (killall -HUP nautilus)

lanzen (lanzen) wrote :

Now it's working. Strange, I didn't do anything new except a 'killall -HUP nautilus' as Sander said. Last time, days ago, I just did 'killalll nautilus' and ogg was not working. Where do those HUP option come from; I didn't see them with 'killall --help'.
Or maybe it needed rebooting.

Anyway,it works fine now. Thank you all!

Fabrizio Pisani (fabry) wrote :

For we it worked installing the following packets:

mpg321
ubuntu-restricted-extras
libasounds2-plugins
esound
mpg123-alsa
mpg123-esd

After a nautilus restart the problem disappeared.
I didn't install Pulseaudio, I installed it in an other system and it messed up audio in applications such as xmms and skype.
I agree with jean Azzopardi that esaound is the key to fix this issue.

Dragomir Minkovski (dejuren) wrote :

I'm looking just to get mpg123 to work from command line in Kubuntu Gutsy, installation of esound & mpg123-esd do the job. Removing esound left me without error message, but no sound too.

Martin Sander (forke) wrote :

As I wrote earlier:

$ echo 'default_driver=oss' >> ~/.libao

See libao.conf (5).

If /etc/libao.conf exists on your system that might be your problem. See my above post.

I can confirm that audio preview in Nautilus has been fixed in Hardy Alpha. Ogg works out of the box, and mp3 works correctly as soon as the correct codecs have been installed. I recommend marking this as fixed committed.

Sander Smid (s-smid) wrote :

Weird.. I just noticed that sound previews stopped working. I see the icon when I move my mouse over an mp3 / ogg file..
I don't want to install Pulseaudio since F43RY noticed it may cause other problems.. any suggestions?

Daniel T Chen (crimsun) wrote :

Installing mpg123 or mpg321 allows mp3 previews to work in Nautilus due to alsa-plugins's hook in 8.10 beta.

Changed in mpg321:
status: Confirmed → Invalid
Changed in mpg123:
status: Confirmed → Fix Released
MyR (myr-jedi) on 2009-04-06
Changed in mpg123 (Baltix):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions