Ubuntu

Wrong declaration of strcasestr() in mpeg4ip.h

Reported by Urs Fleisch on 2009-10-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mpeg4ip (Ubuntu)
Undecided
Unassigned

Bug Description

The declaration of strcasestr() in /usr/include/mpeg4ip.h is wrong in Ubuntu 9.10, thus the library is not usable in Ubuntu Karmic.

Reproduction (one line of code typed in via stdin, terminated by Ctrl-D):
$ g++ -x c++ -
#include <mp4.h>
In file included from /usr/include/mp4.h:35,
                 from <stdin>:1:
/usr/include/mpeg4ip.h:126: error: new declaration ‘char* strcasestr(const char*, const char*)’
/usr/include/string.h:367: error: ambiguates old declaration ‘const char* strcasestr(const char*, const char*)’

Fix:
Just omit the wrong declaration, strcasestr() is declared in string.h, which is included by mpeg4ip.h.

--- mpeg4ip-1.6dfsg.orig/include/mpeg4ip.h 2009-10-06 14:51:41.381661458 +0200
+++ mpeg4ip-1.6dfsg/include/mpeg4ip.h 2009-10-06 15:08:24.045607069 +0200
@@ -123,7 +123,6 @@
 #ifdef __cplusplus
 extern "C" {
 #endif
-char *strcasestr(const char *haystack, const char *needle);
 #ifdef __cplusplus
 }
 #endif

Related branches

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mpeg4ip - 1:1.6dfsg-0.2ubuntu5

---------------
mpeg4ip (1:1.6dfsg-0.2ubuntu5) karmic; urgency=low

  * debian/patches/08_strcasestr.dpatch: Fix FTBFS due to strcasestr
   declaration (LP: #444555). Patch by Urs Fleisch.

 -- John Dong <email address hidden> Tue, 06 Oct 2009 11:24:26 -0400

Changed in mpeg4ip (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers