Ubuntu

cdtext_init symbol both imported from libcdio10 and libcue1

Reported by Matthias Klose on 2010-09-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libmpd (Debian)
Invalid
Undecided
Unassigned
mpd (Debian)
Fix Released
Unknown
mpd (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: libmpd

from the debian report:

libcue has the internal symbol cdtext_init(), which is also provided
by libcdio10 (/usr/lib/libcdio.so.10.0.0). MPD is linked with both
libraries (libcdio10 is indirectly linked via libiso9660-7). On my
machine, MPD crashes every time I try to load a CUE sheet, because
libcue's cd_init() calls libcdio's cdtext_init(), instead of its own
one (ABI mismatch).

Matthias Klose (doko) on 2010-09-22
Changed in libmpd (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Matthias Klose (doko) wrote :

mpd, not libmpd

affects: libmpd (Ubuntu) → mpd (Ubuntu)
Changed in libmpd (Debian):
status: Unknown → Fix Released
Changed in mpd (Debian):
status: Unknown → Fix Released
Logan Rosen (logan) on 2013-05-10
Changed in libmpd (Debian):
importance: Unknown → Undecided
status: Fix Released → New
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.