Ubuntu

mozvoikko makes Firefox 6 crash

Reported by Martin-Éric Racine on 2011-08-24
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
libvoikko (Ubuntu)
Medium
Unassigned
Natty
Medium
Micah Gersten
Oneiric
Medium
Unassigned
mozvoikko (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

TEST CASE:

1. Open http://www.w3schools.com/html/showit.asp?filename=tryhtml_textarea in one tab
2. Copy contents of the page http://wiki.ubuntu-fi.org/Etusivu?action=raw to clipboard
3. Enable spellchecking and choose Finnish as the language
4. Paste the contents to the text field

RESULT:
Crash of Firefox, without indication that it would be related to spell checking.

EXPECTED RESULT:
No crash.

Original report:

Since the Firefox upgrade to version 6, selecting Finnish (i.e. mozvikko) in the proofreading feature of Firefox crashes the browser in a systematic way.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xul-ext-mozvoikko 1.9.0~svn20101114r3591-0ubuntu3.11.04.2
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic i686
Architecture: i386
Date: Wed Aug 24 11:07:15 2011
ProcEnviron:
 LANGUAGE=fi_FI:fi_FI.UTF-8:fi
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
SourcePackage: mozvoikko
UpgradeStatus: Upgraded to natty on 2009-09-14 (708 days ago)

Martin-Éric Racine (q-funk) wrote :
Chris Coulson (chrisccoulson) wrote :

Thanks, but you need to at least provide a stacktrace or the crash ID of the crash report you submitted to Mozilla. There's not much to go on here

Changed in mozvoikko (Ubuntu):
status: New → Incomplete
Martin-Éric Racine (q-funk) wrote :

I would have thought that 'ubuntu-bug' attaches these traces automatically? Oh well...

Otherwise, how do I go about retreiving the ID of the Mozilla bug that was automatically submitted when the crash took place?

Chris Coulson (chrisccoulson) wrote :

The crash ID will be in about:crashes, but if it is crashing inside an extension then you'll need to get a stacktrace anyway, as crash-stats only has our symbols for firefox

Martin-Éric Racine (q-funk) wrote :

The latest one seems to be c5a37649-800f-48ec-b841-647eb2110823 as far as I can tell.

I can confirm this. FF doesn't crash always, but sometimes when one opens a page containing a textbox (=> Firefox tries to check the spelling in it using Mozvoikko) it crashes.

Crash report: https://crash-stats.mozilla.com/report/index/4d70e202-2737-4eb7-a9a4-0da282110824

I tried to install debug symbols but I can't find xul-ext-mozvoikko-dbgsym for mozvoikko
1.9.0~svn20101114r3591-0ubuntu3.11.04.2 (current version in Natty).

Changed in mozvoikko (Ubuntu):
status: Incomplete → Confirmed
Chris Coulson (chrisccoulson) wrote :

I still can't reproduce this, and so far there isn't a good stacktrace. Heikki, it seems you are on amd64, so I'll give you an unstripped build to test if that's ok?

Ok, I'll test it.

Chris: did I miss something, where should I find the unstripped build?

jykae (ville-jyrkka) wrote :

I doubleconfirm this. It is the hyphen symbol in the form field that crashes the Firefox.

Timo Jyrinki (timo-jyrinki) wrote :

This affects all natty stable release users as well, and should be fixed in Ubuntu 11.04 as well, and probably even Ubuntu 10.04 LTS if it gets newer Firefox before 2013 when it support ends.

Micah Gersten (micahg) wrote :

This should be fixed next week when Firefox 7 + the new mozvoikko get pushed.

Micah Gersten (micahg) wrote :

The update should be staged in ppa:ubuntu-mozilla-security/ppa later this week or you can try ppa:mozillateam/firefox-next now.

Timo Jyrinki (timo-jyrinki) wrote :

Micah: This is not fixed in oneiric either, and the firefox-next packages seem to be simply backports from oneiric to previous Ubuntus without additional changes. This bug does not have a known fix - except that javascript based mozvoikko2 (http://voikko.svn.sourceforge.net/viewvc/voikko/trunk/mozvoikko/ + http://voikko.svn.sourceforge.net/viewvc/voikko/trunk/debian/mozvoikko%2Bdebian/ ) does not have this problem, and also the problem does not exist in eg. Firefox 3.6.

The "-" in text field causing the problem indicated by jykae sounds like a worthy clue.

Timo Jyrinki (timo-jyrinki) wrote :

It's not "-" only that's enough, but for example copy-pasting the contents of the page http://wiki.ubuntu-fi.org/Etusivu?action=raw into any Firefox text field and trying to spell-check in Finnish causes Firefox crash. Reported also to upstream mailing list http://lists.puimula.org/listinfo/voikko

Timo Jyrinki (timo-jyrinki) wrote :

Problem solved by upstream also for mozvoikko1, and the problem was found in libvoikko, introduced a year ago (so theoretically should not affect 10.04 LTS).

Changed in libvoikko (Ubuntu):
status: New → Confirmed
Changed in mozvoikko (Ubuntu):
status: Confirmed → Invalid
Timo Jyrinki (timo-jyrinki) wrote :

Patch for oneiric.

Timo Jyrinki (timo-jyrinki) wrote :

Patch for natty.

Ubuntu 10.04 LTS should not be affected even if it were to get FIrefox 6+, but this has not yet been tested. However libvoikko upstream stated that the libvoikko problem would have been introduced in Autumn 2010.

Timo Jyrinki (timo-jyrinki) wrote :

Natty try2 with correct distribution field and tested on natty, uploaded to https://launchpad.net/~timo-jyrinki/+archive/ppa

Timo Jyrinki (timo-jyrinki) wrote :
description: updated
sk (skfin) wrote :

I can confirm that Timo's PPA fixes the problem at least when running Oneiric.

The attachment "debdiff_natty_fix_crasher_when_using_mozvoikko.patch" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
description: updated

I can confirm that Timo's new libvoikko 3.1-1ubuntu1 fixes this bug in Natty.

Micah Gersten (micahg) wrote :

Did this same problem exist at release with Firefox 4, or did this only occur with a later Firefox?

Timo Jyrinki (timo-jyrinki) wrote :

Micah: only in newer Firefoxes, see https://bugzilla.mozilla.org/show_bug.cgi?id=355178 - the word boundary recognization algorithm was changed to spell-check hyphen including words as a whole instead of parts.

The Voikko upstream is now releasing a new version with the same patch as I've included in the bzr:s + PPA + debdiff:s for natty and oneiric. The patched libvoikko is now also in Debian.

Please sponsor these changes into oneiric and (then) natty.

Micah Gersten (micahg) wrote :

@Timo Jyrinki
Thank you for the update. I just needed to know if this should go through natty-security or not, and it seems the answer is yes.

Changed in mozvoikko (Ubuntu Natty):
status: New → Invalid
Changed in libvoikko (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
Changed in libvoikko (Ubuntu Natty):
milestone: none → natty-updates
importance: Undecided → Medium
status: New → In Progress
assignee: nobody → Micah Gersten (micahg)
Changed in libvoikko (Ubuntu Oneiric):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libvoikko - 3.2-1ubuntu1

---------------
libvoikko (3.2-1ubuntu1) oneiric; urgency=low

  * debian/patches/fix_crasher_when_using_mozvoikko.patch:
    - Add patch from upstream to fix a mozvoikko crasher (LP: #832582)
 -- Timo Jyrinki <email address hidden> Mon, 26 Sep 2011 10:24:42 -0400

Changed in libvoikko (Ubuntu Oneiric):
status: Confirmed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

My bzr branches were poor and missed the actual patch (forgot bzr add). I fixed the natty branch now for merging by making similar changes that Michael did for me on the oneiric side.

Timo Jyrinki (timo-jyrinki) wrote :

Micah: any progress on pushing the fix to natty-proposed for testing?

Micah Gersten (micahg) wrote :

Yes, I'll get this uploaded on Monday.

Micah Gersten (micahg) wrote :

I'm ready to upload, but noticed we don't have the source of the patch. Timo, did you write this or is it a cherry pick from upstream? If from upstream, do you have the link to the commit?

Micah Gersten (micahg) wrote :

This has been uploaded to https://launchpad.net/~ubuntu-mozilla-security/+archive/ppa and will build shortly.

Changed in libvoikko (Ubuntu Natty):
status: In Progress → Fix Committed
Micah Gersten (micahg) on 2011-10-19
tags: added: regression-update security-verification verification-needed
Micah Gersten (micahg) on 2011-10-19
tags: added: testcase
Micah Gersten (micahg) wrote :

Tested with the test case on both amd64 and i386 on updated natty systems, crashed before this update, does not crash after the update.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libvoikko - 3.1-1ubuntu0.1

---------------
libvoikko (3.1-1ubuntu0.1) natty-security; urgency=low

  [ Timo Jyrinki ]
  * Add patch from upstream to fix a mozvoikko crasher (LP: #832582); This crash
    was triggered by the Firefox 6 security update
    - See http://lists.puimula.org/pipermail/voikko/2011-September/001624.html
    - add fix_crasher_when_using_mozvoikko.patch
    - add debian/patches/series

  [ Micah Gersten ]
  * Add DEP-3 headers to the new patch
    - update fix_crasher_when_using_mozvoikko.patch
 -- Timo Jyrinki <email address hidden> Fri, 23 Sep 2011 18:00:41 +0300

Changed in libvoikko (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.