missing Conflicts against firefox >=3.6 and needs a rebuilt for Lucid

Bug #513320 reported by Martin-Éric Racine on 2010-01-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mozvoikko (Ubuntu)
High
Heikki Mäntysaari

Bug Description

Binary package hint: mozvoikko

mozvoikko Conflicts with mozilla variants >=3.6 (abrowser, iceweasel - firefox is missing from that list in the control file), because it needs versionned Depends.

 As a result of FF 3.6 replacing FF 3.5 in Lucid since yesterday, mozvoikko must therefore be rebuilt, otherwise, it prevents FF from launching and must be removed as a temporary workaround. Doing this of course completely removes spell checking support for the Finnish language in mozilla products.

since there's already a wishlist bug open to import a newer Debian release, perhaps these two issues ought to be examined and fixed simultaneously.

ProblemType: Bug
Architecture: i386
Date: Wed Jan 27 17:27:57 2010
DistroRelease: Ubuntu 10.04
Package: mozvoikko 1.0-1ubuntu3
ProcEnviron:
 LANGUAGE=fi_FI.UTF-8
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-11.15-generic
SourcePackage: mozvoikko
Uname: Linux 2.6.32-11-generic i686

Martin-Éric Racine (q-funk) wrote :
Micah Gersten (micahg) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as Triaged and let them handle it from here. Thanks for taking the time to make Ubuntu better! Please report any other issues you may find.

Changed in mozvoikko (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → High
milestone: none → lucid-alpha-3
status: New → Triaged

Thanks for your bug report. I updated the Debian package and my sponsor will probably upload it soon (see http://mentors.debian.net/cgi-bin/sponsor-pkglist?action=details;package=mozvoikko).

When the new package is uploaded into Debian I'll make the necessary Ubuntu changes (change abrowser and firefox version numbers) and update the merge request (#493628).

Changed in mozvoikko (Ubuntu):
assignee: Micah Gersten (micahg) → Heikki Mäntysaari (heikki-mantysaari)
Martin-Éric Racine (q-funk) wrote :

Thanks Heikki!

Why not simply add the Conflicts against abrowser and firefox directly to the upstream Debian control file? This would make the maintenance much easier and would allow updating the Ubuntu package simply by requesting an automated sync from Debian.

Btw, Alexander Sack made a few changes to the current Lucid package, most of which could be merged directly into the upsteam Debian package as well.

New version is now in Debian and I have updated the merge requests bug.

I'll see if I can reduce the difference between Ubuntu and Debian packages.

Martin-Éric Racine (q-funk) wrote :

Heikki, do you need any help with this?

Thanks for offering help. However, the updated package is ready and it is waiting for a sponsorship (see #493628).

About merging changes to the Debian package: I think I'll try to merge the changes when upstream releases a new version or I for some other reason have to update the package in Debian.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mozvoikko - 1.0-4ubuntu1

---------------
mozvoikko (1.0-4ubuntu1) lucid; urgency=low

  * Merge changes from Debian (LP: #493628)
  * Change conflict to abrowser (>= 3.7). Closes LP: #513320
  * Add optional dependency to firefox-3.6. (LP: #513320)
 -- Heikki Maentysaari <email address hidden> Mon, 22 Feb 2010 11:07:48 +0100

Changed in mozvoikko (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers