navigation keys not working inside firefox

Bug #439540 reported by PascalC on 2009-09-30
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
mozplugger (Debian)
Confirmed
Unknown
mozplugger (Ubuntu)
Medium
Alessio Treglia
Karmic
Medium
Unassigned

Bug Description

Binary package hint: kdegraphics

open a pdf inside konqueror -> okular is embeded and works well

open a pdf inside firefox olular is embeded but navidations keys ( arrows and page up down) do not work at all ! only the mouse can scroll the document

ii firefox 3.0.14+build2+nobinonly-0ubuntu0.9.04.1 meta package for the popular mozilla web browser
ii firefox-3.0 3.0.14+build2+nobinonly-0ubuntu0.9.04.1 safe and easy web browser from Mozilla
ii firefox-3.0-branding 3.0.14+build2+nobinonly-0ubuntu0.9.04.1 Package that ships the firefox branding

ii libokularcore1 4:4.3.1-0ubuntu1~jaunty1~ppa1 libraries for the Okular document viewer
ii okular 4:4.3.1-0ubuntu1~jaunty1~ppa1 document viewer for KDE 4
ii okular-extra-backends 4:4.3.1-0ubuntu1~jaunty1~ppa1 additional document format support for Okula

ii mozplugger 1.12.0-1ubuntu1 Plugin allowing external viewers to be launched inside Mozilla

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: okular 4:4.3.1-0ubuntu1~jaunty1~ppa1
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 LANGUAGE=fr_FR:fr:en_GB:en
SourcePackage: kdegraphics
Uname: Linux 2.6.28-11-generic i686
UnreportableReason: Ceci n'est pas un authentique paquet Ubuntu

Related branches

PascalC (p92) wrote :
Jonathan Thomas (echidnaman) wrote :

This is a problem with the software you are using to embed Okular in Firefox.

affects: kdegraphics (Ubuntu) → mozplugger (Ubuntu)
Alessio Treglia (quadrispro) wrote :

The issue seems reproducible.

Alessio Treglia (quadrispro) wrote :
Changed in mozplugger (Ubuntu):
status: New → Triaged
Changed in mozplugger (Debian):
status: Unknown → Confirmed
Changed in mozplugger (Ubuntu):
importance: Undecided → Low
importance: Low → Medium
status: Triaged → In Progress
assignee: nobody → Alessio Treglia (quadrispro)
Changed in mozplugger (Ubuntu):
status: In Progress → Fix Committed
Changed in mozplugger (Ubuntu Karmic):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mozplugger - 1.13.3-1ubuntu1

---------------
mozplugger (1.13.3-1ubuntu1) lucid; urgency=low

  * Merge from debian unstable, Ubuntu remaining changes:
    - debian/mozplugger.links:
      + Replace ice{weasel,ape} with firefox,xulrunner-addons.
    - This closes LP: #439540.

mozplugger (1.13.3-1) unstable; urgency=low

  * New upstream release:
    - Fixes upstream bug #22723 (Closes: #519832).
  * Refresh 01-manpages.patch and add more patches.
  * Add README.source to document howto patch the sources.

mozplugger (1.13.2-2) unstable; urgency=low

  * Add xulrunner-1.9.{1,2} support (Closes: #575532).
  * Don't depend on epiphany-browser, see bug #566857.
 -- Alessio Treglia <email address hidden> Sat, 17 Apr 2010 10:47:53 +0200

Changed in mozplugger (Ubuntu):
status: Fix Committed → Fix Released
Changed in mozplugger (Debian):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mozplugger (Ubuntu Karmic):
status: New → Confirmed
linux-man (caldas-lopes) wrote :

Same problem on precise 64 with Evince 3.3.90, FIrefox 11.0, Mozplugger 1.14.3-7.

Oliver R. (oliverr) wrote :

Bug is still present in Precise. And it seems related to bug #343182.

uglyoldbob (thomas-epperson) wrote :

I have mozplugger 1.143-7 and I still experience the bug with okular 4.8.5 and firefox 17.0.1

cristian (cristiancozzolino) wrote :

I confirm this bug in Precise 12.04.4 using MozPlugger 1.14.3 (I've tried with Chromium and Opera).

Rolf Leggewie (r0lf) wrote :

karmic has seen the end of its life and is no longer receiving any updates. Marking the karmic task for this ticket as "Won't Fix".

Changed in mozplugger (Ubuntu Karmic):
status: Confirmed → Won't Fix
Changed in mozplugger (Debian):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.