evince cannot open files when embedded with mozplugger in Gutsy

Bug #145064 reported by Stephen on 2007-09-26
48
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evince
Unknown
Medium
mozplugger (Ubuntu)
Undecided
Unassigned
Declined for Gutsy by Henrik Nilsen Omma

Bug Description

Binary package hint: mozplugger

When using evince embedded in firefox with mozplugger I cannot open any postscript or pdf files. Evince opens in a new tab but just displays "loading" but does not finish loading. If I change tabs and then come back the evince window has changed to a uniform colour with no definition. Evince works fine to open documents as a standalone app so it may be a mozplugger issue. I am using Ubuntu Gutsy 64bit on Intel core2 duo.

Philipp Sieweck (psieweck) wrote :

Same here. But here is a quick fix (but its not a solution):

1. before opening the pdf, open the searbar with Strg+F
2. open the pdf. You'll see, that nothing gets loaded.
3. Close the searchbar. And -- oh wonder -- the pdf is there :/

Changed in mozplugger:
status: New → Confirmed
Guido Conaldi (guido-conaldi) wrote :

I'm having the same issue with mozplugger and epiphany on gutsy x86_64. When clicking on a link to a .pdf file, epiphany's window either freezes saying "loading..." or the .pdf is loaded in a broken window that cannot be resized.

Andy Pascall (apascall) wrote :

On the advice of a post in http://ubuntuforums.org/showthread.php?t=584917&page=2 , I deleted ~/.gnome2/evince.

This allowed me to open PDFs with evince in firefox. However, most PDFs only open in about a quarter of the browser window while a few open in the full window.

A reload of the document allows all (so far) PDFs to be opened in the full window.

Andy Pascall (apascall) wrote :

An update on my previous report.

Deleting ~/.gnome2/evince is only a temporary fix to the bug. The bug resurfaces after a few hours.

Deleting ~/.gnome2/evince again will then allow PDFs to open.

Elliot Winkler (elliot-winkler) wrote :

So this is a problem with Evince, not with mozplugger?

I guess it is a bug of Evince, since the same problem arises with Epiphany. Anyway a decent temporary solution is to resize Firefox: this makes the pdf show up.

Alvise Trevisan (vvvsan) wrote :

Just a comment: if you re-open the same pdf after you have used one of the two tricks above (resizing or Ctrl+F), you can see it immediately.

Andy Pascall (apascall) wrote :

If you open multiple PDFs in separate tabs, the resize trick will work for the first PDF you view, but not subsequent ones.

Brendan Cully (bcully) wrote :

Subscribing to this report (me too)

Don Cristóbal (doncristobal) wrote :

I can confirm the multi tab comment by Andy Pascall.

Sometimes there is also just a big white nothing, instead of evince displaying the pdf.

(xubuntu 7.10/gutsy, firefox 2.0.0.8, mozplugger 1.8.0-3ubuntu1)

Henrik Nilsen Omma (henrik) wrote :

This bug was nominated for Gutsy but does currently not qualify for a 7.10 stable release update (SRU) and the nomination is therefore declined. According the the SRU policy, the fix should already be deployed and tested in the current development version before an update to the stable releases will be considered. With 7.10 now released, that policy applies to this bug. See: https://wiki.ubuntu.com/StableReleaseUpdates

Changed in evince:
status: Unknown → New

Another work around is to just edit the mozpluggerrc to stop embedding evince.

Replace:
 repeat noisy swallow(evince) fill: evince "$file"
with:
 nokill: evince "$file"

Thomas M. Hinkle wrote:
> Another work around is to just edit the mozpluggerrc to stop embedding
> evince.
>
> Replace:
> repeat noisy swallow(evince) fill: evince "$file"
> with:
> nokill: evince "$file"
>
>
Try this:
1.) Remove the Ubuntu mozplugger package.
2.) Go to http://mozplugger.mozdev.org/ and download Version 1.10.1 source.
3.) Move it to /usr/src and extract it.
4.) sudo make install.

Guido Conaldi (guido-conaldi) wrote :

Thank you geschoss, using mozplugger 1.10.1 on my gutsy amd64 and .pdf are loaded correcly in epyphany.

It would be great to have mozplugger updated in hardy.

Andy Pascall (apascall) wrote :

I can confirm that mozplugger 1.10.1 fixes this bug on i386. However, I had a bit of trouble installing it. See bug report on mozplugger's site: https://www.mozdev.org/bugs/show_bug.cgi?id=18569

geschoss (geschoss) wrote :

Depending on what browser you are using, you may have to link mozplugger.so in /usr/lib/mozilla/plugins to your browser plugins directory. For firefox:

  cd /usr/lib/firefox/plugins
  sudo ln -s /usr/lib/mozilla/plugins/mozplugger.so

  geschoss

Andy Pascall <email address hidden> wrote:
  I can confirm that mozplugger 1.10.1 fixes this bug on i386. However, I
had a bit of trouble installing it. See bug report on mozplugger's site:
https://www.mozdev.org/bugs/show_bug.cgi?id=18569

--
evince cannot open files when embedded with mozplugger in Gutsy
https://bugs.launchpad.net/bugs/145064
You received this bug notification because you are a direct subscriber
of a duplicate bug.

Jeff Fortin Tam (kiddo) wrote :

isn't this gone in hardy?

Stephen (sawjew) wrote :

This is no longer an issue with Hardy.

Changed in evince:
status: New → Invalid
Alessio Treglia (quadrispro) wrote :

Cannot reproduce on Lucid.

Changed in mozplugger (Ubuntu):
status: Confirmed → Fix Released
geschoss (geschoss) wrote :

Apparently is fixed in Lucid.

--- On Thu, 4/15/10, Alessio Treglia <email address hidden> wrote:

From: Alessio Treglia <email address hidden>
Subject: [Bug 145064] Re: evince cannot open files when embedded with mozplugger in Gutsy
To: <email address hidden>
Date: Thursday, April 15, 2010, 12:18 PM

Cannot reproduce on Lucid.

** Changed in: mozplugger (Ubuntu)
       Status: Confirmed => Fix Released

--
evince cannot open files when embedded with mozplugger in Gutsy
https://bugs.launchpad.net/bugs/145064
You received this bug notification because you are a direct subscriber
of a duplicate bug.

Changed in evince:
importance: Unknown → Medium
status: Invalid → Unknown
Paul Garlick (pgarlick) wrote :

This bug has reappeared in Maverick.

In Epiphany, when a pdf file is opened a blank grey window is shown with the outline of the evince viewer. Re-sizing the window or Edit->Find (CTRL-F) displays the pdf file.

The package versions on my system are as follows:

epiphany-browser 2.30.2-1ubuntu7

evince 2.32.0-0ubuntu1.1

mozplugger 1.14.1-2~exp3ubuntu1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.