Added Menu Item shows up in editor, not in Menu

Bug #1800585 reported by Robert Pearson on 2018-10-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned
mozo (Ubuntu)
Undecided
Unassigned

Bug Description

I started mozo by Control Center->Main Menu.
Under Programming I added a new item. Type Application Name: VisualWorks Command: $VISUALWORKS/bin/linuxx86_64/vwlinuxx86_64 "$VWPROJECTS/launchpad64.im" with the default icon.

When I entered the command in a terminal window it launched correctly.

Closed the properties. Closed mojo. When I tried to use the Menu, the new item was not there. When I started mozo again, it showed the item with the correct values. Mojo just did not update the menu.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: mozo 1.20.0-1
ProcVersionSignature: Ubuntu 4.15.0-38.41-generic 4.15.18
Uname: Linux 4.15.0-38-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
CurrentDesktop: MATE
Date: Tue Oct 30 00:04:55 2018
ExecutablePath: /usr/bin/mozo
InstallationDate: Installed on 2018-10-25 (5 days ago)
InstallationMedia: Ubuntu-MATE 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcEnviron:
 XDG_RUNTIME_DIR=<set>
 SHELL=/bin/bash
 LANGUAGE=en_US
 PATH=(custom, no user)
 LANG=en_US.UTF-8
Python3Details: /usr/bin/python3.6, Python 3.6.6, python3-minimal, 3.6.5-3ubuntu1
PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 2.7.15~rc1-1
SourcePackage: mozo
UpgradeStatus: No upgrade log present (probably fresh install)

Robert Pearson (rpearsonii) wrote :
APolihron (apolitech) wrote :

In 18.10 i don't have this problem. What if you will change the "Type" in the launcher properties to "Application in terminal" (if the app wont't start from the menu)
About the problem of not finding the new menu entry this will persists after a reboot\restart?

Robert Pearson (rpearsonii) wrote :

Dear APolihron,

Yes this error persists after a complete shutdown and restart. When I choose Control Center->Main Menu the.

Under Menus: I select programming and the application (VisualWorks) appears.
When I select its properties I see the command:
$VISUALWORKS/bin/linuxx86_64/vwlinuxx86_64 "$VWPROJECTS/launchpad64.im"

When I try to select VisualWorks from Menu->Programming, its not there. I tried moving it up. It still is not there.

I tried to create a launcher on the desktop. Linux created a launcher with the correct command - it just does not work. I copied the launcher to the top bar next to the FireFox icon. I checked the command. It still did not work! I tried editing the Main Menu and selected "Application in terminal" as you suggested. It still does not appear. I tried unchecking "Show" exiting mozo and then restarting mozo and re-checking the "Show" check box

I opened a Terminal window and entered the command and the program started up correctly. It still is not available in the Menu, not in Programming nor in All.

Mozo apparently edits the data used by Ubuntu MATE for the Menu properly. Ubuntu MATE just does not display the contents correctly.

Robert Pearson

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers