mozilla-mailnews can't be installed because of unmet dependencies

Bug #24244 reported by Christoph Bier on 2005-10-19
4
Affects Status Importance Assigned to Milestone
mozilla (Ubuntu)
High
Unassigned

Bug Description

Upgrading from Hoary to Breezy removed Mozilla and some of its components. After
finishing upgrade I just wanted to install mozilla-mailnews again
(mozilla-browser was automatically installed again during the upgrade) but it
fails. Here's the output:

chris@skull:~$ LANG=C sudo apt-get install mozilla-mailnews
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  mozilla-mailnews: Depends: mozilla-browser (= 2:1.7.12-0ubuntu2)
but 2:1.7.12-1ubuntu1 is to be installed
E: Broken packages

There is no mozilla-browser in version 1.7.12-0ubuntu2 in the respositories.

Christoph Bier (christoph-bier) wrote :

(In reply to comment #0)
> Upgrading from Hoary to Breezy removed Mozilla and some of its components. After
> finishing upgrade I just wanted to install mozilla-mailnews again
> (mozilla-browser was automatically installed again during the upgrade) but it
> fails. Here's the output:
>
> chris@skull:~$ LANG=C sudo apt-get install mozilla-mailnews
> Reading package lists... Done
> Building dependency tree... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
>
> Since you only requested a single operation it is extremely likely that
> the package is simply not installable and a bug report against
> that package should be filed.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
> mozilla-mailnews: Depends: mozilla-browser (= 2:1.7.12-0ubuntu2)
> but 2:1.7.12-1ubuntu1 is to be installed
> E: Broken packages
>
> There is no mozilla-browser in version 1.7.12-0ubuntu2 in the respositories.

Sorry, bug was filed before I was finished because I hit return after choosing a
package.

OS is Linux, of course, severity is major, IMHO.

I have all respositories (main restricted universe multiverse) in sources.list.

Best regards,
Christoph

Adam Conrad (adconrad) wrote :

Looks like you have "universe" enabled for "breezy", but only have "main"
enabled for "breezy-updates". This means your mozilla-browser (from
breezy-updates/main) and mozilla-mailnews (from breezy/universe) are out of
sync. Enable the bit in sources.list to get breezy-updates for universe and you
should be on your merry way.

Christoph Bier (christoph-bier) wrote :

(In reply to comment #2)
> Looks like you have "universe" enabled for "breezy", but only have "main"
> enabled for "breezy-updates". This means your mozilla-browser (from
> breezy-updates/main) and mozilla-mailnews (from breezy/universe) are out of
> sync. Enable the bit in sources.list to get breezy-updates for universe and you
> should be on your merry way.

That's it! Thank you very much and sorry for the noise! My mistake.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.