Ubuntu

Thunderbird stalls while sound is suspended

Reported by Broomer68 on 2008-03-17
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mozilla-thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mozilla-thunderbird

When the (pulse-)audio is suspended by some program (for instance MusiScore, who accesses the soundsystem directly), not only the sound is suspended, but thunderbird (and firefox) stalls untill the sound is produced (this happens after the suspending program releases the sound system) then thunderbird gets reactive again and all is well...

This using the current (and earlier) versions of 8.04, all updates applied.

system sounds are suspended as well, but the system does not stall.

Ralph Wabel (rwabel) wrote :

Are you using pulseaudio?
If yes try to stop pulseaudio and start it again, worked for me
pulseaudio -k
pulseaudio -D

If Thunderbird tries to fetch a mail, before I did this, it also freezes as it uses sound alert when a mail is received. Either disable this or try to restart pulseaudio after suspend

Id2ndR (id2ndr) wrote :

A workaround is to redirect thunderbird sound to pulseaudio with the command $ padsp thunderbird

Changed in mozilla-thunderbird:
status: New → Confirmed
Fabio Marzocca (thesaltydog) wrote :

On Intrepid, thunderbird 2.0.0.17, there is no way to let it play a
sound when a new email is received, neither by setting a specific .wav
file, nor by let it use the deafult sound system event.

Thunderbird notification plays only if I kill pulseaudio. But with pulseaudio running, all my sounds are OK, but thunderbird.

Przemysław Kulczycki (azrael) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner.
There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test the current Ubuntu development version (10.04). If you can test it, and it is still an issue, we would appreciate if you could upload updated logs by running apport-collect 203352, and any other logs that are relevant for this particular issue.

Changed in mozilla-thunderbird (Ubuntu):
status: Confirmed → Incomplete
Przemysław Kulczycki (azrael) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future.
To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".
If you decide to reopen this bug, it would help us a lot if you could test the current Ubuntu development version (10.10) and check if this bug is still relevant.
Thanks again!

Changed in mozilla-thunderbird (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers