Add pt-BR translation

Bug #65223 reported by Evandro Fernandes Giovanini on 2006-10-11
6
Affects Status Importance Assigned to Milestone
mozilla-firefox-locale-all (Ubuntu)
Wishlist
Martin Pitt

Bug Description

Binary package hint: mozilla-firefox-locale-pt-br

evandro@ubuntu:~$ dpkg -L mozilla-firefox-locale-pt-br
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/mozilla-firefox-locale-pt-br
/usr/share/doc/mozilla-firefox-locale-pt-br/copyright
/usr/share/doc/mozilla-firefox-locale-pt-br/changelog.Debian.gz
evandro@ubuntu:~$ dpkg -l | grep mozilla-firefox-locale-pt-br
ii mozilla-firefox-locale-pt-br 2.0~beta2-3 Transitional package for unavailable languag
evandro@ubuntu:~$

Firefox appears in English (I don't have the pt_PT translation installed).

Martin Pitt (pitti) wrote :

As the package description says, there is no pt-BR translation available from Mozilla. If you use language-support-pt, then you'll automatically get the pt-PT one.

Changed in mozilla-firefox-locale-all:
status: Unconfirmed → Rejected

The binaries released by mozilla.org have a pt-BR translation:
http://www.mozilla.org/projects/bonecho/all-rc.html

Would it be possible to update this before the Edgy release?

Martin Pitt (pitti) wrote :

Ah, nice that they finally added it again. Too bad that it is too late for Edgy, but I'll add it to Edgy+1 early.

Changed in mozilla-firefox-locale-all:
assignee: nobody → pitti
importance: Undecided → Wishlist
status: Rejected → In Progress
Jonh Wendell (wendell) wrote :

You mean that edgy will be released without pt_BR translation?
I can't believe. Ubuntu can't do this with Brazilian users

Martin Pitt (pitti) wrote :

OK, since we want 2.0rc3 in edgy, we need to update the translations again anyway, so we can as well put pt-BR back and make the Brazilian guys happy again. :)

Martin Pitt (pitti) wrote :

Prepared for upload, has to wait until after RC release.

Changed in mozilla-firefox-locale-all:
status: In Progress → Fix Committed
Jonh Wendell (wendell) wrote :

What's a good news! Thank you. I'm waiting this update.

Jonh Wendell (wendell) wrote :

Martin, i don't know if what i will write now is related to this bug:

Can the Firefox default start page point to /usr/share/ubuntu-artwork/home/locales-ubuntu/index-pt_BR.html instead of /usr/share/ubuntu-artwork/home/index.html ?

Thank you.

Jonh Wendell (wendell) wrote :

Hi, Pitt.

I just figure out how to make my wish become true.
In the language pack, you need to edit locale/browser-region/region.properties file (inside pt-BR.jar) and add the following line at the end of it:

browser.startup.homepage=file:///usr/share/ubuntu-artwork/home/locales-ubuntu/index-pt_BR.html

Can you check out this?

Thanks,
 Wendell.

Martin Pitt (pitti) wrote :

 mozilla-firefox-locale-all (2.0~rc3-1) edgy; urgency=low
 .
   * Update XPIs for Firefox 2.0 RC3.
   * Use 2.0RC2 version for Japanese translation, the 2.0RC3 one is busted.
   * ga-IE and pt-BR are available again, remove these from debian/unavail.txt.
     Closes: LP#65223
   * Remove debian/patches/cs-CZ.diff: Fixed upstream.
   * debian/patches/en-GB.diff: Updated to work for new upstream version.
   * Add debian/patches/fy-NL.diff: Fix broken install.rdf.

Changed in mozilla-firefox-locale-all:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers