Please merge mozc 1.1.773.102-1 (multiverse) from Debian unstable (non-free)

Bug #811892 reported by Nobuto Murata on 2011-07-17
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mozc (Ubuntu)
Wishlist
Unassigned

Bug Description

Please merge mozc 1.1.773.102-1 (multiverse) from Debian unstable (non-free)

Changelog entries of Debian since current oneiric version 1.1.717.102-1:

mozc (1.1.773.102-1) unstable; urgency=low

  * New upstream release (r58).

 -- Nobuhiro Iwamatsu <email address hidden> Fri, 22 Jul 2011 08:19:04 +0900

mozc (1.1.758.102-1) unstable; urgency=low

  * New upstream release (r57) (Closes: #633007).
  * Remove mozc-el-issue76.patch. Applied to upstream.
  * Update patches/support-kfreebsd.patch.
    Support build with libzinnia.
  * Update debian/rules.
    Add path of build directory.
  * Add patches/fix_scim-mozc_cannot_type_char.patch.
    This fix scim-mozc cannot type char.
    issue 88:scim-mozc cannot type "ぃ" in Kana input method
    http://code.google.com/p/mozc/issues/detail?id=88

 -- Nobuhiro Iwamatsu <email address hidden> Tue, 12 Jul 2011 01:24:48 +0900

Related branches

Benjamin Drung (bdrung) on 2011-07-18
Changed in mozc (Ubuntu):
assignee: nobody → Benjamin Drung (bdrung)
importance: Undecided → Wishlist
status: New → In Progress
Benjamin Drung (bdrung) wrote :

It fails to build on amd64:

  LINK(target) out_linux/Release/gen_user_pos_data_main
out_linux/Release/obj.target/base/base/init.o: In function `Mutex':
/tmp/buildd/mozc-1.1.758.102/./base/mutex.h:98: undefined reference to `pthread_mutexattr_init'
/tmp/buildd/mozc-1.1.758.102/./base/mutex.h:99: undefined reference to `pthread_mutexattr_settype'
/tmp/buildd/mozc-1.1.758.102/./base/mutex.h:98: undefined reference to `pthread_mutexattr_init'
/tmp/buildd/mozc-1.1.758.102/./base/mutex.h:99: undefined reference to `pthread_mutexattr_settype'
/tmp/buildd/mozc-1.1.758.102/./base/mutex.h:98: undefined reference to `pthread_mutexattr_init'
/tmp/buildd/mozc-1.1.758.102/./base/mutex.h:99: undefined reference to `pthread_mutexattr_settype'
/tmp/buildd/mozc-1.1.758.102/./base/mutex.h:98: undefined reference to `pthread_mutexattr_init'
/tmp/buildd/mozc-1.1.758.102/./base/mutex.h:99: undefined reference to `pthread_mutexattr_settype'
collect2: ld returned 1 exit status
make[2]: *** [out_linux/Release/gen_user_pos_data_main] Error 1
make[2]: Leaving directory `/tmp/buildd/mozc-1.1.758.102'
Generating version definition file...
export $QTDIR = /usr/local/Trolltech/Qt-4.6.3
Running: make -j1 MAKE_JOBS=1 BUILDTYPE=Release primitive_tools
Traceback (most recent call last):
  File "build_mozc.py", line 959, in <module>
    main()
  File "build_mozc.py", line 947, in main
    BuildToolsMain(original_directory_name)
  File "build_mozc.py", line 911, in BuildToolsMain
    BuildMain(original_directory_name)
  File "build_mozc.py", line 888, in BuildMain
    BuildOnLinux(options, targets)
  File "build_mozc.py", line 759, in BuildOnLinux
    RunOrDie([make_command] + build_args + target_names)
  File "build_mozc.py", line 556, in RunOrDie
    '==========']))
__main__.RunOrDieError:
==========
 ERROR: make -j1 MAKE_JOBS=1 BUILDTYPE=Release primitive_tools
==========

Changed in mozc (Ubuntu):
assignee: Benjamin Drung (bdrung) → nobody
status: In Progress → Incomplete
Yusuke Sato (yusukes) wrote :

Hi,
I'm an upstream maintainer of the project (code.google.com/p/mozc). We're aware of the issue and now trying to fix the upstream code. For now, could you try the attached patch?

patch description:
g++ 4.6 on Oneiric seems to be more strict than others. For example, if we use 'g++ -lXXX -o binary_name *.o', g++ sometimes fails to link due to undefined references even when libXXX is a shared library. On this environment, it seems that we always have to pass the command line parameters in this order: 'g++ -o binary_name *.o -lXXX'.

The patch fixes the order.

Nobuto Murata (nobuto) wrote :

@Yusuke Sato,
Thank you for providing the patch.
I will take a look and get it into the package.

Changed in mozc (Ubuntu):
assignee: nobody → Nobuto MURATA (nobuto)
status: Incomplete → In Progress
Nobuto Murata (nobuto) on 2011-07-19
summary: - Sync mozc 1.1.758.102-1 (multiverse) from Debian unstable (non-free)
+ Please merge mozc 1.1.758.102-1 (multiverse) from Debian unstable (non-
+ free)
description: updated
Nobuto Murata (nobuto) wrote :
Nobuto Murata (nobuto) wrote :

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Nobuto Murata (nobuto) wrote :

I attached debdiffs and un-assigned myself.

Ubuntu Sponsors Team,
Could you review the attached debdiffs?

Changed in mozc (Ubuntu):
assignee: Nobuto MURATA (nobuto) → nobody
status: In Progress → Confirmed
Nobuto Murata (nobuto) wrote :

Upstream and Debian has done a new release. I will update this bug.

Changed in mozc (Ubuntu):
assignee: nobody → Nobuto MURATA (nobuto)
status: Confirmed → In Progress
Nobuto Murata (nobuto) wrote :
summary: - Please merge mozc 1.1.758.102-1 (multiverse) from Debian unstable (non-
+ Please merge mozc 1.1.773.102-1 (multiverse) from Debian unstable (non-
free)
description: updated
Nobuto Murata (nobuto) wrote :

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in mozc (Ubuntu):
assignee: Nobuto MURATA (nobuto) → nobody
status: In Progress → Confirmed
Benjamin Drung (bdrung) wrote :

Please forward the build fix patch to upstream so that we can sync the package from Debian next time.

I upload it with the changelog modified, because this isn't really a merge. This is a sync and then modifying it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mozc - 1.1.773.102-1ubuntu1

---------------
mozc (1.1.773.102-1ubuntu1) oneiric; urgency=low

  * debian/patches/fix-oneiric-ftbfs.patch: change an order of g++ parameters
    to fix FTBFS on oneiric (LP: #811892).

mozc (1.1.773.102-1) unstable; urgency=low

  * New upstream release (r58).

mozc (1.1.758.102-1) unstable; urgency=low

  * New upstream release (r57) (Closes: #633007).
  * Remove mozc-el-issue76.patch. Applied to upstream.
  * Update patches/support-kfreebsd.patch.
    Support build with libzinnia.
  * Update debian/rules.
    Add path of build directory.
 -- Nobuto MURATA <email address hidden> Tue, 26 Jul 2011 13:47:30 +0200

Changed in mozc (Ubuntu):
status: Confirmed → Fix Released
Nobuto Murata (nobuto) wrote :

Upstream commit log says FTBFS issue was fixed in r61.
http://code.google.com/p/mozc/source/detail?r=61
The patch can be dropped if Debian releases Mozc 1.2.809.102 or newer.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers