mozart:i386 depends on emacsen:i386, but does not need to and should not

Bug #927387 reported by Karl Hegbloom on 2012-02-06
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
mozart (Ubuntu)
Undecided
Unassigned

Bug Description

Multiarch

karlheg@oaktree:~/src/Ubuntu/precise$ sudo apt-get install mozart:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mozart:i386 : Depends: emacs23:i386 or
                        emacsen:i386
E: Unable to correct problems, you have held broken packages

I want to install mozart:i386 on an AMD64, but it depends on the same architecture version of Emacs. I've already got Emacs installed, and since Emacs Lisp is not architecture dependant, there does not need to be an architecture specific dependancy here.

Mozart can not easily be compiled for x86_64. It is the language used by a very interesting and likely popular computer science textbook (the cathedral book), and so I think we ought to have an installable version of it. Thanks.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: mozart:i386 (not installed)
ProcVersionSignature: Ubuntu 3.2.0-8000.2~ppa1-generic-tuxonice 3.2.2
Uname: Linux 3.2.0-8000-generic-tuxonice x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Sun Feb 5 18:02:03 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110301.7)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: mozart
UpgradeStatus: Upgraded to precise on 2012-01-26 (10 days ago)

Karl Hegbloom (karl.hegbloom) wrote :

See Bug #927434 on Emacs23.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mozart (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers