[Mac] numlock and capslock leds don't light up unless mouseemu is removed

Bug #218263 reported by mabovo on 2008-04-16
This bug report is a duplicate of:  Bug #251830: Mouseemu installed, not wanted. Edit Remove
56
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mactel Support
Undecided
Unassigned
kbd (Ubuntu)
Undecided
Unassigned
mouseemu (Ubuntu)
Low
Unassigned
x11-xkb-utils (Ubuntu)
Undecided
Unassigned
xserver-xorg-input-keyboard (Ubuntu)
Undecided
Unassigned

Bug Description

the two common led on my keyboard (NumLock and CapsLock) stopped functioning properly.
The related key continue working (if I press CapsLock characters get enabled and disabled, even if I don't see the light), but the leds don't give any response. Regarding to the NumLock key it doesn't work in MacBook probably missing some xmap configuration in x11-xkb-utils.

My xmodmap file has this configuration:
keycode 115 = ISO_Level3_Shift
keycode 49 = section plusminus
keycode 94 = grave asciitilde

xorg.conf
Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "XkbRules" "xorg"
 Option "XkbModel" "apple_laptop"
# Option "XkbModel" "macintosh(macbook79)"
 Option "XkbLayout" "us"
# Option "XkbLayout" "pt"
 Option "XkbVariant" "basic"
# Option "XkbVariant" "apple_laptop"
# Option "XkbVariant" "mac"
 Option "XkbOptions" "grp_led:scrol l,compose:rwin,lv3:lwin_switch,grp:alts_toggle"
EndSection

I am using brazilian portuguese support language.

mabovo (mabovo) wrote :

Confirmed on a 2nd gen MacBook (core 2 duo) running Hardy RC amd64, however, a workaround has been found from these sources:

https://bugs.launchpad.net/ubuntu/+source/mouseemu/+bug/103375
http://ubuntuforums.org/archive/index.php/t-458978.html

Running "sudo apt-get remove mouseemu" fixed the issue for me immediately.

mabovo (mabovo) wrote :

Confirmed keyboard leds fixed on a 2nd gen MacBook Hardy amd64 - Leds are lighting up after removing package mouseemu as mentioned on bug report https://bugs.launchpad.net/ubuntu/+source/mouseemu/+bug/103375.

Kieran Hogg (xerosis) wrote :

Confirming this in mouseemu, I've been seeing this on Intrepid so hopefully it can be fixed before release.

Changed in mouseemu:
status: New → Confirmed

Confirming this on Intrepid release version. Running MBP Santa Rosa (3.1). Removing mouseemu fixes the issue; perhaps not installing it by default would be a valid approach if the problem itself cannot be fixed?

damian (damian-stewart) wrote :

I just did an apt-get remove mouseemu on a fresh install of Intrepid with a MacBook 2,1 and immediately the caps lock and num lock lights started working, /but/ i lost all other keyboard keys except for the brightness controls (!?). fixed by switching to one of the text-only consoles (err, alt-ctrl-fn-f4 i think) and reinstalling mouseemu.

but, i've just installed an FDI file for the trackpad, and gsynaptics, so i'm going to reboot and try again, and if that works i'll post a new message here.

damian (damian-stewart) wrote :

ok, just confirmed it: even with an FDI file installed, and with gsynaptics, removing mouseemu on Intrepid on a MacBook 2,1 COMPLETELY KILLS all keyboard input EXCEPT the brightness controls.

Daniel T Chen (crimsun) on 2008-12-14
Changed in mouseemu:
importance: Undecided → Low
Tyson Moore (squircle) wrote :

I just removed mouseemu, used HAL to configure two-finger right-click (Google appletouch.fdi ubuntu), and installed pommed (sudo apt-get install pommed). The pommed daemon controls keyboard backlight controls, brightness, eject button etc. Just edit /etc/pommed.conf and change FNMODE to 2 to force Fn mode (Fn + F2 = Brightness Up). That worked for me. Removing mouseemu kills all keyboard input UNLESS the proper appletouch.fdi is identified to the HAL daemon (as HAL is used for mouse configuration now, not X). Also, add "applesmc" to a new line of /etc/modules to enable full Apple keyboard control and everything. It may seem like a lot to do, but now it works flawlessly.

Bryce Harrington (bryce) wrote :

[This is an automated message]

Hi mabovo,

Please attach the output of `lspci -vvnn` too.

Changed in x11-xkb-utils:
status: New → Incomplete
Bryce Harrington (bryce) on 2009-01-09
Changed in xserver-xorg-input-keyboard:
status: New → Incomplete
mabovo (mabovo) wrote :

solved removing mouseemu.

only the mouse cursor in trackpad is not so smooth, sometimes it runs faster than was pressed.

Thanks Bryce.

Bryce Harrington (bryce) wrote :

[Closing uninvolved products]

Changed in kbd:
status: New → Invalid
Changed in x11-xkb-utils:
status: Incomplete → Invalid
Changed in xserver-xorg-input-keyboard:
status: Incomplete → Invalid
David D Miller (justdave) wrote :

I'm on an nVidia Mac Mini (Macmini3,1) running Jaunty, and the num-lock key works fine, but caps lock has the problem described here (key works, but the light doesn't light up). Removing the mouseemu package does correct the problem, as others here have stated, and does not disable the rest of my keyboard, nor does it seem to affect the operation of my mouse at all. I did already have applesmc loaded in the kernel (I didn't have to add that).

Greenbear (p-uvwxy) wrote :

I had the same problem on a samsung q210 laptop.

#sudo apt-get remove mouseemu

solved the problem, after a reboot(?).

Przemek K. (azrael) wrote :

Same thing on Jaunty.
Why is mouseemu still installed by default if its not needed?

Przemek K. (azrael) wrote :

Bug #147934 - duplicate of this one?

Przemek K. (azrael) wrote :

Bug 251830 is fixed - mouseemu won't be installed in Karmic.
Therefore, I'm marking it as fix released.
---
This bug was fixed in the package hw-detect - 1.72ubuntu4

---------------
hw-detect (1.72ubuntu4) karmic; urgency=low

  [ Colin Watson ]
  * Drop disk-detect/iscsi/enable template, which is no longer used.
  * Don't install mouseemu on Intel Mac desktops (LP: #251830).

Changed in mouseemu (Ubuntu):
status: Confirmed → Fix Released
Changed in mactel-support:
status: New → Invalid

On Mon, Aug 31, 2009 at 06:53:53AM -0000, Przemysław Kulczycki wrote:
> Bug 251830 is fixed - mouseemu won't be installed in Karmic.

To clarify, it will be installed on Intel Mac laptops, but not desktops.
Since this bug as reported concerned MacBooks, I see no justification
for closing it, and am reopening it now.

 status Confirmed

Changed in kbd (Ubuntu):
status: Invalid → Confirmed
Przemek K. (azrael) wrote :

Oh, my bad. I've misunderstood the description of the bug fix.
So, is there any reason to keep mouseemu on Macbooks? The right-click functionality is already provided by the Synaptics touchpad driver.

Colin Watson (cjwatson) on 2009-09-01
Changed in kbd (Ubuntu):
status: Confirmed → Invalid
Changed in mouseemu (Ubuntu):
status: Fix Released → Confirmed
Ricky Campbell (cyberdork33) wrote :

If that is correct, then the issue still remains and the bug should still be open. I am going to make this a duplicate of #251830 since that seems to be where work is being done on this. Please add appropriate information there.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers