[Mac] Wacom tablet works from LiveCD but not installed because mouseemu is installed

Bug #212737 reported by Jon A. Cruz on 2008-04-06
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mouseemu (Ubuntu)
Medium
Unassigned

Bug Description

I tried Hardy beta with a MacBook Pro and Wacom Intuos3. Things worked from a LiveCD session once I added manual wacom entries to xorg.conf. (I'd previously setup the tablet on a PC running 7.10)

However, once I used that CD to install to the laptop, the tablet did not work. Updating packages did not help. Using wacdump sees no input. The buttons do actually function as expected (left button, right button, mouse scroll wheel, etc), however no motion is seen and applications do not get extended input events.

One difference in the non-functional install is that Xorg.0.log shows an error as the pad is set up:

Xorg.0.log-(**) Option "Device" "/dev/input/wacom"
Xorg.0.log:pad Wacom X driver can't grab event device, errno=1022
Xorg.0.log-(==) Wacom using pressure threshold of 61 for button 1

Bryce Harrington (bryce) wrote :

Hmm, it sounds like perhaps the device isn't being created? Can you check if /dev/input/wacom exists? My guess is that maybe the device is getting linked to the mouse driver rather than wacom or something. Also, please attach your Xorg.0.log and your /etc/X11/xorg.conf files. Can you also check if the wacom driver is installed?

Jon A. Cruz (jon-joncruz) wrote :

/dev/input/wacom exists and appears to be linked to the proper event. Also when pointing wacdump at either /dev/input/wacom or the linked event*, the expected tablet info is displayed (only non-functional). Pointing wacdump to the other devices there does not show any recognized device.

lrwxrwxrwx 1 root root 7 2008-04-07 20:36 tablet-intuos3-6x8 -> event13
crw-rw----+ 1 root root 10, 223 2008-04-07 20:19 uinput
lrwxrwxrwx 1 root root 7 2008-04-07 20:36 wacom -> event13
joncruz@moover:~$ file /dev/input/event13
/dev/input/event13: character special (13/77)

Jon A. Cruz (jon-joncruz) wrote :

It also appears that there was more wacom info in dmesg on the live-CD boot than on the boot from install on HD.

Bryce Harrington (bryce) on 2008-04-08
Changed in xorg:
importance: Undecided → Medium
status: Incomplete → Triaged
Jon A. Cruz (jon-joncruz) wrote :

I have exactly the same problem with Hardy Final, my Mac Pro and a Wacom Bamboo. The logs and errors look the same.

Attached are /var/log/messages for three separate boots trying different configurations to get the tablet to work.

Any help would be greatly appreciated, as this is my graphics box and I would really not have to go back to fiesty.

Thanks.

Changed in wacom-tools:
status: Triaged → Confirmed
Bryce Harrington (bryce) on 2008-08-08
Changed in wacom-tools:
assignee: nobody → bryceharrington
Jon A. Cruz (jon-joncruz) wrote :

Compiled and installed wacom drivers myself, but did not help.

However, in searching I came across some mention of mouseemu interfering with a wacom installation. I checked and did have it running. Removed it via synaptic, restarted X11 and the wacom tablet started working properly.

Alexander Rice (alex-rices) wrote :

I can confirm this behavior with an intuos3 equipped iMac.

mouseemu seems to be installed by default on Apple computers to emulate a two button mouse/trackpad but breaks the wacom drivers. Uninstalling mouseemu restores normal operation. This seems like it should be a mouseemu bug rather than a linux-wacom bug and I originally submitted it as such as bug #261385

Bryce Harrington (bryce) on 2009-01-16
Changed in wacom-tools:
status: Confirmed → Triaged
Changed in mouseemu:
assignee: bryceharrington → nobody
Bryce Harrington (bryce) wrote :

I believe most of the wacomtools bugs are now sorted out in karmic. Please give it a try and see.
There may still be more wacomtools bugs - if so please report them via the command 'ubuntu-bug xorg'. If you can tell that this specific issue is still occuring, feel free to reopen it.

Changed in mouseemu (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers