mdadm arrays fail to mount

Bug #776908 reported by Mike Wittman on 2011-05-04
76
This bug affects 14 people
Affects Status Importance Assigned to Milestone
mountall (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: mountall

I have a RAID 1 partition across /dev/sdb3 and /dev/sdc3 which was created with mdadm in 9.10. It worked fine through upgrades to 10.04 and 10.10, but in 11.04 it fails to mount at boot time.

I updated my /etc/fstab to account for the apparent device name change from /dev/md0 to /dev/md_d0 in 11.04. This allowed me to mount the RAID partition manually, but it still does not mount at boot. I get the error "The disk drive for /mnt/data is not yet ready or not present". If I drop into the manual recovery shell, however, a "mount /mnt/data" succeeds.

If I drop into the manual recovery shell, but exit without doing anything, the subsequent invocation of mountall still fails to mount the partition. So it appears that this is not a timing issue.

dmesg shows the RAID as active, with no errors, apparently before mountall is invoked. /proc/mdstat concurs.

mountall 2.25ubuntu1

Mark Ovens (parish) wrote :

I have *exactly* the same problem. My array (also RAID 1) was created under 10.10.

This is more of a problem for me as I use a Bluetooth keyboard and at the boot error where I have to type S(kip) or M(anual Recovery) BT is not running so I have had to connect an old PS/2 keyboard just to boot.

Austin (ninjamonic) wrote :

Problem is happening for me with a RAID5 array. I am mounting the array by UUID in /etc/fstab. I get the error that the drive is not ready at boot and I am given the option to wait, skip, or manually recover. If I manually recover I can simply type mount -a and the array mounts correctly. I then logout and boot continues normally.

This is a major issue for me because this is supposed to be a headless machine.

Michael Beltoft (mbeltoft) wrote :

I'm having the exact same problem with my Raid5 created under 10.10. After the upgrade to 11.04 it just don't mount anymore

pklaus (pklaus) wrote :

There has been a post in the German Ubuntu users forum about this problem too: <http://forum.ubuntuusers.de/topic/home-auf-raid-wird-beim-systemstart-nicht-gemo/>

When I start up my Ubuntu computer, I get this message that it could not mount all partitions as defined in `/etc/fstab`. I the press [m] (for a terminal instead of s:skip) and run the command `mount -a`. This works fine and mount all entries from fstab successfully. I then press [Ctrl]-[d] to exit the recovery terminal and the startup continues without further problems.

(I only have /etc/home on the /dev/md_d0 but I think it would be difficult to solve this on a headless system.)

As far as I know, the main difference between `mount -a` and `mountall` (used by upstart) is that the latter publishes status output via dbus.

(I also experienced the renaming from `/dev/md0` to `/dev/md_d0` but this is irrelevant for me as I use the UUID to mount the partition in /etc/fstab.)

summary: - mdadm RAID 1 fails to mount
+ mdadm arrays fail to mount
Changed in mountall (Ubuntu):
importance: Undecided → High
status: New → Confirmed
tags: added: natty
linuxkungfu (linuxkungfu) wrote :

Same problem. Upgraded to 11.04 , can't boot from RAID 1 array.

Subscribed to thread.

Mike Szmansky (mszmansky) wrote :

Same problem is happening to me with 11.04 64 bit server edition. I created a RAID1 array and can mount it fine as /dev/md1 at the command line but when I boot it fails to mount the md1 device. If i skip or manually recover and re-assemble the array and remount at the command line, it works fine.

Aaron Anderson (anderson-aaron) wrote :

You should really read through my thread here: http://ubuntuforums.org/showthread.php?t=1772692

It boils down to needing to update the initram; read through it. See if it helps the confusion.

Mike Szmansky (mszmansky) wrote :

I did read through it. This did not seem to help me. I updated the ramfs but it still lost my array when I rebooted.

Mike Wittman (wittman) wrote :

Updating the initramfs did not help me either. I verified that the initramfs mdadm.conf had the same contents as the root mdadm.conf, which mounts successfully via the recovery shell.

sflinux (lenoxgruvin) wrote :

 I updated from 10.1 to 11.04 and my raid 1 fails to mount on reboot. I have to type M to enter Manual and type,
sudo mdamd -A -R /dev/mdo
then I can type Control D and boot as normal.
I tried dpkg-reconfigure mdadm
and update-initramfs -u
but neither fixed the problem for me.
I will try the workaround by parish at this thread:
http://ubuntuforums.org/archive/index.php/t-1748467.html

Austin (ninjamonic) wrote :

Still exists in Oneiric (11.10) beta.

Austin (ninjamonic) on 2011-09-04
tags: added: oneiric
Chris Brosnan (r-achounts-l) wrote :

Same issue. Any updates?

Issue no longer occurs on my Oneiric machine. I ran an upgrade today and
now everything seems fine.

$ uname -a
Linux nas 3.0.0-12-generic-pae #19-Ubuntu SMP Fri Sep 23 23:10:56 UTC
2011 i686 i686 i386 GNU/Linux

Mark Ovens (parish) wrote :

The upgrade to Oneiric hasn't fixed it for me - the problem persists

$ uname -a
Linux kubuntu 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Einar (esr496) wrote :

I use this quick-n-dirty workaround for now:

http://ubuntuforums.org/showpost.php?p=10829313&postcount=14

Mike Szmansky (mszmansky) wrote :

any updates on this bug? How does it get assigned?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers