mountall does not honor nobootwait flag on /var/* and /usr/* filesystems

Bug #654545 reported by Raphaël Pinson on 2010-10-04
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
mountall (Ubuntu)
High
Surbhi Palande
Precise
Undecided
Unassigned

Bug Description

Binary package hint: mountall

For very valid reasons, mountall always waits on /usr/* and /var/* remote filesystems.

That said, /var/opt/* are valid FHS filesystems that are not vital to the system. In order to not get the boot stuck on such remote filesystems, we tried using the "nobootwait" flag, but it is ignored on /usr/* and /var/* remote filesystems. This is believed to be a bug, since this behaviour should be possible to be forced.

In general, it would also be a good idea to make /var/opt/* filesystems default to TAG_NOWAIT since they are not vital to the system.

Related branches

Raphaël Pinson (raphink) wrote :

The attached patch fixes the bug by:
   * honoring the "nobootwait" flag on /usr, /var, /usr/* and /var/* filesystems ;
   * making /var/opt and /var/opt/* filesystems default to TAG_NOWAIT.

Changed in mountall (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Scott James Remnant (scott)
tags: added: patch
Mathieu Alorent (kumy) wrote :

I've build a package, you could find it in my PPA.

https://launchpad.net/~kumy/+archive/ppa?field.series_filter=lucid

( sudo add-apt-repository ppa:kumy/ppa )

mountall (2.15.3~kumy2) lucid; urgency=low

  * Default behavior for missing part set to nobootwait (LP #571444).
  * mountall does not honor nobootwait flag on /var/* and /usr/* filesystems (LP #654545)
  * gfs2 mount not seen as remote (LP #582278)
  * Disk check message is grammatically incorrect (LP #572016)

mountall (2.15.3~kumy1) lucid; urgency=low

  * Press S or M does not work for more than one partition on error (LP: #655616).

Changed in mountall (Ubuntu):
assignee: Scott James Remnant (scott) → nobody
Surbhi Palande (csurbhi) on 2011-03-10
Changed in mountall (Ubuntu):
assignee: nobody → Surbhi Palande (csurbhi)
Surbhi Palande (csurbhi) wrote :

@Raphaël Pinson, please rewrite your patch making it generic for /var/* or /usr/* and the ! has_option (mnt, "nobootwait", FALSE) condition, as discussed on irc. Also to request a merge of your patch, please follow the instructions here:
https://wiki.ubuntu.com/DistributedDevelopment/Documentation
Thanks!

Steve Langasek (vorlon) wrote :

I've committed a fix for this locally, for inclusion in the next mountall upload.

Changed in mountall (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mountall - 2.38

---------------
mountall (2.38) unstable; urgency=low

  * Counterproductively document in debian/copyright the license of files in
    intl that form no part of the binary package, to get through the Debian
    NEW queue.

 -- Steve Langasek <email address hidden> Sat, 30 Jun 2012 11:44:59 -0700

Changed in mountall (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mountall (Ubuntu Precise):
status: New → Confirmed
Nick Moriarty (nick-moriarty) wrote :

Backport of relevant section in mountall.c for 2.36.4; this should make mountall respect nobootwait, even if the mountpoint is under /usr or /var.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers