Often 'Press S to skip mount or M for manual recovery' during mounting

Bug #614855 reported by Ernst on 2010-08-07
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Debian
New
Unknown
mountall (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mountall

I often get during boot: Press S to skip mount or M for manual recovery.
At this time, I press 'M', and then directly 'ctrl-d'. As far as I can see, everything is mounted correctly. SO, Ubuntu should mount everything itself as there are no (obvious) errors or problems.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: mountall 2.15
ProcVersionSignature: Ubuntu 2.6.35-14.19~lucid1-generic 2.6.35
Uname: Linux 2.6.35-14-generic x86_64
Architecture: amd64
Date: Sun Aug 8 00:21:30 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100122)
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: mountall

Ernst (ernst-blaauw) wrote :
dazza5000 (darran-kelinske) wrote :

I am thinking this is possibly related to

https://bugs.launchpad.net/ubuntu/+source/cryptsetup/+bug/475936

or

https://bugs.launchpad.net/ubuntu/+source/mountall/+bug/571682

Do you think either of these are the same issue as the one you are having Ernst?

Sincerely,

Darran

Ernst (ernst-blaauw) wrote :
Download full text (3.5 KiB)

It ain't those bugs, as I don't have any encrypted drives.
I just figured out something more:

$ cat /var/log/boot.log
swapon: /dev/disk/by-uuid/27cac63b-5a29-4c3f-a9f2-8218a51be4d4: swapon failed: Device or resource busy
mountall: swapon /dev/disk/by-uuid/27cac63b-5a29-4c3f-a9f2-8218a51be4d4 [1061] terminated with status 255
mountall: Problem activating swap: /dev/disk/by-uuid/27cac63b-5a29-4c3f-a9f2-8218a51be4d4

It seems the problem is with my swap (instead of /mnt/media, which is reported at the main screen). I have no idea what could be the problem. See my logs below:

My swap fstab entry:
# swap was on /dev/sda6 during installation
UUID=27cac63b-5a29-4c3f-a9f2-8218a51be4d4 none swap sw 0 0

$ sudo fdisk -l
Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xa8be0b8c

   Device Boot Start End Blocks Id System
/dev/sda1 1 7649 61440561 83 Linux
/dev/sda2 7650 29872 178506247+ f W95 Ext'd (LBA)
/dev/sda3 * 30395 49516 153597465 7 HPFS/NTFS
/dev/sda4 49517 91201 334834762+ 7 HPFS/NTFS
/dev/sda5 7650 29374 174506031 83 Linux
/dev/sda6 29375 29872 4000153+ 82 Linux swap / Solaris

Disk /dev/sdb: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0b911d8a

   Device Boot Start End Blocks Id System
/dev/sdb1 2 91201 732564000 f W95 Ext'd (LBA)
/dev/sdb2 * 1 1 8001 83 Linux
/dev/sdb5 2 13056 104864256 7 HPFS/NTFS
/dev/sdb6 13057 26111 104864256 83 Linux
/dev/sdb7 26112 29322 25792326 82 Linux swap / Solaris
/dev/sdb8 29323 59918 245762338+ 7 HPFS/NTFS
/dev/sdb9 59919 86027 209720511 7 HPFS/NTFS
/dev/sdb10 86028 91201 41560123+ 7 HPFS/NTFS

Partition table entries are not in disk order

$ ls -l /dev/disk/by-uuid/
total 0
lrwxrwxrwx 1 root root 10 2010-08-10 20:50 04543EE4543ED85E -> ../../sdb9
lrwxrwxrwx 1 root root 10 2010-08-10 20:50 0f104604-00b2-4b97-962f-b48f8c29db01 -> ../../sda1
lrwxrwxrwx 1 root root 10 2010-08-10 18:50 27cac63b-5a29-4c3f-a9f2-8218a51be4d4 -> ../../sda6
lrwxrwxrwx 1 root root 10 2010-08-10 20:57 6b1e0962-5830-458a-91d2-709abb46f142 -> ../../sdb6
lrwxrwxrwx 1 root root 10 2010-08-10 20:57 7E9A41319A40E6ED -> ../../sda3
lrwxrwxrwx 1 root root 10 2010-08-10 20:57 8e9822e1-8bcd-44bb-a69b-c497d95942ca -> ../../sdb7
lrwxrwxrwx 1 root root 10 2010-08-10 20:57 ba5c5d61-e80d-4b83-206e-a98eacb0ca4c -> ../../sdb2
lrwxrwxrwx 1 ro...

Read more...

Ernst (ernst-blaauw) wrote :

Is it possible this bug is related to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440719, where is stated that the swap is mounted twice?

Changed in debian:
status: Unknown → New
dazza5000 (darran-kelinske) wrote :

Ernst,

I am unsure what causes this, but I did do a quick google search and found some individuals with the same issue. Have you been able to find a successful workaround while this issue is addressed?

http://www.google.com/search?sourceid=chrome&ie=UTF-8&q=mountall%3A+Problem+activating+swap%3A#sclient=psy&hl=en&q=%22mountall%3A+Problem+activating+swap%3A%22&aq=f&aqi=&aql=&oq=&pbx=1&fp=fca90e9507624f80

Darran

At the moment, I'm running Maverick and do not suffer from this bug.

On Sat, Jan 29, 2011 at 23:17, drizzle <email address hidden> wrote:

> Ernst,
>
> I am unsure what causes this, but I did do a quick google search and
> found some individuals with the same issue. Have you been able to find a
> successful workaround while this issue is addressed?
>
>
> http://www.google.com/search?sourceid=chrome&ie=UTF-8&q=mountall%3A+Problem+activating+swap%3A#sclient=psy&hl=en&q=%22mountall%3A+Problem+activating+swap%3A%22&aq=f&aqi=&aql=&oq=&pbx=1&fp=fca90e9507624f80
>
> Darran
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/614855
>
> Title:
> Often 'Press S to skip mount or M for manual recovery' during mounting
>

Steve Langasek (vorlon) wrote :

sounds like this is fixed in 10.10 and above.

Changed in mountall (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.