Comment 10 for bug 561390

Matt Grant (mattgrant) wrote :

Tried the PPA over in bug #567910, still get problems....

I am getting tempted to have ago at this myself.

May I suggest a fix for mountall to get this thing from being a show stopper?

This whole thing could be avoided if a mount for the file system read from fstab is tried. If this fails, then the 'press 'M' for shell, or 's' to skip' should be shown. The file system is in /etc/fstab for a reason, and having a blind go and checking the return code of the mount operation is justified given that udev is creating all the device nodes etc needed.

Missing an add/change event from udev in early boot can be a hard thing to debug.,

unless you set a a 20G partition as LVM, add 10 !G LVs to /etc/fstab, and run gdb on mountall in a terminal window... You can activate and deactivate the the test volume group with '# vgchange -a y /dev/<volume_group>' wile logged in to the desktop.

The heat needs to be taken off this one, and it can be fixed properly after the Lucid release with an update.