[lucid] vboxsf mounts defined on /etc/fstab cause errors on boot: needs upstart job

Bug #530179 reported by Sensiva on 2010-03-01
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
mountall (Ubuntu)
Medium
Unassigned
virtualbox-ose (Ubuntu)
Medium
Unassigned

Bug Description

I am runniing Lucid amd64 in vbox appliance, When I add vbox shared folders mounts in fstab, boot process stops (in both normal and recovery). I have to add noauto option to their lines to avoid this behaviour.

syntax I use : <sharname> <mountpoint> vboxsf

That didn't happen with any prior releases of Ubuntu.

Thank you

Sensiva (sensiva) on 2010-03-01
tags: added: lucid mount.vboxsf vbox
James P. Carter (jpcarter) wrote :

I have changed the package selection to mountall.

affects: ubuntu → mountall (Ubuntu)

Could you attach a copy of the /etc/fstab that fails for me?

Changed in mountall (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
Sensiva (sensiva) wrote :

Attached

Felix Geyer (debfx) on 2010-04-17
Changed in mountall (Ubuntu):
status: Incomplete → Confirmed

Could you try the following?

  echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash
  sudo update-initramfs -u

Changed in mountall (Ubuntu):
status: Confirmed → Incomplete
Sensiva (sensiva) wrote :

I tried it, it gave me the choice to press S to skip mounting the shared folder, or to press M to drop to recovery console

On Sun, 2010-04-18 at 21:17 +0000, Sensiva wrote:

> I tried it, it gave me the choice to press S to skip mounting the shared
> folder, or to press M to drop to recovery console
>
And did either of these options work?

Scott
--
Scott James Remnant
<email address hidden>

both worked, pressing S skipps mounting the shared folder, I have to mount it manually after finishing boot, and pressing M drops to root shell so its possible to resume boot later.

Still the shared folder isn't mounted automatically.

The apparent hang is a plymouth bug for not showing the messsage, marked as a duplicate.

I've no idea why the mount command fails - but that's not a mountall bug - that's a bug in whatever provides vboxsf? (is there a mount.vboxsf?)

João Pinto (joaopinto) on 2010-04-20
summary: - [lucid] Adding vboxsf in fstab stops boot process
+ [lucid] vboxsf causes a mount error on boot
summary: - [lucid] vboxsf causes a mount error on boot
+ [lucid] vboxfs causes mount errors on boot
João Pinto (joaopinto) on 2010-04-20
summary: - [lucid] vboxfs causes mount errors on boot
+ [lucid] vboxsf mounts defined on /etc/fstab cause errors on boot

Sensiva,
the fact that the error was not shown is related to the bug Scott was setting the duplicate to.

I am re-opening the bug for the aspect that the filesystem is not mounted and causing an error instead.

Scott,
The mount.vboxfs is provided by the virtualbox-guest-additions package.

The issue here is that the vboxsf file system type depends on the module "vboxfs" kernel module which is only loaded later from /etc/init.d/virtualbox-ose-guest-utils .

Sensiva,
a workaround is to mount the filesystem from /etc/rc.local using:
sudo mount -t vboxsf share mountpoint

I have kept the bug open for mountall just to track the feedback on how should this modular filesystems should be handed from a "mountall" perspective.

mountall doesn't care about modular filesystems; it sounds like virtualbox-guest-additions needs an Upstart job to load the module "on starting mountall"

Changed in mountall (Ubuntu):
status: Incomplete → Invalid
João Pinto (joaopinto) wrote :

I will attempt to provide a patch to replace the current /etc/init.d/virtualbox-ose-guest-utils with an upstart job.
According to Scott's feedback the start should be something like:
start on starting mountall
task
exec modprobe vboxsf

Sensiva (sensiva) wrote :

Please note that vboxsf stops the boot process even when choosing recovery mode (an error message is given tho). I am not sure this is related to plymouth too or not. In such situation I used to recover using alternate CD.

So bottom line is the expected behavior in normal boot mode is either mounting that shared folder or skipping it if error occurs with a warning message. In recovery boot mode it should continue to the recovery menu even if an error occurred.

Please update bug summary if necessary, and let me know of any further tests required

Appreciate your work
Thank you
/Sensiva>

Steve Langasek (vorlon) wrote :

That script is from the virtualbox-ose source package; not sure why this was assigned to virtualbox-guest-additions.

Scott, would 'start on mounting TYPE=vboxsf' also work here?

affects: virtualbox-guest-additions (Ubuntu) → virtualbox-ose (Ubuntu)
João Pinto (joaopinto) wrote :

Sensiva,
you report relates 2 different problems.

The fact that there was an error and the filesystem was not mounted is the one being addressed on this bug report, the fix requires a change to the virtualbox-ose package.

The fact that the boot stopped *even in recovery mode*, is related to bug 507881, if you are concerned with that behavior please subscribe it.

Thanks.

On Tue, 2010-04-20 at 23:46 +0000, Steve Langasek wrote:

> Scott, would 'start on mounting TYPE=vboxsf' also work here?
>
Yes!

That's a really good idea, I hadn't thought of that.

Scott
--
Scott James Remnant
<email address hidden>

On Tue, 2010-04-20 at 22:38 +0000, Sensiva wrote:

> So bottom line is the expected behavior in normal boot mode is either
> mounting that shared folder or skipping it if error occurs with a
> warning message. In recovery boot mode it should continue to the
> recovery menu even if an error occurred.
>
The current recovery mode is being phased out in favour of every boot
being able to be used for recovery

Scott
--
Scott James Remnant
<email address hidden>

Daniel Hahler (blueyed) on 2010-04-23
Changed in virtualbox-ose (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
tags: added: upstart
summary: - [lucid] vboxsf mounts defined on /etc/fstab cause errors on boot
+ [lucid] vboxsf mounts defined on /etc/fstab cause errors on boot: needs
+ upstart job
Frank Mehnert (frank-mehnert) wrote :

The upcoming release 3.2 as well as the maintenance release 3.1.8 will rename the kernel module from vboxvfs.ko to vboxsf.ko. This will allow the kernel to load the module on demand so no further change should be necessary.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ose - 3.2.0-dfsg-1ubuntu1

---------------
virtualbox-ose (3.2.0-dfsg-1ubuntu1) maverick; urgency=low

  * Merge from Debian unstable, remaining changes:
    - Set x11 backport switch to "lucid".
    - VirtualBox should go in Accessories, not in System tools. (LP: #288590)
      - debian/virtualbox-ose-qt.files/virtualbox-ose.desktop
    - Add Apport hook.
      - debian/virtualbox-ose.files/source_virtualbox-ose.py
      - debian/virtualbox-ose.install
    - Drop *-source packages.
  * Drop u03-fix-cpu-lockup.dpatch, fixed upstream.
  * Remove Launchpad integration as (non-packaging) bugs should be reported
    upstream.

virtualbox-ose (3.2.0-dfsg-1) unstable; urgency=low

  [ Felix Geyer ]
  * New upstream release.
  * Add 23-remove-invalid-chars-check.patch to remove a check for invalid
    characters in the build path since kBuild is now able to handle those.
  * Fix FTBFS when building without arch-all packages.

  [ Michael Meskes ]
  * Changed order of some commands to make sure links are created inside
    the source tarball not outside.

virtualbox-ose (3.1.53-dfsg-1) experimental; urgency=low

  * New upstream release 3.2.0 Beta 3.
  * Add build-dependencies required by new upstream version.
  * Adapt 18-system-xorg.dpatch to new upstream version.
  * Update to new upstream release of vdfuse.
  * Build vdfuse with -Wl,--as-needed.
  * Install vbox PAM module.
  * Drop 17-disable-help-contents.dpatch and 20-hide-help-buttons.dpatch
    as VirtualBox can download the manual.
  * Enable VDE networking.
  * Enable VNC server in VBoxHeadless.
  * Don't build VBoxBFE as it's not installed anyway.
  * Hide the update menu item and settings page instead of disabling them.
  * Make both dkms packages conflict with each other as the kernel modules
    export the same symbol. (LP: #571574)
  * Switch from dpatch to quilt patching system.
  * Convert debian/rules to dh7.
  * Use dkms debhelper script.

virtualbox-ose (3.1.8-dfsg-1) unstable; urgency=low

  * New upstream version (LP: #578723).
    - Fixes vboxsf file systems not being mounted while booting on Ubuntu.
      (LP: #530179)
  * Adapt 18-system-xorg.dpatch and 06-xsession.dpatch to new upstream version.
  * Use upstream 50-vboxmouse.conf instead of our own.
  * Add libxrandr-dev to build-dependencies.
  * Don't load the kernel modules in the guest utils init script as they are
    loaded automatically.
  * Drop 15-wined3d-guest-addition.dpatch as the Windows guest additions
    provide Direct3D acceleration.

virtualbox-ose (3.1.6-dfsg-3) unstable; urgency=low

  * Move 10-vboxmouse.conf to 50-vboxmouse.conf and install it in
    /usr/share/X11/xorg.conf.d.
  * Use substvar from new xsfbs.mk.
 -- Felix Geyer <email address hidden> Tue, 25 May 2010 22:51:39 +0200

Changed in virtualbox-ose (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments