mountall and cryptsetup will fight for the console when not using usplash

Bug #497684 reported by ceg on 2009-12-17
74
This bug affects 14 people
Affects Status Importance Assigned to Milestone
cryptsetup (Ubuntu)
Undecided
Unassigned
mountall (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: mountall

reporting as another bug as summuarized by
Steve Langasek in https://bugs.launchpad.net/ubuntu/+source/mountall/+bug/456274/comments/39

"on the second prompt (for /home)" ... it should be reported as a separate bug....

it's ... known that mountall and cryptsetup will fight for the console when not using usplash, and there's no way we can get this fixed for karmic.

ceg (ceg) on 2009-12-17
Changed in mountall (Ubuntu):
status: New → Confirmed
Changed in cryptsetup (Ubuntu):
status: New → Confirmed

mountall in trunk no longer uses the console at all, and relies on plymouth for all prompting (since plymouth is able to arbitrate parallel requests)

cryptsetup should do the same

Changed in mountall (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
status: Triaged → Fix Committed
Changed in mountall (Ubuntu):
milestone: none → lucid-alpha-2
Changed in mountall (Ubuntu):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

cryptsetup also uses plymouth now, when it's available. It falls back to direct interaction if it isn't - but that's supposed to be fixed so that it's always available.

Changed in cryptsetup (Ubuntu):
status: Confirmed → Fix Released
edvardl (edvard-lauman) wrote :

Steve - is the fix available for Karmic or just Lucid?

edvardl (edvard-lauman) wrote :

Nevermind - I see in 512141 you said it will only be fixed in Lucid.

TomasKovacik (nail-nodomain) wrote :

nice, so we should switch to alpha ?

Steve Langasek (vorlon) wrote :

I hesitate to recommend switching to the alpha for general use, because even though this bug is now fixed, there will be many other bugs that come and go between now and the Lucid release. With that caveat in mind, if karmic is unusable for you because of this bug, then upgrading to lucid early is /an/ option.

Malinger_now (rory-stubble) wrote :

Steve, your caution is well-advised. I tried Xubuntu10.04 Alpha2 a few weeks ago and the several problems made the effort premature. My AMD rig has Nvidia Nforce2 chipset and Gforce4 graphic if that matters. I'm heartened by all the replies to the various linked bug reports.

Comments 10 and 11 on Bug #484272 provide a work around for karmic.

ceg (ceg) wrote :

Thank you Paul, for spreading that. I am backing up the ubuntu md raid systems now though, and switching them to a distro that does less hectic transitions and leaving things like raid or boot up unreliable in the process.

Changed in mountall (Ubuntu):
assignee: nobody → Shawn (shawn-subscribe-gmail)
Steve Langasek (vorlon) on 2011-02-09
Changed in mountall (Ubuntu):
assignee: Shawn (shawn-subscribe-gmail) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers