/var/run/dbus is not getting populated on live CDs

Bug #448981 reported by Mario Limonciello on 2009-10-11
66
This bug affects 9 people
Affects Status Importance Assigned to Milestone
mountall (Ubuntu)
High
Scott James Remnant (Canonical)
Karmic
High
Scott James Remnant (Canonical)

Bug Description

Binary package hint: mountall

I'm not sure how this is *supposed* to work, so adjust the source package accordingly.

The symptoms are usplash starts flickers a bit, and then you're left with a black screen and possibly a logged in shell.

Looking at /var/log/syslog you can see that network-manager failed, hal failed, gdm, and a whole slew of others that went into a respawn loop.

It stands out that network manager was failing because it couldn't find it's dbus socket at /var/run/dbus/system_bus_socket.

Sure enough, when I look there, it's nowhere to be found.

ProblemType: Bug
Architecture: i386
Date: Sun Oct 11 14:35:48 2009
DistroRelease: Ubuntu 9.10
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Alpha i386 (20091011)
Package: mountall 0.2.1
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.44-generic
SourcePackage: mountall
Uname: Linux 2.6.31-13-generic i686

Mario Limonciello (superm1) wrote :
Changed in mountall (Ubuntu):
milestone: none → ubuntu-9.10
Steve Langasek (vorlon) wrote :

I don't think it makes much sense for mountall to emit the 'local-filesystems' signal before the virtual filesystems have also been brought up; these are also "local" in a real sense. And all three of the jobs in the base system that currently depend on local-filesystems also write to /var/run, so I think it's clear that "local" should imply "virtual".

Steve Langasek (vorlon) wrote :

Scott, does the linked branch look reasonable?

There seems to be a rather widespread live-image regression since 2009-10-10.
Could you please look at bug 448495. I think it is the same. Mario, can you start dbus, hal and gdm by hand as described in bug 448495? Do you think it is the same bug?

I am seeing this a lot in /var/log/syslog:

Oct 12 05:59:50 ubuntu avahi-daemon[1451]: avahi-daemon 0.6.25 starting up.
Oct 12 05:59:50 ubuntu avahi-daemon[1451]: dbus_bus_get_private(): Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
Oct 12 05:59:50 ubuntu avahi-daemon[1451]: WARNING: Failed to contact D-Bus daemon.
Oct 12 05:59:50 ubuntu init: avahi-daemon main process (1451) terminated with status 255
Oct 12 05:59:50 ubuntu init: avahi-daemon main process ended, respawning

also gdm, hal and ubiquity terminating a lot.

Yes, that looks reasonable.

I have a bunch of other changes to merge in, so I'll pull this along with them.

Thanks Steve!

Changed in mountall (Ubuntu Karmic):
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Scott James Remnant (scott)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mountall - 0.2.2

---------------
mountall (0.2.2) karmic; urgency=low

  [ Steve Langasek ]
  * Don't emit the local-filesystem signal until after virtual filesystems
    are also done mounting. LP: #448981.

  [ Robert Gerlach ]
  * Fix segfault when root filesystem missing from fstab, or listed
    as /dev/root. LP: #448323.

  [ Johan Kiviniemi ]
  * Don’t queue filesystem check when either device or type is "none".

  [ Scott James Remnant ]
  * Removed /srv from the list of "essential" mountpoints. LP: #448267.
  * Allow overriding of the above list by using the "bootwait" and
    "nobootwait" fstab options, e.g.

    LABEL=foo /home ext4 nobootwait 0 0

  * Mount /proc before attempting to parse /proc/filesystems. LP: #447947.
  * Further improvements to event tagging of filesystems. A virtual bootwait
    filesystem underneath a local or remote filesystem inherits that tag,
    a local bootwait filesystem underneath a remote filesystem inherits that
    tag, remote filesystems do not inherit them. LP: #447654.

  * Replace previous hardcoded "arch specific" flag for /spu with an
    "optional" fstab mount option.
  * Made binfmt_misc,fusectl, debugfs, securityfs and /lib/init/rw optional
    as well.
  * Check whether the mountpoint of optional fstab entries exists before
    trying to mount, and skip over that if it doesn't. LP: #447525.

  * Keep /proc/self/mountinfo open, if it changes while we're running,
    update the knowledge of the mount table and what's mounted. That
    way if something else mounts it while mountall running, you'll still
    get events and mountall will still exit.
  * Try mounts again if another network device comes up while we were
    waiting.

 -- Scott James Remnant <email address hidden> Tue, 13 Oct 2009 02:17:47 +0100

Changed in mountall (Ubuntu Karmic):
status: Fix Committed → Fix Released
Commoner (commoner51) wrote :

Great that this bug has been fixed! When can I download Kubuntu Karmic cd-image with this new version of mountall?

Tom Pino (metalsmith-rangeweb) wrote :

I am trying to upgrade from 9.04 to 9.10. Dist-upgrade fails due to too many errors. The root of those errors seems to be the inability to configure dbus due to the lack of this file.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers