mountall: /proc/filesystems: No such file or directory

Bug #447947 reported by Jan Včelák on 2009-10-10
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
mountall (Ubuntu)
Medium
Scott James Remnant (Canonical)
Karmic
Medium
Scott James Remnant (Canonical)

Bug Description

Binary package hint: mountall

After upgrading mountall to version 0.21 my system hangs immediately after loading kernel with this message:

EXT4-fs: mballoc enabled
EXT4-fs: (sda1): mounted filesystem with ordered data mode
VFS: Mounted root (ext4 filesystem) readonly on device 8:1.
Freeing unused kernel memory: 464k freed
Write protecting the kernel read-only data: 4104k
mountall: /proc/filesystems: No such file or directory
init: mountall main process (1030) killed by SEGV signal
rm: cannot remove '/forcefsck': Read-only file system
init: mountall post-stop process (1031) terminated with status 1

I rebooted and appended init=/bin/bash to kernel parameters. There was no /forcefsck file present. In spite of that I run "fsck -f /dev/sda1" but no problem was found. After next reboot the same information appeared again system hanged again.

I rebooted again with 'init=/bin/bash', downloaded mountall_0.1.8_amd64.deb from repository FTP and installed it. After reboot everything works well.

Robert Gerlach (khnz) wrote :

Same issue here, SEGV in mountall.

(gdb) bt
#0 strcmp () at ../sysdeps/i386/i686/strcmp.S:39
#1 0x00e7b608 in parse_mountinfo () at mountall.c:821
#2 0x00e824f2 in main (argc=1, argv=0xbffff7f4) at mountall.c:2852

Second dup of this bug, thanks Jan. Pretty obvious too, you didn't have an initramfs I take it?

summary: - system hangs on startup
+ mountall: /proc/filesystems: No such file or directory
Changed in mountall (Ubuntu):
status: New → Triaged
importance: Undecided → Medium

On Sat, 2009-10-10 at 12:01 +0000, Robert Gerlach wrote:

> Same issue here, SEGV in mountall.
>
> (gdb) bt
> #0 strcmp () at ../sysdeps/i386/i686/strcmp.S:39
> #1 0x00e7b608 in parse_mountinfo () at mountall.c:821
> #2 0x00e824f2 in main (argc=1, argv=0xbffff7f4) at mountall.c:2852
>
Actually Robert, that's *very* definitely a different bug. Could you
please file it as a new bug and attach your patch there so I don't lose
track of it.

Thanks,

Scott
--
Scott James Remnant
<email address hidden>

Jan Včelák (jvcelak) wrote :

Scott, I went trough reported bugs before reporting this one and I think this is another problem. But maybe I'm wrong.

As for the initramfs: No, you aren't right. I have self compiled kernel (2.6.31.1) and don't use initramfs. The only change I made was downgrading the mountall package from 0.2.1 to 0.1.8.

Are you sure it has nothing to do with Robert's SEGV? It seems similar to me.

Thanks

Jan

Ulrich Lukas (ulrich-lukas) wrote :

Same problem here since upgrade yesterday.

mountall crashes with SEGV at boot.

No recovery console is displayed (this might also have to do with the installed cryptsetup package, as other bugreports suggest).

After downgrade to 0.1.8 the system boots normally again.

(For other people with the same problem: mountall 0.1.8 binary packages are available for download here:
https://launchpad.net/ubuntu/+source/mountall/0.1.8/)

What might be relevant is that when booting the Ubuntu provided binary kernel package (2.6.31-10-generic) the SEGV is not displayed (but for me, the system still doesn't boot with that kernel package).

I'm running a vanilla 2.6.31.1 with no initrd. AMD64.

Ulrich Lukas (ulrich-lukas) wrote :

If there is a chance this breaks working setups for users who upgrade when Karmic-final is released, this bugreport should be rated release-critical, IMHO.

Since I upgrade mountall, this bug affects me too only with myself compiled kernel built without initramfs.
It doesn't happen with Ubuntu kernel.

On Sat, 2009-10-10 at 19:38 +0000, Jan Včelák wrote:

> Scott, I went trough reported bugs before reporting this one and I think
> this is another problem. But maybe I'm wrong.
>
I entirely agree, the missing /proc/filesystems issue is entirely
separate from any SEGV issue.

> As for the initramfs: No, you aren't right. I have self compiled kernel
> (2.6.31.1) and don't use initramfs. The only change I made was
> downgrading the mountall package from 0.2.1 to 0.1.8.
>
This was what I was confirming - I suspected you did not have an
initramfs.

> Are you sure it has nothing to do with Robert's SEGV? It seems similar
> to me.
>
Yes, very sure. The /proc/filesystems issue is simply that the code in
mountall to mount /proc is in the wrong place ;-)

Scott
--
Scott James Remnant
<email address hidden>

Changed in mountall (Ubuntu Karmic):
milestone: none → ubuntu-9.10
assignee: nobody → Scott James Remnant (scott)
Changed in mountall (Ubuntu Karmic):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mountall - 0.2.2

---------------
mountall (0.2.2) karmic; urgency=low

  [ Steve Langasek ]
  * Don't emit the local-filesystem signal until after virtual filesystems
    are also done mounting. LP: #448981.

  [ Robert Gerlach ]
  * Fix segfault when root filesystem missing from fstab, or listed
    as /dev/root. LP: #448323.

  [ Johan Kiviniemi ]
  * Don’t queue filesystem check when either device or type is "none".

  [ Scott James Remnant ]
  * Removed /srv from the list of "essential" mountpoints. LP: #448267.
  * Allow overriding of the above list by using the "bootwait" and
    "nobootwait" fstab options, e.g.

    LABEL=foo /home ext4 nobootwait 0 0

  * Mount /proc before attempting to parse /proc/filesystems. LP: #447947.
  * Further improvements to event tagging of filesystems. A virtual bootwait
    filesystem underneath a local or remote filesystem inherits that tag,
    a local bootwait filesystem underneath a remote filesystem inherits that
    tag, remote filesystems do not inherit them. LP: #447654.

  * Replace previous hardcoded "arch specific" flag for /spu with an
    "optional" fstab mount option.
  * Made binfmt_misc,fusectl, debugfs, securityfs and /lib/init/rw optional
    as well.
  * Check whether the mountpoint of optional fstab entries exists before
    trying to mount, and skip over that if it doesn't. LP: #447525.

  * Keep /proc/self/mountinfo open, if it changes while we're running,
    update the knowledge of the mount table and what's mounted. That
    way if something else mounts it while mountall running, you'll still
    get events and mountall will still exit.
  * Try mounts again if another network device comes up while we were
    waiting.

 -- Scott James Remnant <email address hidden> Tue, 13 Oct 2009 02:17:47 +0100

Changed in mountall (Ubuntu Karmic):
status: Fix Committed → Fix Released
Dave North (north) wrote :

Fix worked here on kernel.org 2.6.31.3 with no initrd. Looking good.

Jan Včelák (jvcelak) wrote :

Thanks Scott! It's working.

The problem persists here after upgrading to 0.2.2 (0.1.8 works)

Sorry, Jonathan, but you're going to need to prove that.

Please take a photo of the screen with the error message you see on it

Stevan Kew Ell (slql) wrote :

 I can also confirmn that 0.2.2 does not work on an IBM X31. The boot process works up to the disk fsck, then simply stops. 0.1.8 works perfectly. It's a definitive issue, repeatable enough for me to have wrtten a script to recover using the Live CD after an update.

On Wed, 2009-10-14 at 15:27 +0000, Stevan Kew Ell wrote:

> I can also confirmn that 0.2.2 does not work on an IBM X31. The boot
> process works up to the disk fsck, then simply stops. 0.1.8 works
> perfectly. It's a definitive issue, repeatable enough for me to have
> wrtten a script to recover using the Live CD after an update.
>
Do you see the error message that is the title of this bug report?

Scott
--
Scott James Remnant
<email address hidden>

@Scott,
Don't be sorry ;-)

You're right, after disabling the splash and quiet, I can confirm that the error message is gone. However the boot process is still stucked and works again after downgrading mountall.

I'll have a hand on this computer later this afternoon and will open a new bug report if Stevan doesn't beat me to it.

Stevan Kew Ell (slql) wrote :

@Scoot - comment 15
No, as Jonathan says in comment 16, nothing further appears on the screen after the fsck, in my case of the two partitions I run, has completed. This is with any version of mountall above 0.1.8

S

Stevan Kew Ell (slql) wrote :

Attached is a photo of the screen at the point at which the boot process hangs, with "quiet splash" removed from grub2. My systems was re-installed from scratch a few days ago, and the screen pic was taken after this morning's update. This is with mountall 0.2.2, in other words. Standard generic kernel. Hope that helps.

S

On Thu, 2009-10-15 at 07:52 +0000, Stevan Kew Ell wrote:

> ** Attachment added: "Boot screen at hanging stage"
> http://launchpadlibrarian.net/33719077/DSCN2591.JPG
>
This image does not show the error:

mountall: /proc/filesystems: No such file or directory

Scott
--
Scott James Remnant
<email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches