trailing slashes in fstab cause problems

Bug #443035 reported by mmaura on 2009-10-05
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
mountall (Ubuntu)
Medium
Scott James Remnant (Canonical)
Karmic
Medium
Scott James Remnant (Canonical)

Bug Description

If /etc/fstab contain error the boot process stop with no error message, in safe-mode too.

I think boot process must put a panic console like previous version of ubuntu.

In my case i have add the line :

/mnt/disk/home /home none defaults,bind 0 1

instead

/mnt/disk/home/ /home/ none defaults,bind 0 1

Philip Muškovac (yofel) on 2009-10-05
affects: ubuntu → mountall (Ubuntu)
Changed in mountall (Ubuntu):
status: New → Confirmed

Could you confirm - it stopped when you had the trailing / - removing the trailing / fixed the problem?

Changed in mountall (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
summary: - karmic ubuntu-boot-experience boot stop when fstab is incorrect
+ trailing slashes in fstab cause problems
Changed in mountall (Ubuntu):
status: Incomplete → Triaged
milestone: none → ubuntu-9.10
status: Triaged → In Progress
assignee: nobody → Scott James Remnant (scott)
Changed in mountall (Ubuntu Karmic):
status: In Progress → Fix Committed

I've uploaded a new mountall package to the ubuntu-boot PPA:

https://launchpad.net/~ubuntu-boot/+archive/ppa

I would appreciate it if you could install this and try it out. *BEFORE* you reboot though, could you run "sudo mountall --debug > mountall.log 2>&1" and attach that to this bug - then after you reboot, let me know whether it worked or not.

Thanks

mmaura (mmaura66) wrote :

first i put the error on my fstab.
i run "sudo mountall --debug > mountall.log 2>&1" (see attachement)

after i reboot...

at boot time the panic console spawn but the boot proccess continu, and getty spawn too, so tty1 are unusable. i go to tty2.

root filesystem (/) are mount readonly and my /home are not mounted.

i run "sudo mount / -o remount" this work fine and gdm run automatically.

i run "sudo mount /home" **BEFORE correct my fstab** and mount success !

i correct my fstab and reboot and all precedent errors repeat (with a fstab correct)

On Thu, 2009-10-08 at 14:30 +0000, mmaura wrote:

> at boot time the panic console spawn but the boot proccess continu, and
> getty spawn too, so tty1 are unusable. i go to tty2.
>
Sorry about that, a bit of a think-o - new version uploaded to the PPA
should fix that, I'd appreciate further testing.

Scott
--
Scott James Remnant
<email address hidden>

Sorry about the issues with the previous PPA versions, as usual things worked just fine when I tested it in the various rigs I have here - of course it flatly failed when installed on normal systems because I hadn't actually tested that ;)

I've uploaded a new ~boot4 version, this one feels much better (and I'm running it on my laptop now :p)

As before, after installing the package but *before* you reboot, please run with --debug and attach the log to the bug - then after rebooting, let me know how it works out.

Thanks for all your help with testing, this is a big change and it's good to know that it's now working for 95% of people and your help getting it work for the final 5% is greatly appreciated!

mmaura (mmaura66) wrote :

for information ~boot3 make error about fsck:

fsck: fsck.none not found
fsck: error 2 while executing fsck.none for /mnt/disk/home

system freeze with no error panic console.
it must be remembered that the type of file system is ** none ** bind as it is

i try ~boot4 and post result.

mmaura (mmaura66) wrote :

With ~boot4:

Partitions are correctly mounted.

error message about fsck.none are always displayed.

I m happy to help.

On Fri, 2009-10-09 at 12:26 +0000, mmaura wrote:

> error message about fsck.none are always displayed.
>
Could you attach your /etc/fstab? This is usually the result of
something other than "0" in the final column for something that's not a
device.

Scott
--
Scott James Remnant
<email address hidden>

mmaura (mmaura66) wrote :

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda3 during installation
UUID=8d5373b1-b77f-4634-9d87-679ba9db8e70 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda4 during installation
UUID=bfa546dc-ae8e-44ca-8a12-f0ea918ba173 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

UUID=04c72f7a-e32f-4125-ad9b-46a5a7570a50 /mnt/disk ext3 errors=remount-ro 0 1
/mnt/disk/home /home none defaults,bind 0 1

mmaura (mmaura66) wrote :

actually shown on the last line

Right, change the 0 1 on the last line to 0 0

mmaura (mmaura66) wrote :

good it s work now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mountall - 0.2.0

---------------
mountall (0.2.0) karmic; urgency=low

  [ Colin Watson ]
  * Always check the root filesystem if --force-fsck is used, regardless of
    passno. LP: #435707.

  [ Johan Kiviniemi ]
  * Have each fsck instance create a lock for each underlying physical device.
    If you have a single disk or RAID, all filesystem checks will happen
    sequentially in order to avoid thrashing. On more complex configurations,
    you’ll benefit from the parallel checks mountall has been doing all along.
    LP: #434974.

  [ Scott James Remnant ]
  * Flush standard output and error before spawning processes to make
    capturing logs easier (otherwise we end up repeating things still in
    the buffer), and before calling exec().
  * Turn the code upside down so that each mount knows what it's waiting
    for, and allow multiple dependencies. This makes the code much more
    readable putting the "policy" in a single function, and will make it
    much easier in future when this is done by Upstart.
  * For kernel filesystems listed in fstab, honour the order that they
    are listed in fstab. LP: #432571, #433537, #436796
  * Always create new swap partition mounts for each fstab entry, don't
    treat them as updating the same. LP: #435027.
  * Virtual filesystems under local or remote filesystems (and local under
    remote) don't delay the virtual or local events. LP: #431040.
  * Simplify event emission, this has the advantage that we can now output
    what mount points we're waiting for and what they are waiting for as
    well.
  * Fixed issue with trailing slashes. LP: #443035.
  * Only run hooks if the filesystem was not already mounted. LP: #444252.
  * Don't clean up /tmp when run without --tmptime argument.
  * Ignore loop and ram devices until ready. LP: #441454.
  * Add options to binfmt_misc filesystem, which will probably cause it to
    be mounted on boot as well.
  * Synchronously mount local and virtual filesystems, I suspect this is
    the real cause behind the XFS races as one will modprobe and the other
    will not (and fail). LP: #432620.
  * Synchronously activate swap to avoid out of memory issues when checking
    the root filesystem.
  * Enumerate existing udev devices on startup, so we don't always have to
    see udev be coldplugged.
  * Don't break on general errors for non-essential filesystems.
    LP: #441144.
  * Don't repeat attempts to mount a filesystem without having first
    succeded to mount another.
  * Still restart mountall even if the recovery shell fails.
  * Don't queue filesystem check when device is "none", or missing, or the
    filesystem is marked nodev.
  * Generate a "mount" event before mounting a filesystem, and wait for its
    effects to complete.

 -- Scott James Remnant <email address hidden> Fri, 09 Oct 2009 16:50:46 +0100

Changed in mountall (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers