bindfs fuse not mounted

Bug #436796 reported by Chris Coulson on 2009-09-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mountall (Ubuntu)
Medium
Scott James Remnant (Canonical)
Karmic
Medium
Scott James Remnant (Canonical)

Bug Description

Binary package hint: mountall

Actually, I'm not entirely sure if this is just specific to bindfs, or whether it affects other FUSE filesystems. I have 2 bindfs mounts in my fstab, which currently don't mount automatically. The 2 fstab entries are:

#/home/.shared /home/shared fuse.bindfs group=shared-rw,perms=0000:u+rwD:g+rwD:o+rD 0 0
#/home/.chris+jo /home/chris+jo fuse.bindfs mirror=@chrisandjo-rw,group=chrisandjo-ro,perms=0000:u+rwD:g+rD 0 0

mountall.log shows the output of "sudo mountall --debug" when the filesystems haven't been mounted. It shows these 2 lines (not sure if they're significant):

children_ready: skipped /home/chris+jo
children_ready: skipped /home/shared

If I run mountall whilst the filesystems are already mounted, I see a different output (mountall-2.log, attached also):

run_mount: mtab /home/shared
spawn: mount -f -a -t fuse.bindfs -o group=shared-rw,perms=0000:u+rwD:g+rwD:o+rD bindfs /home/shared
spawn: mount /home/shared [17199]
mount /home/shared [17199] exited normally
run_mount: mtab /home/chris+jo
spawn: mount -f -a -t fuse.bindfs -o mirror=@chrisandjo-rw,group=chrisandjo-ro,perms=0000:u+rwD:g+rD bindfs /home/chris+jo
spawn: mount /home/chris+jo [17200]
mount /home/chris+jo [17200] exited normally

If I manually run "sudo mount -f -a -t fuse.bindfs -o group=shared-rw,perms=0000:u+rwD:g+rwD:o+rD bindfs /home/shared" (which seems to be what mountall is doing) then it doesn't work anyway, so I'm not sure if mount is being called correctly here. However, if I manually run "sudo mount -f -a -t fuse -o group=shared-rw,perms=0000:u+rwD:g+rwD:o+rD bindfs#/home/.shared /home/shared", then it works ok (/sbin/mount calls /sbin/mount.fuse, which spawns /usr/bin/bindfs, and mounts the filesystem)

ProblemType: Bug
Architecture: amd64
Date: Fri Sep 25 19:31:11 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: mountall 0.1.8
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
SourcePackage: mountall
Uname: Linux 2.6.31-10-generic x86_64

Chris Coulson (chrisccoulson) wrote :
Chris Coulson (chrisccoulson) wrote :
Chris Coulson (chrisccoulson) wrote :
Changed in mountall (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - Doesn't mount some FUSE filesystems
+ bindfs fuse not mounted
Changed in mountall (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Scott James Remnant (scott)
milestone: none → ubuntu-9.10
Changed in mountall (Ubuntu Karmic):
status: In Progress → Fix Committed

I've uploaded a new mountall package to the ubuntu-boot PPA:

https://launchpad.net/~ubuntu-boot/+archive/ppa

I would appreciate it if you could install this and try it out. *BEFORE* you reboot though, could you run "sudo mountall --debug > mountall.log 2>&1" and attach that to this bug - then after you reboot, let me know whether it worked or not.

Thanks

Sorry about the issues with the previous PPA versions, as usual things worked just fine when I tested it in the various rigs I have here - of course it flatly failed when installed on normal systems because I hadn't actually tested that ;)

I've uploaded a new ~boot4 version, this one feels much better (and I'm running it on my laptop now :p)

As before, after installing the package but *before* you reboot, please run with --debug and attach the log to the bug - then after rebooting, let me know how it works out.

Thanks for all your help with testing, this is a big change and it's good to know that it's now working for 95% of people and your help getting it work for the final 5% is greatly appreciated!

Chris Coulson (chrisccoulson) wrote :

Here is a log from the latest version. I haven't actually tried rebooting yet, but it seems to be doing the right thing on a running system now anyway. Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mountall - 0.2.0

---------------
mountall (0.2.0) karmic; urgency=low

  [ Colin Watson ]
  * Always check the root filesystem if --force-fsck is used, regardless of
    passno. LP: #435707.

  [ Johan Kiviniemi ]
  * Have each fsck instance create a lock for each underlying physical device.
    If you have a single disk or RAID, all filesystem checks will happen
    sequentially in order to avoid thrashing. On more complex configurations,
    you’ll benefit from the parallel checks mountall has been doing all along.
    LP: #434974.

  [ Scott James Remnant ]
  * Flush standard output and error before spawning processes to make
    capturing logs easier (otherwise we end up repeating things still in
    the buffer), and before calling exec().
  * Turn the code upside down so that each mount knows what it's waiting
    for, and allow multiple dependencies. This makes the code much more
    readable putting the "policy" in a single function, and will make it
    much easier in future when this is done by Upstart.
  * For kernel filesystems listed in fstab, honour the order that they
    are listed in fstab. LP: #432571, #433537, #436796
  * Always create new swap partition mounts for each fstab entry, don't
    treat them as updating the same. LP: #435027.
  * Virtual filesystems under local or remote filesystems (and local under
    remote) don't delay the virtual or local events. LP: #431040.
  * Simplify event emission, this has the advantage that we can now output
    what mount points we're waiting for and what they are waiting for as
    well.
  * Fixed issue with trailing slashes. LP: #443035.
  * Only run hooks if the filesystem was not already mounted. LP: #444252.
  * Don't clean up /tmp when run without --tmptime argument.
  * Ignore loop and ram devices until ready. LP: #441454.
  * Add options to binfmt_misc filesystem, which will probably cause it to
    be mounted on boot as well.
  * Synchronously mount local and virtual filesystems, I suspect this is
    the real cause behind the XFS races as one will modprobe and the other
    will not (and fail). LP: #432620.
  * Synchronously activate swap to avoid out of memory issues when checking
    the root filesystem.
  * Enumerate existing udev devices on startup, so we don't always have to
    see udev be coldplugged.
  * Don't break on general errors for non-essential filesystems.
    LP: #441144.
  * Don't repeat attempts to mount a filesystem without having first
    succeded to mount another.
  * Still restart mountall even if the recovery shell fails.
  * Don't queue filesystem check when device is "none", or missing, or the
    filesystem is marked nodev.
  * Generate a "mount" event before mounting a filesystem, and wait for its
    effects to complete.

 -- Scott James Remnant <email address hidden> Fri, 09 Oct 2009 16:50:46 +0100

Changed in mountall (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers