var partition reported as mounted to /dev/.var

Bug #434172 reported by Chris Clonch on 2009-09-21
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
mountall (Ubuntu)
Medium
Scott James Remnant (Canonical)

Bug Description

Binary package hint: mountall

Applied latest updates this morning (2009/09/21) to my Kubuntu 9.10 system, rebooted, and now df and mount report my LVM var partition mounted to /dev/.var on a fresh boot. However /proc/mounts reports it correctly mounted as /var and everything is there leading me to believe it really is mounted at /var. All other partitions mount correctly. Manually running mountall post boot seems to fix df and mount.

Snippets from those involved:

root@darth:~# blkid /dev/vg00/lv_var
/dev/vg00/lv_var: UUID="f7a2ecbc-34b6-40b0-94e1-6bbb97f16091" TYPE="ext4"

root@darth:~# grep var /etc/fstab
# /dev/mapper/vg00-lv_var
UUID=f7a2ecbc-34b6-40b0-94e1-6bbb97f16091 /var ext4 relatime,defaults 0 2

root@darth:~# cat /proc/mounts |grep lv_var
/dev/mapper/vg00-lv_var /var ext4 rw,relatime,barrier=1,data=ordered 0 0

root@darth:~# mount |grep lv_var
/dev/mapper/vg00-lv_var on /dev/.var type ext4 (rw,relatime)

root@darth:~# df -h |grep lv_var
df: `/dev/.var': No such file or directory

Changed in mountall (Ubuntu):
assignee: nobody → Scott James Remnant (scott)
importance: Undecided → Medium
milestone: none → ubuntu-9.10-beta
status: New → Triaged
Changed in mountall (Ubuntu):
status: Triaged → Fix Committed

The ubuntu-boot PPA has a new version of mountall which I hope will fix this problem, please install that and let me know how it works out.

Stefan Fleiter (stefan-fleiter) wrote :

I had the same problem and can confirm this is fixed with
mountall 0.1.7~boot2 from ubuntu-boot PPA.

Chris Clonch (cacack) wrote :

Yes, I confirm this fixes the problem. With mountall_0.1.7~boot2 df and mount now correctly report my var partition's mountpoint after a fresh boot. I did have and issue with installing using apt-get and the ppa though. 0.1.7 ranks higher and so it refused to download/install 0.1.7~boot2. I had to manually download and install using dpkg. No biggie, just wanted to inform.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mountall - 0.1.8

---------------
mountall (0.1.8) karmic; urgency=low

  [ Scott James Remnant ]
  * Further work on the fix from the previous version where the root
    filesystem would always be considered "local", retain that from the
    POV of the {virtual,local,remote}-filesystems events, but do mount
    the root straight away when it's virtual since there's no device to
    wait until it's ready. LP: #431204.
  * If a remote filesystem is already mounted and doesn't need a remount,
    don't wait for a network device to come up. LP: #430348.

  * Ignore single and double quotes in fstab device specifications, since
    mount -a used to. LP: #431064.
  * Never write mtab when mounting a mount with showthroughs (ie. /var)
    and instead update mtab once we've moved it into place
    later. LP: #434172.

  [ Kees Cook ]
  * src/mountall.c: rework nftw hooks to use a global for argument passing
    instead of using nested functions and the resulting trampolines that
    cause an executable stack. LP: #434813.
  * debian/rules: revert powerpc exception, since the cause is fixed by
    removing the nested functions.

 -- Scott James Remnant <email address hidden> Wed, 23 Sep 2009 14:19:01 -0700

Changed in mountall (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers