can't write mtab when /etc/mtab~ exists

Bug #431865 reported by Matthias Klose on 2009-09-17
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
mountall (Ubuntu)
Medium
Scott James Remnant (Canonical)
Karmic
Medium
Scott James Remnant (Canonical)

Bug Description

Binary package hint: mountall

for some reason (pressed reset during reboot) I had an /etc/mtab~ file, which prevented mountall to continue the boot. The message was given for every fs which was tried to mount. Didn't wait for it to finish, but just removed the file manually.

Changed in mountall (Ubuntu):
status: New → Triaged
summary: - boot hangs/is delayed when lockfile /etc/mtab~ exists
+ can't write mtab when /etc/mtab~ exists
Changed in mountall (Ubuntu):
importance: Undecided → Medium

Haven't found any reason not to just unlink this, so let's do that

Changed in mountall (Ubuntu Karmic):
assignee: nobody → Scott James Remnant (scott)
milestone: none → ubuntu-9.10
status: Triaged → Fix Committed
Jesse Michael (jesse.michael) wrote :

Is the fix actually out to the mirrors? I ran into this bug and was still getting hit by it even after updating and rebooting less than an hour ago.

Jesse Michael (jesse.michael) wrote :

Nevermind, I didn't realize there was a difference between "Fix Committed" and "Published".

I've uploaded a new version of mountall (0.2.5) to the ubuntu-boot PPA, as usual I would appreciate a little testing before I upload it to the archive proper.

Thanks

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mountall - 0.2.5

---------------
mountall (0.2.5) karmic; urgency=low

  * Filesystem check progress reporting, including cancellation. LP: 446596.
  * When we're waiting for a mountpoint, if a few seconds of inactivity
    passes, report what we're waiting for and allow Escape to drop you to
    a recovery shell.
  * Start usplash for filesystem check progress reporting or when we've
    been waiting for more than a few seconds. LP: #431184.

  * Hide error removing /forcefsck, people mis-report this as a bug and
    don't tell us the error above it.
  * Don't call mount.ecryptfs or mount.aufs when adding an entry for
    /etc/mtab; these helpers are broken and do not support the -f argument.
    This means your passphrase may end up in /etc/mtab, blame them not me.
    LP: #431954, #443080.
  * Unlink /etc/mtab~ after creating/truncating /etc/mtab and before writing
    mtab entries. LP: #431865.
  * Stop the recovery shell if the user runs shutdown within it, so we
    don't run mountall again. LP: #452196.
  * If the root filesystem check fails, we'll need to reboot, so just have
    the recovery shell script do that.

  * Post-review logic fixes.

 -- Scott James Remnant <email address hidden> Tue, 20 Oct 2009 12:19:16 +0100

Changed in mountall (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers