arguments to dbus_server_disconnect() were incorrect

Bug #1066144 reported by Paul Larson on 2012-10-12
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
mountall (Ubuntu)
High
Unassigned

Bug Description

With postfix installed, I'm getting the following error in my boot.log
process 268: arguments to dbus_server_disconnect() were incorrect, assertion "old_refcount > 0" failed in file ../../dbus/dbus-server.c line 786
process 268: arguments to dbus_server_unref() were incorrect, assertion "old_refcount > 0" failed in file ../../dbus/dbus-server.c line 749

Complete boot.log can be seen at:
http://paste.ubuntu.com/1275728

If I remove postfix, the error goes away. I've tried uninstalling several other packages that actually depend on libdbus, but so far as long as postfix is installed, it still gets the error.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: postfix 2.9.3-2ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
ApportVersion: 2.6.1-0ubuntu3
Architecture: i386
Date: Fri Oct 12 16:27:53 2012
InstallationMedia: Ubuntu-Server 12.10 "Quantal Quetzal" - Release i386 (20121012.1)
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: postfix
UpgradeStatus: No upgrade log present (probably fresh install)

Paul Larson (pwlars) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1066144

tags: added: iso-testing
Scott Kitterman (kitterman) wrote :

Postfix doesn't use dbus. Perhaps upstart is doing something.

affects: postfix (Ubuntu) → upstart (Ubuntu)
Paul Larson (pwlars) on 2012-10-12
tags: added: qa-manual-testing rls-q-incoming
James Hunt (jamesodhunt) wrote :

I don't believe this is an Upstart issue: The current version of Upstart does have code to call dbus_server_disconnect(), but this code is never actually run (since Upstart never "shuts down" itself). Additionally, if it were an Upstart issue, according to that log, the assertion would have failed on boot, which would have caused Upstart to crash and a kernel panic to ensue.

So, there must be some other application that is using D-Bus incorrectly. I'd suggest looking at the rdepends for libdbus-1-3. I wonder which set of postfix packages you have installed too? Also, you could conceivably disable each SysV init script and Upstart job in turn for the set of packages that trigger the problem to help hone in on the issue (I've installed "postfix" but cannot force the issue).

Changed in upstart (Ubuntu):
status: New → Incomplete
importance: Undecided → High
James Hunt (jamesodhunt) wrote :

Not an upstart issue fwics.

affects: upstart (Ubuntu) → postfix (Ubuntu)
James Hunt (jamesodhunt) wrote :

@Paul: Please can you specify which packages are newly installed for your to see this issue? Is it reproducable on other systems for you? As mentioned, I do not see this problem on vanilla quantal system + the postfix package installed.

Paul Larson (pwlars) wrote :

Note that I'm only seeing this with i386 it seems, not amd64. I was able to reproduce it easily as long as postfix was installed. If I removed postfix, the problem would go away, reinstall and it would come back. However I was just running in vbox, not on real hardware. I'll do an install on a physical system in just a bit and see if I can reproduce there also.

Paul Larson (pwlars) wrote :

Let me correct myself, I *did* just manage to reproduce it on amd64, but previously I thought when I tried, I did not see it show up on amd64, only on i386. Seems it is possible to reproduce it on amd64 after all.
First boot: bug
reboot: bug
sudo apt-get purge postfix (also removes bsd-mailx): no bug
sudo apt-get install postfix (bsd-mailx suggested, but not installed): bug
sudo apt-get purge postfix (and reboot of course): no bug

...
I can very reliably reproduce it when postfix is installed, and *not* reproduce it when postfix is removed.
Note that this is still in vbox, haven't had a chance to test on hardware yet due to lots of respins, but I haven't forgotten.

Walter Lapchynski (wxl) wrote :

don't see this on 20121017.2 ppc

Scott Kitterman (kitterman) wrote :

Postfix still doesn't use dbus.

affects: postfix (Ubuntu) → ubuntu
Sasa Paporovic (melchiaros) wrote :

dino99 wrote on report

https://bugs.launchpad.net/ubuntu/+source/dbus/+bug/1077581

------------------------------------------------------:

"
I'm not sure about the package to report against, might not be dbus as its the output. Get that error logged inside boot.log:

process 330: arguments to dbus_server_disconnect() were incorrect, assertion "old_refcount > 0" failed in file ../../dbus/dbus-server.c line 786.
This is normally a bug in some application using the D-Bus library.
process 330: arguments to dbus_server_unref() were incorrect, assertion "old_refcount > 0" failed in file ../../dbus/dbus-server.c line 749.
This is normally a bug in some application using the D-Bus library.

The lightdm.log is clean, and i dont have a plymouth.log; so maybe its related to 3.7.0.0.5 kernel i use (RR proposed)

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: dbus 1.6.4-1ubuntu4
ProcVersionSignature: Ubuntu 3.7.0-0.5-generic 3.7.0-rc4
Uname: Linux 3.7.0-0-generic i686
ApportVersion: 2.6.2-0ubuntu3
Architecture: i386
Date: Sun Nov 11 09:08:36 2012
MarkForUpload: True
SourcePackage: dbus
UpgradeStatus: No upgrade log present (probably fresh install)
"

Changed in ubuntu:
status: Incomplete → Confirmed
tags: added: raring
Sasa Paporovic (melchiaros) wrote :

A boot.log is available there.

dino99 (9d9) wrote :

About the #11 comment above, and the libdbus rdepends:

- i'm seeing that issue on RR i386 using "nouveau" , so it could be due some RR packages updates (like telepathy)
- there is no postfix on my side, but wine1.5, vlc, gnome, hal, pgld and the likes

note: that error is shown very early (in verbose mode) in the boot process after selecting a kernel to boot on: the 2 first lines are about fsck, then comes that error. So, at that time, it should be good to know which app/process is loaded.

note2: the apps list started at bootup are: wicd, kerneloops applet, gnome-user-share, gsettings-data-convert

So im wondering about that old "hal" still used by mountmanager (will remove mountmanager for testing, and will report back)

dino99 (9d9) wrote :

Feedback:
- i've purged mountmanager (hal still installed)
- then rebooted twice

none of the new cold boots have that error : so could it be a libqt4 issue ?

James Hunt (jamesodhunt) wrote :

I've just seen this error in a precise VM and the the error is coming from mountall.

affects: ubuntu → mountall (Ubuntu)
James Hunt (jamesodhunt) wrote :
James Hunt (jamesodhunt) wrote :

The mountall Upstart job currently specifies 'console output' such that it's output is *not* logged. However, either commenting out that stanza or changing it to 'console log' then rebooting results in a /var/log/upstart/mountall.log as attached in #17.

glmm (glmm-deactivatedaccount) wrote :

With me the message is showing up every now and then, not at every boot.

With me (Kubuntu 12.10 64) the message shows up at every boot.

Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal

I Have the same problem, other services raise the same error with dbus.

dino99 (9d9) wrote :

With the latest updates applied on RR i386 & kernel 3.7 final, now while booting in verbose mode, i get logged (as the very first lines):

fsck de util-linux 2.20.1
mountall: Event failed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers