mountall does not recognize option "nofail"

Bug #1027352 reported by ill on 2012-07-21
This bug report is a duplicate of:  Bug #610869: mountall ignores nofail mount option. Edit Remove
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mountall (Ubuntu)
Medium
Unassigned

Bug Description

The man page for mount describes the mount option "nofail" but it does not seem to be implemented in mountall. It probably should treat it as an alias for "nowait".

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1027352/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we cannot work on this bug because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures

At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).
Thanks!

Changed in ubuntu:
status: New → Incomplete
ill (illumilore) wrote :

1. the specific steps or actions you took that caused you to encounter the problem,

An entry in fstab was listed with the nofail option, but the drive was not present at bootup

2. the behavior you expected, and

I expected the machine to boot up

3. the behavior you actually encountered (in as much detail as possible).

It failed to boot up on its own, requiring user input to continue.

Changed in ubuntu:
status: Incomplete → Confirmed
Phillip Susi (psusi) wrote :

"failed to boot" and "required user input" are very vague. What sort of error message did you get, and what input did you give are the kind of details needed when reporting bugs.

Also mountall does not seem to recognize the option "nofail". You need to use "nowait".

affects: ubuntu → mountall (Ubuntu)
Changed in mountall (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
summary: - bootup fails if fstab entry is not present
+ mountall does not recognize option "nofail"
description: updated
Changed in mountall (Ubuntu):
importance: Low → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers