motion: FTBFS with ffmpeg 5.0

Bug #1982886 reported by Dan Bungert
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
motion (Debian)
Confirmed
Unknown
motion (Ubuntu)
Fix Released
Undecided
Steve Langasek

Bug Description

Imported from Debian bug http://bugs.debian.org/1004629:

| ffmpeg.c: In function ‘ffmpeg_get_oformat’:
| ffmpeg.c:343:67: error: assignment of member ‘video_codec’ in read-only object
| 343 | if (ffmpeg->oc->oformat) ffmpeg->oc->oformat->video_codec = MY_CODEC_ID_MPEG2VIDEO;
| |

+ similar

Tags: ftbfs
Dan Bungert (dbungert)
tags: added: ftbfs
description: updated
Revision history for this message
Dan Bungert (dbungert) wrote :

Backport commit from upstream around const usage and codec_id.

Changed in motion (Ubuntu):
status: New → Confirmed
Changed in motion (Debian):
importance: Undecided → Unknown
status: New → Confirmed
Revision history for this message
Steve Langasek (vorlon) wrote :

uploaded.

Changed in motion (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Steve Langasek (vorlon)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package motion - 4.3.2-1ubuntu1

---------------
motion (4.3.2-1ubuntu1) kinetic; urgency=medium

  * Backport FFMPEG 5 fixes (LP: #1982886)

 -- Dan Bungert <email address hidden> Tue, 26 Jul 2022 13:27:55 -0600

Changed in motion (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.