Ubuntu

Keyboard navigation of menus not working correctly

Reported by Graham Inggs on 2013-11-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
motif (Debian)
Fix Released
Unknown
motif (Ubuntu)
Undecided
Unassigned
Saucy
Medium
Brian Murray

Bug Description

[Impact]
Keyboard navigation of menus in applications built against Motif 2.3.4 is broken.
This is a regression for applications that were previously built against Lesstif but have been built against Motif in Saucy, see the transition bug LP: #1222747. The fix is an updated patch for upstream bug #1565 [1], provided by upstream.

[Test Case]
Install and run xball (or any other Motif application with a menu bar).
Click on 'File' in the menu bar (or press Alt-F).
Now press Left Arrow or Right Arrow and the highlight should move left and right through the horizontal menu options (File, Actions, Options and Help).
Now press Up Arrow, Down Arrow or Enter and nothing happens, the expect behaviour is that the highlight should move through the vertical menu options and the option be actioned.

[Regression Potential]
This patch affects the operation of ComboBox, PopupMenu, OptionMenu and DropDownList widgets in applications built against Motif.
The behaviour of the original bug #1565 and previous versions of the patch to fix it were different on different display managers / window managers. I have successfully tested the current patch in Unity, MWM, XFCE, FluxBox, LXDE, GNOME, KDE and Openbox.

In this SRU, I would like to include fixes for two additional bugs:
- the undefined use of sprintf in lib/Xm/XmRenderT.c where the source and destination buffers overlap (upstream bug #1628 [2])
- an array bounds error in lib/Xm/DataF.c where _XmDataFieldIsWSpace() is called with num_entries = 3 (upstream bug #1629 [3])
I believe the fixes for these are trivial and the regression potential for them is low.

[1] http://bugs.motifzone.net/show_bug.cgi?id=1565
[2] http://bugs.motifzone.net/show_bug.cgi?id=1628
[3] http://bugs.motifzone.net/show_bug.cgi?id=1629

Graham Inggs (ginggs) on 2013-11-27
description: updated
Changed in motif (Debian):
status: Unknown → New
Graham Inggs (ginggs) on 2013-12-03
Changed in motif (Ubuntu):
status: New → Fix Released
Changed in motif (Debian):
status: New → Fix Released
Graham Inggs (ginggs) wrote :
Graham Inggs (ginggs) on 2013-12-07
description: updated
Brian Murray (brian-murray) wrote :

I've uploaded this to the Saucy proposed queue.

Changed in motif (Ubuntu Saucy):
status: New → In Progress
assignee: nobody → Brian Murray (brian-murray)
importance: Undecided → Medium

Hello Graham, or anyone else affected,

Accepted motif into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/motif/2.3.4-4ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in motif (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed
Graham Inggs (ginggs) wrote :

Works for me. Thanks Brian!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package motif - 2.3.4-4ubuntu0.1

---------------
motif (2.3.4-4ubuntu0.1) saucy-proposed; urgency=low

  * Backport the following bug fixes from 2.3.4-5 in trusty:
    - Fix keyboard navigation of menus (LP: #1255473)
    - Fix array bounds error in lib/Xm/DataF.c
    - Fix undefined sprintf() usage
 -- Graham Inggs <email address hidden> Wed, 11 Dec 2013 13:19:39 -0800

Changed in motif (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.