Ubuntu

function keys are not working on byobu-tmux under mosh connection

Reported by Nobuto MURATA on 2012-07-25
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
byobu (Ubuntu)
Wishlist
Unassigned
mosh (Ubuntu)
Undecided
Keith Winstein

Bug Description

With a combination of byobu-tmux and mosh, some function keys (F2, F3, F4) are not working.

byobu 5.17-0ubuntu1
mosh 1.1.3-1

Steps to reproduce:
 1. connect remote-host with mosh
      local:~$ mosh remote-host
 2. launch byobu-tmux on remote-host
      remote:~$ byobu-tmux
 3. press F2

Expected result:
 open a new tab on byobu-tmux

Actual result:
 nothing happens

Additional information:
 * byobu-tmux without mosh (plain ssh) works.
      local:~$ ssh remote-host
      remote:~$ byobu-tmux
      F2 - OK
 * byobu-screen with mosh works.
      local:~$ mosh remote-host
      remote:~$ byobu-screen
      F2 - OK
 * if a pager is active, it works
      local:~$ mosh remote-host
      remote:~$ byobu-tmux
      remote:~$ less FILE
      F2 - OK

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: byobu 5.17-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
Uname: Linux 3.2.0-27-generic x86_64
ApportVersion: 2.0.1-0ubuntu11
Architecture: amd64
Date: Thu Jul 26 02:22:43 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=ja_JP.UTF-8
 SHELL=/bin/bash
ScreenRC:

SourcePackage: byobu
UpgradeStatus: No upgrade log present (probably fresh install)

Nobuto MURATA (nobuto) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in byobu (Ubuntu):
status: New → Confirmed
Kristian Kolev (kkolev) wrote :

Same problem here. Could this be related to the escape sequences mosh generates for the function keys?
There was a similar issue with putty and byobu: https://answers.launchpad.net/byobu/+question/117672

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mosh (Ubuntu):
status: New → Confirmed
Keith Winstein (keithw) wrote :

We believe this issue was fixed in mosh 1.2 (https://github.com/keithw/mosh/issues/161), which will be included in the next Ubuntu release. It is also available in the PPA (ppa:keithw/mosh).

Changed in mosh (Ubuntu):
status: Confirmed → Fix Released
assignee: nobody → Keith Winstein (keithw)
Dustin Kirkland  (kirkland) wrote :

Great, thanks, Keith.

Could someone please see if mosh 1.2 solves this problem in Byobu? Thanks!

Changed in byobu (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Wishlist
Serge Victor (ser) wrote :

No, it does not help. F2,F3 keys are still not available. With plain ssh they work.

$ mosh -v
mosh 1.2.3

1.2.3-0~855~precise1

Changed in byobu (Ubuntu):
status: Incomplete → Confirmed
Dustin Kirkland  (kirkland) wrote :

Mosh + Byobu + F-keys appear to be working just fine for me now.

I'm using mosh from Ubuntu 13.04 (1.2.4a) on the client and mosh from Debian 7.1 (1.2.3) on the server. I'm able to use all of the F-keys like I can in ssh.

Changed in byobu (Ubuntu):
status: Confirmed → Fix Released
Serge Victor (ser) wrote :

I can agree, mosh from ppa:keithw/mosh fixes the issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers