Sync morse-simulator 1.0.0-1~exp3 (universe) from Debian experimental (main)

Bug #1146637 reported by Sylvestre Ledru
32
This bug affects 2 people
Affects Status Importance Assigned to Milestone
morse-simulator (Ubuntu)
Fix Released
Wishlist
Unassigned

Bug Description

Please sync morse-simulator 1.0.0-1~exp3 (universe) from Debian experimental (main)

Explanation of the Ubuntu delta and why it can be dropped:
  * Rebuild against python3.3.
  * Build against python3-dev instead of python3.2-dev.
  * Call dh_python3.
  * Use python3:Depends, instead of python:Depends.
  * Use pkg-config to find python includes.

I merge Dmitrijs Ledkov changes into the debian package (thanks btw)

Changelog entries since current raring version 0.6~alpha-1~exp1ubuntu2:

morse-simulator (1.0.0-1~exp3) experimental; urgency=low

  * Fix a bad dependency (python:depends instead of python3:depends).

 -- Sylvestre Ledru <email address hidden> Tue, 05 Mar 2013 08:57:07 +0100

morse-simulator (1.0.0-1~exp2) experimental; urgency=low

   [ Dmitrijs Ledkov ]
   * Build against python3-dev instead of python3.2-dev.
   * Call dh_python3.
   * Use python3:Depends, instead of python:Depends.
   * Use pkg-config to find python includes.

 -- Sylvestre Ledru <email address hidden> Mon, 04 Mar 2013 18:02:01 +0100

morse-simulator (1.0.0-1~exp1) experimental; urgency=low

  * New upstream release

 -- Sylvestre Ledru <email address hidden> Sat, 02 Mar 2013 18:55:48 +0100

morse-simulator (1.0-beta1-1~exp1) experimental; urgency=low

  * New testing upstream release

 -- Sylvestre Ledru <email address hidden> Sat, 16 Feb 2013 10:38:22 +0100

morse-simulator (0.6-1~exp1) experimental; urgency=low

  * New upstream release
  * Update of the watch file
  * Tests disabled
  * Remove __pycache__ directories

 -- Sylvestre Ledru <email address hidden> Sun, 04 Nov 2012 13:55:01 +0100

Changed in morse-simulator (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Jamie Strandboge (jdstrand) wrote :

It currently FTBFS on raring:

dh build --with python3
   dh_testdir
   debian/rules override_dh_auto_configure
make[1]: Entering directory `/«PKGBUILDDIR»'
dh_auto_configure -- -DBUILD_DOC_SUPPORT=ON
-- The C compiler identification is GNU 4.7.2
-- The CXX compiler identification is GNU 4.7.2
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.26")
-- Found PythonInterp: /usr/bin/python3.2 (found suitable version "3.2.3", required is "3.2")
CMake Error at config/FindPythonLibs.cmake:179 (STRING):
  string sub-command SUBSTRING requires four arguments.
Call Stack (most recent call first):
  CMakeLists.txt:29 (find_package)

CMake Error at config/FindPackageHandleStandardArgs.cmake:97 (MESSAGE):
  Could NOT find PythonLibs (missing: PYTHON_LIBRARIES) (Required is exact
  version "3.2")
Call Stack (most recent call first):
  config/FindPackageHandleStandardArgs.cmake:288 (_FPHSA_FAILURE_MESSAGE)
  config/FindPythonLibs.cmake:218 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:29 (find_package)

-- Configuring incomplete, errors occurred!
dh_auto_configure: cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_VERBOSE_MAKEFILE=ON -DBUILD_DOC_SUPPORT=ON returned exit code 1
make[1]: *** [override_dh_auto_configure] Error 2
make[1]: Leaving directory `/«PKGBUILDDIR»'
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Changed in morse-simulator (Ubuntu):
status: New → In Progress
Revision history for this message
Arnaud Degroote (arnaud-degroote) wrote :

Hi, I'm one of the main morse-simulator developer.

The attached patch must handle the failure more properly. However, from what I understanding, you want to build morse-simulator against python3.3. In presence of both python3.2 and python3.3 interpreter, morse currently chooses python3.2 and the according dependencies (which does not seems to be installed on the build system). To force the build with python3.3, you can call

   cmake -DPYTHON_EXECUTABLE=/usr/bin/python3.3 <other_args>

I think it will solve your build issue.

Note that we will release soon a version 1.0.1 which contains various other fixes (including the proposed one).

Best regards,

Revision history for this message
Sylvestre Ledru (sylvestre) wrote :

I applied your fix in version 1.0.0-1~exp5
I uploaded in Debian experimental. Jamie, could you sync it ?
thanks

Revision history for this message
Sylvestre Ledru (sylvestre) wrote : any news

Hi

Any news on this subject ? (sync of morse from Debian to Ubuntu)

Thanks
S

Revision history for this message
Séverin Lemaignan (skadge) wrote :

morse-simulator 1.0.1 has been uploaded on debian, with the fix for the cmake configuration.

http://packages.debian.org/experimental/morse-simulator

Would it be possible to sync it?

Revision history for this message
Julian Taylor (jtaylor) wrote :

synced

Changed in morse-simulator (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers