Ubuntu

Moovida doesn't start with a Turkish locale

Reported by lipstick on 2010-05-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Elisa Media Center
Critical
Olivier Tilloy
Moovida
Critical
Fernando Carvalho
moovida (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: moovida

When i try to run moovida, i get these errors

Launcher core version: 1.0.9
Current core version: 1.0.9
Traceback (most recent call last):
  File "/usr/bin/moovida", line 9, in <module>
    load_entry_point('elisa==1.0.9', 'gui_scripts', 'elisa')()
  File "/usr/lib/pymodules/python2.6/elisa/core/launcher.py", line 398, in main
    Launcher().main(sys.argv)
  File "/usr/lib/pymodules/python2.6/elisa/core/launcher.py", line 83, in main
    return self.main_after_voodoo(argv)
  File "/usr/lib/pymodules/python2.6/elisa/core/launcher.py", line 230, in main_after_voodoo
    self.run_application()
  File "/usr/lib/pymodules/python2.6/elisa/core/launcher.py", line 365, in run_application
    from elisa.core.application import Application
  File "/usr/lib/pymodules/python2.6/elisa/core/application.py", line 37, in <module>
    from elisa.core import media_uri
  File "/usr/lib/pymodules/python2.6/elisa/core/media_uri.py", line 29, in <module>
    from elisa.extern.translation import Translatable
  File "/usr/lib/pymodules/python2.6/elisa/extern/translation.py", line 31, in <module>
    from twisted.spread import pb
  File "/usr/lib/python2.6/dist-packages/twisted/spread/pb.py", line 49, in <module>
    from twisted.spread.jelly import jelly, unjelly, globalSecurity
  File "/usr/lib/python2.6/dist-packages/twisted/spread/jelly.py", line 89, in <module>
    import decimal
  File "/usr/lib/python2.6/decimal.py", line 3606, in <module>
    val = globals()[globalname]
KeyError: 'ROUND_CEiLiNG'

In my opinion, it is because of I am a Turkish locale user.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: moovida 1.0.9+bzr1614-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
Architecture: i386
Date: Sat May 22 12:29:53 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
PackageArchitecture: all
ProcEnviron:
 LANG=tr_TR.utf8
 SHELL=/bin/bash
SourcePackage: moovida

Related branches

lipstick (sinanaykut-gmail) wrote :
Olivier Tilloy (osomon) wrote :

I can reliably reproduce when running with LANG=tr_TR.UTF-8.
See the related http://bugs.python.org/issue1813.

Changed in moovida (Ubuntu):
status: New → Confirmed
summary: - moovida crashes while trying to run
+ Moovida doesn't start with a Turkish locale
Changed in moovida:
importance: Undecided → Critical
status: New → Confirmed
tags: added: startup
removed: i386 lucid ubuntu-unity
Olivier Tilloy (osomon) wrote :

As already discussed in bug #310826, this is an issue in Python itself. Nevertheless, it doesn't seem it's going to be fixed there anytime soon, so we should try and find a workaround in Moovida.

Olivier Tilloy (osomon) on 2010-05-24
Changed in elisa:
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → Critical
status: New → In Progress
boracasli (mac-os-9-bora) wrote :

bu sorun nereden çıktı?

Moovida'yı başlatacağım sırada yaşadım.

2010/5/28 boracasli <email address hidden>

> bu sorun nereden çıktı?
>
> --
> Moovida doesn't start with a Turkish locale
> https://bugs.launchpad.net/bugs/584161
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Elisa Media Center: In Progress
> Status in Moovida (formerly Elisa), a universal and user-friendly media
> center: Confirmed
> Status in “moovida” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: moovida
>
> When i try to run moovida, i get these errors
>
> Launcher core version: 1.0.9
> Current core version: 1.0.9
> Traceback (most recent call last):
> File "/usr/bin/moovida", line 9, in <module>
> load_entry_point('elisa==1.0.9', 'gui_scripts', 'elisa')()
> File "/usr/lib/pymodules/python2.6/elisa/core/launcher.py", line 398, in
> main
> Launcher().main(sys.argv)
> File "/usr/lib/pymodules/python2.6/elisa/core/launcher.py", line 83, in
> main
> return self.main_after_voodoo(argv)
> File "/usr/lib/pymodules/python2.6/elisa/core/launcher.py", line 230, in
> main_after_voodoo
> self.run_application()
> File "/usr/lib/pymodules/python2.6/elisa/core/launcher.py", line 365, in
> run_application
> from elisa.core.application import Application
> File "/usr/lib/pymodules/python2.6/elisa/core/application.py", line 37, in
> <module>
> from elisa.core import media_uri
> File "/usr/lib/pymodules/python2.6/elisa/core/media_uri.py", line 29, in
> <module>
> from elisa.extern.translation import Translatable
> File "/usr/lib/pymodules/python2.6/elisa/extern/translation.py", line 31,
> in <module>
> from twisted.spread import pb
> File "/usr/lib/python2.6/dist-packages/twisted/spread/pb.py", line 49, in
> <module>
> from twisted.spread.jelly import jelly, unjelly, globalSecurity
> File "/usr/lib/python2.6/dist-packages/twisted/spread/jelly.py", line 89,
> in <module>
> import decimal
> File "/usr/lib/python2.6/decimal.py", line 3606, in <module>
> val = globals()[globalname]
> KeyError: 'ROUND_CEiLiNG'
>
> In my opinion, it is because of I am a Turkish locale user.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: moovida 1.0.9+bzr1614-1ubuntu1
> ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
> Uname: Linux 2.6.32-22-generic i686
> Architecture: i386
> Date: Sat May 22 12:29:53 2010
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
> PackageArchitecture: all
> ProcEnviron:
> LANG=tr_TR.utf8
> SHELL=/bin/bash
> SourcePackage: moovida
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/elisa/+bug/584161/+subscribe
>

--
twitter.com/sinan_aykut

Changed in moovida:
assignee: nobody → Fernando Carvalho (fernandocrvlh6)

(http://friendfeed.com/?ic=yN8fokshG3)

 Sinan Aykut (http://friendfeed.com/sinanaykut?ic%3DyN8fokshG3) invites you to try FriendFeed, where you can share and discover links, photos, videos and more!

 (https://friendfeed.com/account/create?ic=yN8fokshG3)

 You are receiving this email because Sinan Aykut sent an invitation to <email address hidden> from http://friendfeed.com/. Opt-out of invitation request emails: (http://friendfeed.com/account/optout?code=yN8fokshG3)

FriendFeed Inc., 313 W. Evelyn Ave., Mountain View, CA 94041

LinkedIn
------------

Bug,

Sizi LinkedIn'deki profesyonel profilime eklemek istiyorum.

- Sinan

Sinan Aykut
Şu okulda öğrenci: Afyon Kocatepe Üniversitesi
Türkiye

Sinan Aykut adlı kişiyi tanıdığınızı onaylayın
https://www.linkedin.com/e/vvktdx-gqm80h55-6/isd/3670125709/JI3XaKP_/

--
(c) 2011, LinkedIn Corporation

dino99 (9d9) wrote :

The latest free moovida 1.09 does not get any maintenance since a while. Now moovidadb.com is supporting Linux and support can be found at : http://www.fluendo.com/faq/

Changed in moovida (Ubuntu):
status: Confirmed → Invalid
Changed in moovida:
status: Confirmed → Invalid
Changed in elisa:
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.