missing dependencies (installed through software center)

Bug #477887 reported by Steven Post
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
moovida-plugins-bad (Ubuntu)
Low
Andrew Starr-Bochicchio

Bug Description

Binary package hint: moovida

Running Karmic (up to date) on a VMWare.

I installed moovida using the ubuntu software center, when starting it, it immediately crashes after the splash screen with the message of a missing dependency 'coherence'.
Installing python-coherence (synaptic) and running moovida again reveals the next message, another dependency:
Twisted, installing 'python-twisted' as well (again using synaptic),
These are required by the coherence plugin for moovida, which gets installed alongside the main program.

Of course it still doesn't run because of an other error: "ERROR: couldn't create the window, exiting..."
But I'm guessing this is due to the fact that this is a vmware and not a native installation. If I'm mistaken about that last statement, please correct me.

console output:
steven@ubuntu-test:~$ moovida
Launcher core version: 1.0.7
Current core version: 1.0.7
WARN MainThread plugin_registry Nov 07 23:16:17 plugin elisa-plugin-coherence has the following unmet dependencies: coherence>=0.5.7 (elisa/core/plugin_registry.py:363)
ERROR: couldn't create the window, exiting...

steven@ubuntu-test:~$ moovida
Launcher core version: 1.0.7
Current core version: 1.0.7
WARN MainThread plugin_registry Nov 07 23:18:16 plugin elisa-plugin-coherence has the following unmet dependencies: Twisted>=2.5.0 (elisa/core/plugin_registry.py:363)
WARN MainThread plugin_registry Nov 07 23:18:16 plugin Coherence has the following unmet dependencies: Twisted>=2.5.0 (elisa/core/plugin_registry.py:363)
ERROR: couldn't create the window, exiting...

steven@ubuntu-test:~$ moovida
Launcher core version: 1.0.7
Current core version: 1.0.7
ERROR: couldn't create the window, exiting...
steven@ubuntu-test:~$

Revision history for this message
Steven Post (redalert-commander) wrote :

Update:
Moovida starts fine on my native 9.10 installation without the dependencies, however some things don't work, and there's no error, apart from the console.
For example: youtube video won't work, it will just hang in the menu.
It's my opinion that this plugin should not be installed without the needed dependencies.

After installing the above python packages solves the problem.
python-coherence and python-twisted should therefore be added as dependencies.

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

Moving to moovida-plugins-bad since it already has the Suggests on coherence and the issue isn't actually with moovida core.

affects: moovida (Ubuntu) → moovida-plugins-bad (Ubuntu)
Changed in moovida-plugins-bad (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Revision history for this message
Olivier Tilloy (osomon) wrote :

IMHO coherence should be a strong dependency of the package (moovida-plugins-bad).
This is the case in our custom packages built in the Moovida packagers team's PPA (https://launchpad.net/~moovida-packagers/+archive/ppa). In this PPA, python-twisted is also a strong dependency of moovida-plugins-bad to work around http://coherence-project.org/ticket/243.

We should probably try to synchronize the packaging branches (see https://code.launchpad.net/~moovida-packagers).

Changed in moovida-plugins-bad (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

We've just been inheriting this dependency relationship from Debian. Do you know if they have a reason for not Depending on coherence there? Paul, Lioc?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package moovida-plugins-bad - 1.0.9-0ubuntu1

---------------
moovida-plugins-bad (1.0.9-0ubuntu1) lucid; urgency=low

  * New upstream release.
  * debian/control:
   - Bump moovida Depends for new release.
   - Move python-coherence and python-louie to Depends (LP: #477887).
   - Add Depends on python-storm.
 -- Andrew Starr-Bochicchio <email address hidden> Fri, 04 Dec 2009 14:30:09 -0500

Changed in moovida-plugins-bad (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
starling13 (starling13) wrote :

In my Ubuntu 9.10 with xfce environment bug with creating window afffects both 1.0.7 version from default repositories and 1.0.9 from mentioned above one.

Launcher core version: 1.0.7
Current core version: 1.0.7
ERROR: couldn't create the window, exiting...

Launcher core version: 1.0.9
Current core version: 1.0.9
ERROR: couldn't create the window, exiting...

After fresh install moovida started successfuly, but after updating system (and possibly python) there appeared this bug.

Revision history for this message
Olivier Tilloy (osomon) wrote :

@starling13: the "ERROR: couldn't create the window, exiting..." means that pigment's openGL backend fails to create a window. Do you manage to run other openGL applications (try e.g. neverball)?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.