Moodle 1.9.4 is not working with PHP 5.3

Bug #578797 reported by Franco Catena on 2010-05-11
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
moodle (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: moodle

I'm using Ubuntu 10.04 LTS and the package of Moodle is 1.9.4.dfsg-0ubuntu4

After the instalation of Moodle when I try to configure it with the "admin" page I get a blank page in one of the lasts steps. When I turn on the debug in the config file I get the following error:

Fatal error: Call to undefined method MoodleQuickForm_hidden::MoodleQuickForm_hidden() in /usr/share/moodle/lib/pear/HTML/QuickForm/element.php on line 363

Searching I found this post: http://moodle.org/mod/forum/discuss.php?d=129384. In resume, they say that Moodle 1.9.4 is not compatible with PHP 5.3.

jedabo (jedabonorton) wrote :

Hi,

I've exactly the same problem. Moodle won't run. And Claroline (another teaching package) isn't available.
Surely, there had been some test before integration of version 1.9.4.
Please, what are the tips to make it run ?

Jeremy Bicha (jbicha) wrote :

One option is to try installing this PPA: https://launchpad.net/~txwikinger/+archive/php5.2

An updated moodle package is being worked on in Debian but it will be at least a few weeks (maybe longer) for it to be available for Lucid users.

You could also download Moodle directly from their website but that will mean you have to configure everything yourself.

Changed in moodle (Ubuntu):
status: New → Confirmed
Franco Catena (francocatena) wrote :

OK, thank you very much Jeremy. I think that the waiting is my prefered option.

markofealing (mark-ferns16) wrote :

A few weeks seem to have turned into a month!

Are we any closer to having this bug fixed via an updated moodle package?

Package for 1.9.8 has been uploaded to Debian last week.

On Tue, Jun 22, 2010 at 6:51 PM, markofealing <email address hidden> wrote:
> A few weeks seem to have turned into a month!
>
> Are we any closer to having this bug fixed via an updated moodle
> package?
>
> --
> Moodle 1.9.4 is not working with PHP 5.3
> https://bugs.launchpad.net/bugs/578797
> You received this bug notification because you are subscribed to moodle
> in ubuntu.
>
> Status in “moodle” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: moodle
>
> I'm using Ubuntu 10.04 LTS and the package of Moodle is 1.9.4.dfsg-0ubuntu4
>
> After the instalation of Moodle when I try to configure it with the "admin" page I get a blank page in one of the lasts steps. When I turn on the debug in the config file I get the following error:
>
> Fatal error: Call to undefined method MoodleQuickForm_hidden::MoodleQuickForm_hidden() in /usr/share/moodle/lib/pear/HTML/QuickForm/element.php on line 363
>
> Searching I found this post: http://moodle.org/mod/forum/discuss.php?d=129384. In resume, they say that Moodle 1.9.4 is not compatible with PHP 5.3.
>
>
>

Tomasz (Tomek) Muras (zabuch) wrote :

New updated package (1.9.9) is available for download from Debian repository.

Kent Tong (kent-tong) wrote :

I downloaded and install http://packages.debian.org/sid/all/moodle/download successfully to fix the problem.

Jan Groenewald (jan-aims) wrote :

I just came across this on a lucid server.
During moodle's installation, at configuring the admin user the pages
are blank and one cannot continue or change the admin password.

I see the moodle version on Maverick is the same
(but I'd want LTS for a production server anyway).

Will a moodle upgrade come in lucid-updates, lucid-backports,
or someone's ppa? Something with security updates.

Alternatively, if one adds deb http://ftp.de.debian.org/debian sid main
to, for example, /etc/apt/sources.list.d/moodle.list, how can apt/aptitude/dpkg/*
be restricted to only get moodle from that moodle.list, and not other packages?

Ali Ayaz (ali-uredge-inc) wrote :

Hello,

I might be asking a very obvious question.

I am using Ubuntu 10.10 DT edition, configured the LAMP server on it. I am trying to get moodle running on it, just for test purposes before installing it on a production server (Most-likely RedHat). Obviously, I have PHP 5.3.3 However, I downloaded and installed Moodle from the terminal, and thought that I would be getting the latest build (2.0.2), but instead 1.9.4 got installed.

I am running into the exact same problem as described by the person who started this thread, and I am sure it is because of the version of moodle having problems with the version of PHP.

So, I assume, if I install Moodle 2.0.2, I should be fine?

And also, because I am complete newbie to Moodle, is there any good (detailed) doc/link for upgrading Moodle? (Preferably from the Terminal as that's how I would like it)

Cheers

Stephen Parry (sgparry) wrote :

Can we _please_ have the Debian package downstream in Lucid? I've wasted several hours bashing my head against a brick wall because I assumed when came to upgrade to Lucid that the Ubuntu maintained package would work.

Thijs Kinkhorst (kink) on 2013-07-12
Changed in moodle (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers