package moodle 1.9.9.dfsg2-6 failed to install/upgrade: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1

Bug #1189902 reported by Patrice Allais on 2013-06-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
moodle (Ubuntu)
Undecided
Unassigned

Bug Description

Extraction des modèles depuis les paquets : 100%
Préconfiguration des paquets...
/tmp/moodle.config.25411: 36: .: Can't open /usr/share/dbconfig-common/dpkg/config
Échec de la préconfiguration de moodle, avec le code d'erreur 2
Sélection du paquet mysql-common précédemment désélectionné.
(Lecture de la base de données... 339473 fichiers et répertoires déjà installés.)
Dépaquetage de mysql-common (à partir de .../mysql-common_5.5.31-0ubuntu0.12.04.2_all.deb) ...
Sélection du paquet libmysqlclient18 précédemment désélectionné.
Dépaquetage de libmysqlclient18 (à partir de .../libmysqlclient18_5.5.31-0ubuntu0.12.04.2_amd64.deb) ...
Sélection du paquet libapr1 précédemment désélectionné.
Dépaquetage de libapr1 (à partir de .../libapr1_1.4.6-1_amd64.deb) ...
Sélection du paquet libaprutil1 précédemment désélectionné.
Dépaquetage de libaprutil1 (à partir de .../libaprutil1_1.3.12+dfsg-3_amd64.deb) ...
Sélection du paquet libaprutil1-dbd-sqlite3 précédemment désélectionné.
Dépaquetage de libaprutil1-dbd-sqlite3 (à partir de .../libaprutil1-dbd-sqlite3_1.3.12+dfsg-3_amd64.deb) ...
Sélection du paquet libaprutil1-ldap précédemment désélectionné.
Dépaquetage de libaprutil1-ldap (à partir de .../libaprutil1-ldap_1.3.12+dfsg-3_amd64.deb) ...
Sélection du paquet apache2.2-bin précédemment désélectionné.
Dépaquetage de apache2.2-bin (à partir de .../apache2.2-bin_2.2.22-1ubuntu1.3_amd64.deb) ...
Sélection du paquet apache2-utils précédemment désélectionné.
Dépaquetage de apache2-utils (à partir de .../apache2-utils_2.2.22-1ubuntu1.3_amd64.deb) ...
Sélection du paquet apache2.2-common précédemment désélectionné.
Dépaquetage de apache2.2-common (à partir de .../apache2.2-common_2.2.22-1ubuntu1.3_amd64.deb) ...
Sélection du paquet apache2-mpm-prefork précédemment désélectionné.
Dépaquetage de apache2-mpm-prefork (à partir de .../apache2-mpm-prefork_2.2.22-1ubuntu1.3_amd64.deb) ...
Sélection du paquet php5-common précédemment désélectionné.
Dépaquetage de php5-common (à partir de .../php5-common_5.3.10-1ubuntu3.6_amd64.deb) ...
Sélection du paquet libapache2-mod-php5 précédemment désélectionné.
Dépaquetage de libapache2-mod-php5 (à partir de .../libapache2-mod-php5_5.3.10-1ubuntu3.6_amd64.deb) ...
Sélection du paquet php5-cli précédemment désélectionné.
Dépaquetage de php5-cli (à partir de .../php5-cli_5.3.10-1ubuntu3.6_amd64.deb) ...
Sélection du paquet php5-mysql précédemment désélectionné.
Dépaquetage de php5-mysql (à partir de .../php5-mysql_5.3.10-1ubuntu3.6_amd64.deb) ...
Sélection du paquet php5-gd précédemment désélectionné.
Dépaquetage de php5-gd (à partir de .../php5-gd_5.3.10-1ubuntu3.6_amd64.deb) ...
Sélection du paquet php5-curl précédemment désélectionné.
Dépaquetage de php5-curl (à partir de .../php5-curl_5.3.10-1ubuntu3.6_amd64.deb) ...
Sélection du paquet libnet-daemon-perl précédemment désélectionné.
Dépaquetage de libnet-daemon-perl (à partir de .../libnet-daemon-perl_0.48-1_all.deb) ...
Sélection du paquet libplrpc-perl précédemment désélectionné.
Dépaquetage de libplrpc-perl (à partir de .../libplrpc-perl_0.2020-2_all.deb) ...
Sélection du paquet libdbi-perl précédemment désélectionné.
Dépaquetage de libdbi-perl (à partir de .../libdbi-perl_1.616-1build2_amd64.deb) ...
Sélection du paquet libdbd-mysql-perl précédemment désélectionné.
Dépaquetage de libdbd-mysql-perl (à partir de .../libdbd-mysql-perl_4.020-1build2_amd64.deb) ...
Sélection du paquet libpq5 précédemment désélectionné.
Dépaquetage de libpq5 (à partir de .../libpq5_9.1.9-0ubuntu12.04_amd64.deb) ...
Sélection du paquet postgresql-client-common précédemment désélectionné.
Dépaquetage de postgresql-client-common (à partir de .../postgresql-client-common_129ubuntu1_all.deb) ...
Sélection du paquet postgresql-client-9.1 précédemment désélectionné.
Dépaquetage de postgresql-client-9.1 (à partir de .../postgresql-client-9.1_9.1.9-0ubuntu12.04_amd64.deb) ...
Sélection du paquet postgresql-client précédemment désélectionné.
Dépaquetage de postgresql-client (à partir de .../postgresql-client_9.1+129ubuntu1_all.deb) ...
Sélection du paquet smarty précédemment désélectionné.
Dépaquetage de smarty (à partir de .../smarty_2.6.26-0.2ubuntu1_all.deb) ...
Sélection du paquet libjs-yui précédemment désélectionné.
Dépaquetage de libjs-yui (à partir de .../libjs-yui_2.8.2r1~squeeze-1_all.deb) ...
Sélection du paquet libphp-snoopy précédemment désélectionné.
Dépaquetage de libphp-snoopy (à partir de .../libphp-snoopy_1.2.4-2_all.deb) ...
Sélection du paquet libphp-magpierss précédemment désélectionné.
Dépaquetage de libphp-magpierss (à partir de .../libphp-magpierss_0.72-10_all.deb) ...
Sélection du paquet dbconfig-common précédemment désélectionné.
Dépaquetage de dbconfig-common (à partir de .../dbconfig-common_1.8.47_all.deb) ...
Sélection du paquet php-fpdf précédemment désélectionné.
Dépaquetage de php-fpdf (à partir de .../php-fpdf_3%3a1.7.dfsg-1_all.deb) ...
Sélection du paquet libphp-pclzip précédemment désélectionné.
Dépaquetage de libphp-pclzip (à partir de .../libphp-pclzip_2.8.2-2_all.deb) ...
Sélection du paquet moodle précédemment désélectionné.
Dépaquetage de moodle (à partir de .../moodle_1.9.9.dfsg2-6_all.deb) ...
Sélection du paquet wwwconfig-common précédemment désélectionné.
Dépaquetage de wwwconfig-common (à partir de .../wwwconfig-common_0.2.2_all.deb) ...
Sélection du paquet javascript-common précédemment désélectionné.
Dépaquetage de javascript-common (à partir de .../javascript-common_8_all.deb) ...
Sélection du paquet mimetex précédemment désélectionné.
Dépaquetage de mimetex (à partir de .../mimetex_1.50-1.1_amd64.deb) ...
Sélection du paquet php5-ldap précédemment désélectionné.
Dépaquetage de php5-ldap (à partir de .../php5-ldap_5.3.10-1ubuntu3.6_amd64.deb) ...
Sélection du paquet php5-xmlrpc précédemment désélectionné.
Dépaquetage de php5-xmlrpc (à partir de .../php5-xmlrpc_5.3.10-1ubuntu3.6_amd64.deb) ...
Sélection du paquet postgresql-common précédemment désélectionné.
Dépaquetage de postgresql-common (à partir de .../postgresql-common_129ubuntu1_all.deb) ...
Ajout de « détournement de /usr/bin/pg_config en /usr/bin/pg_config.libpq-dev par postgresql-common »
Sélection du paquet postgresql-9.1 précédemment désélectionné.
Dépaquetage de postgresql-9.1 (à partir de .../postgresql-9.1_9.1.9-0ubuntu12.04_amd64.deb) ...
Sélection du paquet postgresql précédemment désélectionné.
Dépaquetage de postgresql (à partir de .../postgresql_9.1+129ubuntu1_all.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Traitement des actions différées (« triggers ») pour « ufw »...
Traitement des actions différées (« triggers ») pour « ureadahead »...
ureadahead will be reprofiled on next reboot
Traitement des actions différées (« triggers ») pour « doc-base »...
Processing 1 added doc-base file...
Enregistrement des documents avec scrollkeeper...
Paramétrage de mysql-common (5.5.31-0ubuntu0.12.04.2) ...
Paramétrage de libmysqlclient18 (5.5.31-0ubuntu0.12.04.2) ...
Paramétrage de libapr1 (1.4.6-1) ...
Paramétrage de libaprutil1 (1.3.12+dfsg-3) ...
Paramétrage de libaprutil1-dbd-sqlite3 (1.3.12+dfsg-3) ...
Paramétrage de libaprutil1-ldap (1.3.12+dfsg-3) ...
Paramétrage de apache2.2-bin (2.2.22-1ubuntu1.3) ...
Paramétrage de apache2-utils (2.2.22-1ubuntu1.3) ...
Paramétrage de apache2.2-common (2.2.22-1ubuntu1.3) ...
Enabling site default.
Enabling module alias.
Enabling module autoindex.
Enabling module dir.
Enabling module env.
Enabling module mime.
Enabling module negotiation.
Enabling module setenvif.
Enabling module status.
Enabling module auth_basic.
Enabling module deflate.
Enabling module authz_default.
Enabling module authz_user.
Enabling module authz_groupfile.
Enabling module authn_file.
Enabling module authz_host.
Enabling module reqtimeout.
Paramétrage de apache2-mpm-prefork (2.2.22-1ubuntu1.3) ...
 * Starting web server apache2 apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
                                                                         [ OK ]
Paramétrage de php5-common (5.3.10-1ubuntu3.6) ...
Paramétrage de libapache2-mod-php5 (5.3.10-1ubuntu3.6) ...

Creating config file /etc/php5/apache2/php.ini with new version
 * Restarting web server apache2 apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
 ... waiting apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
                                                                         [ OK ]
Paramétrage de php5-cli (5.3.10-1ubuntu3.6) ...

Creating config file /etc/php5/cli/php.ini with new version
update-alternatives: utilisation de « /usr/bin/php5 » pour fournir « /usr/bin/php » (php) en mode automatique.
Paramétrage de php5-mysql (5.3.10-1ubuntu3.6) ...
Paramétrage de php5-gd (5.3.10-1ubuntu3.6) ...
Paramétrage de php5-curl (5.3.10-1ubuntu3.6) ...
Paramétrage de libnet-daemon-perl (0.48-1) ...
Paramétrage de libplrpc-perl (0.2020-2) ...
Paramétrage de libdbi-perl (1.616-1build2) ...
Paramétrage de libdbd-mysql-perl (4.020-1build2) ...
Paramétrage de libpq5 (9.1.9-0ubuntu12.04) ...
Paramétrage de postgresql-client-common (129ubuntu1) ...
Paramétrage de postgresql-client-9.1 (9.1.9-0ubuntu12.04) ...
update-alternatives: utilisation de « /usr/share/postgresql/9.1/man/man1/psql.1.gz » pour fournir « /usr/share/man/man1/psql.1.gz » (psql.1.gz) en mode automatique.
Paramétrage de postgresql-client (9.1+129ubuntu1) ...
Paramétrage de smarty (2.6.26-0.2ubuntu1) ...
Paramétrage de libjs-yui (2.8.2r1~squeeze-1) ...
Paramétrage de libphp-snoopy (1.2.4-2) ...
Paramétrage de libphp-magpierss (0.72-10) ...
Paramétrage de dbconfig-common (1.8.47) ...

Creating config file /etc/dbconfig-common/config with new version
Paramétrage de php-fpdf (3:1.7.dfsg-1) ...
Paramétrage de libphp-pclzip (2.8.2-2) ...
Paramétrage de moodle (1.9.9.dfsg2-6) ...
dbconfig-common: writing config to /etc/dbconfig-common/moodle.conf

Creating config file /etc/dbconfig-common/moodle.conf with new version
chown: utilisateur incorrect: «postgres»
unable to connect to postgresql server.
error encountered creating user:
identifiant inconnu : postgres
dbconfig-common: moodle configure: aborted.
dbconfig-common: flushing administrative password
dpkg : erreur de traitement de moodle (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de wwwconfig-common (0.2.2) ...
Paramétrage de javascript-common (8) ...
Paramétrage de mimetex (1.50-1.1) ...
Paramétrage de php5-ldap (5.3.10-1ubuntu3.6) ...
Paramétrage de php5-xmlrpc (5.3.10-1ubuntu3.6) ...
Paramétrage de postgresql-common (129ubuntu1) ...
Ajout de l'utilisateur postgres au groupe ssl-cert
Building PostgreSQL dictionaries from installed myspell/hunspell packages...
  en_au
  en_ca
  en_gb
  en_us
  en_za
  fr
Paramétrage de postgresql-9.1 (9.1.9-0ubuntu12.04) ...
Creating new cluster (configuration: /etc/postgresql/9.1/main, data: /var/lib/postgresql/9.1/main)...
Moving configuration file /var/lib/postgresql/9.1/main/postgresql.conf to /etc/postgresql/9.1/main...
Moving configuration file /var/lib/postgresql/9.1/main/pg_hba.conf to /etc/postgresql/9.1/main...
Moving configuration file /var/lib/postgresql/9.1/main/pg_ident.conf to /etc/postgresql/9.1/main...
Configuring postgresql.conf to use port 5432...
update-alternatives: utilisation de « /usr/share/postgresql/9.1/man/man1/postmaster.1.gz » pour fournir « /usr/share/man/man1/postmaster.1.gz » (postmaster.1.gz) en mode automatique.
 * Starting PostgreSQL 9.1 database server [ OK ]
Paramétrage de postgresql (9.1+129ubuntu1) ...
Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking place
Des erreurs ont été rencontrées pendant l'exécution :
 moodle
W: A attendu dpkg --assert-multi-arch mais il n'était pas présent - dpkgGo (10: Aucun processus enfant)
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de récupération :

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: moodle 1.9.9.dfsg2-6
ProcVersionSignature: Ubuntu 3.2.0-45.70-generic 3.2.44
Uname: Linux 3.2.0-45-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.3
Architecture: amd64
Date: Tue Jun 11 15:13:46 2013
DuplicateSignature: package:moodle:1.9.9.dfsg2-6:le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
ErrorMessage: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: moodle
Title: package moodle 1.9.9.dfsg2-6 failed to install/upgrade: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
UpgradeStatus: No upgrade log present (probably fresh install)

Patrice Allais (patrice-allais) wrote :
tags: removed: need-duplicate-check
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers