[Karmic] Restart or shut down now requires root password

Bug #443441 reported by Martin Gamache on 2009-10-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
monopd (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-session

I'm not sure this is the right package, but...

In Karmic Beta, every time I try to shut down or reboot, I get a message telling me that I don't have the user privilege to do so while other sessions are active.

I have no apps open nor any other sessions opened.

I then input my password. Then it closes as it should.

This is starting to be irritating. This behaviour is similar to what you get in Windows Vista. Please don't start imitating them.. :(

ProblemType: Bug
Architecture: amd64
Date: Mon Oct 5 15:45:53 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: wl nvidia
Package: gnome-session 2.28.0-0ubuntu3
PackageArchitecture: all
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: gnome-session
Uname: Linux 2.6.31-11-generic x86_64

Martin Gamache (martin-gamache) wrote :
Chris Coulson (chrisccoulson) wrote :

Thanks, but this isn't the correct package. consolekit requires the user to authenticate if there is more than one session open - this is the intended behaviour and is not a bug. Could you please capture the output of "ck-list-sessions" before shutting down, and post it here *if* you are asked for a password on that shutdown.

Thanks!

affects: gnome-session (Ubuntu) → consolekit (Ubuntu)
Changed in consolekit (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Martin Gamache (martin-gamache) wrote :

As requested.

I get asked for my password at every shut down...

James Westby (james-w) wrote :

Odd, there is a session opened for 'nobody', which apparently
originated from your session, but doesn't have a console attached.

Could you please attach the output of

  ps aux | grep nobody

to see if you have any processes running as that user.

Thanks,

James

Martin Gamache (martin-gamache) wrote :

There you are. Apparently, this is related to my installation of the monopoly daemon, monopd...

James Westby (james-w) on 2009-10-09
affects: consolekit (Ubuntu) → monopd (Ubuntu)
Changed in monopd (Ubuntu):
importance: Low → Medium
status: Incomplete → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package monopd - 0.9.3-4ubuntu2

---------------
monopd (0.9.3-4ubuntu2) karmic; urgency=low

  * Use --chuid instead of /bin/su to run the daemon as 'nobody'. Using
    su mean that a pam session was opened, hence a consolekit session,
    hence trying to shut down via consolekit would require the root password
    as it thought there were multiple users logged in. (LP: #443441)

 -- James Westby <email address hidden> Fri, 09 Oct 2009 02:07:26 +0100

Changed in monopd (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers