Can't run NUnit test from inside MonoDevelop

Bug #889241 reported by Andreas Richter
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
monodevelop (Ubuntu)
Fix Released
Undecided
Unassigned
Oneiric
Fix Released
Undecided
Unassigned

Bug Description

[Impact] monodevelops nunit adding does not work anymore due to an issue in with the new nunit 2.5
you cannot use any of the builtin test facilities anymore and is obligated to use the external tools shipped in nunit.

[Development Fix] the issue was fixed with a patch instantiating the service which was missing and adapting a couple of lines for the new api.

[Stable Fix] the same fix can be applied in stable.

[Test Case] download the attached project, open MyApplication.mds with monodevelop
View -> Unit Test
rightclick on project in the sidebar -> Run Tests

result: internal error
expected result: tests run (result ignored in this case)

[Regression Potential] low only touches functionality that is completely broken anyway.

original report

After an upgrade to Ubuntu 11.10 i can't start NUnit Unit Tests from within MonoDevelop anymore.
I get an NullReferenceException

Julian Taylor (jtaylor)
Changed in monodevelop (Ubuntu):
status: New → Confirmed
Revision history for this message
Andreas Richter (anrichter) wrote :

Is there a fix for this issue?
I would to develop on Oneiric with MonoDevelop and can't do TDD inside the IDE. Has anybody an idea what i can do to fix this issue?

Revision history for this message
Anton Sheihman (sheix) wrote :

Confirmed on 32bit machine, monodevelop 2.6 nunit support 2.6.0

Revision history for this message
Andreas Richter (anrichter) wrote :

Maybe it is a packaging problem.
I tryed to compile and start the monodevelop source from Oneric with the same problem.

Then i grabbed the vanilla monodevelop from http://download.mono-project.com/sources/monodevelop/monodevelop-2.6.0.1.tar.bz2, compile and start it. And voila: NUnit runs right in MonoDevelop as expected.

But: The nunit bundled with MonoDevelop 2.6.0.1 are version 2.4.8. And the nunit installed in Oneric are version 2.5.0. Perhaps this ist the problem?

Revision history for this message
Julian Taylor (jtaylor) wrote :
Revision history for this message
Dražen Lučanin (kermit666) wrote :

Julian, can you tell me how to apply the suggested fix?

Revision history for this message
Julian Taylor (jtaylor) wrote :

I'll prepare a fix for oneiric, please test that when its been uploaded.

Julian Taylor (jtaylor)
affects: monodevelop (Ubuntu) → nunit (Ubuntu)
Changed in nunit (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Julian Taylor (jtaylor) wrote :
description: updated
Revision history for this message
Lazar Ivanov (lazari-t) wrote :

Hey Julian, when do you expect this fix to be uploaded?

Revision history for this message
Julian Taylor (jtaylor) wrote :

Sorry a couple more fixes where required in monodevelop too to resolve this issue.
I'll try to get it ready today evening

Revision history for this message
Julian Taylor (jtaylor) wrote :

assigned back to mondevelop because the fix needs to be done there

affects: nunit (Ubuntu) → monodevelop (Ubuntu)
description: updated
Revision history for this message
Julian Taylor (jtaylor) wrote :

I have uploaded monodevelop to -proposed
It should fix the issue without requiring an additional nunit upload.

Please test it when the upload is approved, the release team will post instructions on how when that happens..

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello anrichter, or anyone else affected,

Accepted monodevelop into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in monodevelop (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
Andreas Richter (anrichter) wrote :

Hi Martin,

thanks for the patch. Monodevelop in oneiric-proposed works now. I can start nunit-tests from inside the IDE.

Again: Thanks for the fix.

Cheers,
Andreas

Revision history for this message
Lazar Ivanov (lazari-t) wrote :

Martin, Julian:

I also verified that the fix works.

Thank you for the fix and the quick turnaround!

-LI

Martin Pitt (pitti)
tags: added: verification-done
removed: verification-needed
Revision history for this message
Dražen Lučanin (kermit666) wrote :

Julian, Martin,

thanks for the fix! Works on my machine as well now.

Cheers,
Dražen

P.S. - don't know if this is important, but I get the following warning "Warning: Reference 'nunit.framework, Version=2.2.8.0, Culture=neutral, PublicKeyToken=96d09a1eb7f44a77' not found on system. Using 'nunit.framework, Version=2.5.10.0, Culture=neutral, PublicKeyToken=96d09a1eb7f44a77' instead. (MyLibraryTest)"

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package monodevelop - 2.6+dfsg-1ubuntu0.1

---------------
monodevelop (2.6+dfsg-1ubuntu0.1) oneiric-proposed; urgency=low

  * fix nunit 2.5 port: (LP: #889241)
     - logic change for the TestSuiteResult -> TestResult merge in 2.5
     - Added a ProjectService needed by nunit's DomainManager service
     - Removed some line ending fuzz
     - treat new Error TestResult as a failure to get it displayed
 -- Julian Taylor <email address hidden> Mon, 20 Feb 2012 19:38:58 +0100

Changed in monodevelop (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments