The road to Monodevelop 2.0

Bug #330519 reported by Jo Shields on 2009-02-17
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
monodevelop (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
monodevelop-boo (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
monodevelop-database (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
monodevelop-java (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned

Bug Description

Binary package hint: monodevelop

I'm starting this bug to help track Monodevelop 2.0.

At this moment in time, the current "stable" upstream release of Monodevelop is 1.0. This has been the release included in Ubuntu since Hardy, and it is rather rough around the edges, truth be told. The next major version, 2.0, has just released its first beta (2.0 beta 1, AKA 1.9.2) which is a significant improvement to usability compared to 1.0. Beta 1 is upstream's "feature freeze" release, with a second beta due on March 8th, and the final release due on March 24th, to address bugs.

It would be great to equip Jaunty with this great new release, rather than the anaemic 1.0 release we've been using for ages (through fear of random SVN snapshots), but it's possible (or even probable) that 1.9.2 will miss Jaunty FF by a few days, due to assorted other packaging commitments for the pkg-mono teams.

My Jaunty PPA contains a current pre-release test package, as well as a required bugfixed mono-addins package (https://bugs.launchpad.net/ubuntu/+bug/330440), and can be enabled at https://launchpad.net/~directhex/+archive/ppa.

Preliminary testing shows that this pre-release package is in good shape, although it won't be uploaded to Debian until *all* of MD2 has been prepared (plugins in different tarballs, currently only the Database plugin has not been updated yet - and some plugins will need to go through NEW).

I'm subscribing motu-release to this bug to help inform about developments, and possible to help provide background information should a formal FFe be needed for some or all of MD2. Please go ahead and test the current package, we're keen to hear about issues.

StefanPotyra (sistpoty) wrote :

<sistpoty|work> directhex: do you have an estimate how many packages will need to be touched to reach the end of the road?
[13:45:10] <directhex> sistpoty|work, beyond the mono-addins sync (which will help other things)? monodevelop itself plus five or six plugins
[13:45:44] <sistpoty|work> directhex: ah, k, so no effect on other packages besides these?
[13:45:59] <directhex> sistpoty|work, indeed. it's pretty self-contained

Jo Shields (directhex) wrote :

MD 2.0 beta 1 is now in Experimental, plugins to follow. Requesting a merge

Jo Shields (directhex) wrote :

I utterly suck when it comes to remembering to run update-maintainer

Jo Shields (directhex) wrote :

Okay, monodevelop-database can be SYNCED cleanly from Experimental. now looking into monodevelop-java

Jo Shields (directhex) wrote :

For whatever reason, monodevelop-java's clean rule calls configure - so debuild only works if monodevelop is installed.

However, the attached debdiff is the final piece of Monodevelop as far as what's in the archive is concerned. There are other packages (two debugger plugins, plus a plugin for the Vala language) for extra functionality not found in the current Monodevelop 1.0 in the archive

Jo Shields (directhex) wrote :

Here's monodevelop-java with the obnoxious "build-deps needed to run clean" thing removed via the bleeding edge of "patch" technology

That's it for the three monodevelop source packages in Ubuntu!

Jo Shields (directhex) wrote :
Download full text (10.4 KiB)

As much of a changelog from 1.0 as I'm able to extract from alpha/beta notes:

== Per-project/solution Policies ==
Many of the settings that were previously only available in the user's global preferences can now be set per-solution and per-project. Those settings are grouped in what we call policies.

Policies include:

    * Text style: tabs to spaces, tab width, etc.
    * Standard header
    * Default namespaces for projects' directories
    * Resource naming styles
    * Commit message formatting
    * ChangeLog location and formatting

Policies can be applied to solutions, and can be overridden on child projects or solution folders.

== Project System ==
This release includes full support for multiple target frameworks. The .NET 3.0 and 3.5 target frameworks are now explicitly supported. MonoDevelop will now detect inconsistencies in project references. For example, a project targeting the 2.0 framework won't be able to reference projects targeting 3.0 or 3.5.

== Project Management ==
=== MSBuild File format ===
MonoDevelop now uses the MSBuild project format as its native file format. This improves compatibility with Visual Studio, and will allow MonoDevelop to transition to using xbuild/MSBuild as the build engine.

The old MonoDevelop project file format (mdp) is still supported. The default file format to use when creating new projects can be configured in the MonoDevelop preferences dialog, Load/Save section.

=== New project model: Workspaces and Solution Folders ===
The MonoDevelop project model has been reorganized to better fit the MSBuild model, but without losing particular features that MonoDevelop used to have.

One important change is the introduction of Solution Folders. Solution folders allows organizing projects using folders inside a solution. This organization used to be done with nested solutions, but the solution folder model is more robust and it is compatible with the Visual Studio model.

Another change is the new support for Workspaces. A workspace allows grouping together a set of solutions (or other child workspaces). Workspaces are useful when you have several related but independent solutions and you want to open all of them at once.

=== Opening Multiple Solutions ===
MonoDevelop now supports opening multiple solutions at the same time. This is useful when you are working with a solution and want to review code side-by-side which belongs to another solution.

=== Configurable Project Base Directory ===
All projects have a base directory assigned. This base directory is where the project file is located. All files included in the project are supposed to be under that directory, and it is the directory structure shown in the Solution Pad (files outside the project directory are still alowed, but they are shown all together in a special 'External Files' folder).

In order to support other project directory structures, it is now possible to specify a custom base directory for a project. So for example, now a project file can be saved in a directory and project files in a different directory. The Solution Pad will show the correct source file structure, and all version control operation will be directed to...

StefanPotyra (sistpoty) wrote :

hm... seeing the rate at which you propose merges, I assume that you'll be done next week? Likewise, it looks like you're also caring much about the packages, and for sure will have done testing and will also volunteer to fix bugs/regressions.

Based on these assumptions, +1 from me to get monodevelop + plugins in for jaunty. I'd suggest to grant a general FFe for monodevelop + plugins until end of next week to let you do work on packaging rather than bureaucracy. @other motu-release members, what do you think?

Iulian Udrea (iulian) wrote :

+1 from me as well.

Luca Falavigna (dktrkranz) wrote :

I tested monodevelop a bit and it seems stable enough to reach Jaunty. I'll follow this transition closely to make sure we don't miss some bits along the way. I'm in favour of a standing FFe for monodevelop + plugins too.

Changed in monodevelop:
status: New → Confirmed
Jo Shields (directhex) wrote :

I think I'm done with the three packages above, for now - i.e. until a bug report lands on my desk from a user or upstream, or a more final tarball is released. The three above cover all the MonoDevelop currently found in the archive. I'm now looking at the plugins which are NEW - monodevelop-vala, monodevelop-debugger-mdb and monodevelop-debugger-gdb.

Unless the release team has spotted something I haven't, I don't see any major reason not to upload the three packages done so far.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package monodevelop - 1.9.2+dfsg-1ubuntu1

---------------
monodevelop (1.9.2+dfsg-1ubuntu1) jaunty; urgency=low

  * Merge from Debian Experimental (LP: #330519), remaining Ubuntu changes:
    + debian/control:
      - Update for Gnome# 2.24
      - Add libmono-cairo1.0-cil to build-deps to fool pkg-config check

 -- Jo Shields <email address hidden> Wed, 18 Feb 2009 08:40:51 +0000

Changed in monodevelop:
status: Confirmed → Fix Released
Jo Shields (directhex) wrote :

Whoops. Someone's a pillock & forgot all about boo.

Merge attached (and tested)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package monodevelop-java - 1.9.2-1ubuntu1

---------------
monodevelop-java (1.9.2-1ubuntu1) jaunty; urgency=low

  * Merge from Debian Experimental (LP: #330519), remaining
    Ubuntu changes:
    + debian/control:
      - Update for Gnome# 2.24 transition
    + debian/rules,
      debian/patches/allow_minimal_configure_for_clean.dpatch:
      - Tweak build process to allow "clean" rule to run without
        all the package dependencies installed

 -- Jo Shields <email address hidden> Thu, 19 Feb 2009 21:30:56 +0000

Changed in monodevelop-java:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package monodevelop-boo - 1.9.2-1ubuntu1

---------------
monodevelop-boo (1.9.2-1ubuntu1) jaunty; urgency=low

  * Merge from Debian Experimental (LP: #330519), remaining
    Ubuntu changes
    + debian/control:
      - Update gconf for Gnome# 2.24
    + debian/rules,
      debian/patches/allow_minimal_configure_for_clean.dpatch:
      - Tweak build process to allow "clean" rule to run without
        all the package dependencies installed

 -- Jo Shields <email address hidden> Sat, 21 Feb 2009 11:42:22 +0000

Changed in monodevelop-boo:
status: New → Fix Released
Luca Falavigna (dktrkranz) wrote :

monodevelop-database will be synced via bug #332493.

Changed in monodevelop-database:
status: New → Confirmed
Stefan Ebner (sebner) wrote :

I (evidently) uploaded MD and the plugin parts so far, MD-database will be synced.
The monodevelop-vala package should be ready today or tomorrow.
The debugger packages (gdb and mdb) still cause some troubles so it will take some
time to have them in the archive

Jo Shields (directhex) wrote :
Jo Shields (directhex) wrote :
Jo Shields (directhex) wrote :

Feel free to regenerate the orig using the get-orig-source rule (for archive security)

Jo Shields (directhex) wrote :

Erm, clicked the wrong file... boo changes was just above vala orig

Stefan Ebner (sebner) wrote :

Monodevelop-vala is now sitting in the New queue :)

Jo Shields (directhex) wrote :

Troublesome C# bugs getting you down? Debug them today, with the all-new Mono debugger!

Jo Shields (directhex) wrote :
Changed in monodevelop-database:
status: Confirmed → Fix Released
Jo Shields (directhex) wrote :

Troublesome C bugs getting you down? Debug them today, with the all-new GDB(tm)!

Jo Shields (directhex) wrote :

Re-marking a component as New, as I can't find a way to add not-in-repo-yet packages to LP's list (and with everything Fix Released, mdb/gdb don't appear in the sponsor queue)

Changed in monodevelop:
status: Fix Released → New
James Westby (james-w) wrote :

Setting monodevelop back to "Fix released" as sponsoring is done.

Thanks,

James

Changed in monodevelop:
status: New → Fix Released
To post a comment you must log in.