[FFe] Merge monodevelop_1.0+dfsg-1 from Debian(Unstable)

Bug #209012 reported by Stefan Ebner
8
Affects Status Importance Assigned to Milestone
monodevelop (Ubuntu)
Medium
Luca Falavigna

Bug Description

Binary package hint: monodevelop

Though Debian Changelog says both times "New upstream (bugfix) release" we need a FFe since also new features were added.

monodevelop (1.0dfsg-1) unstable; urgency=low

  * DFSG version of MonoDevelop 1.0
    (deleted all pre-compiled binaries from the tarball)
     For the record here a list of the deleted files:
      src/addins/NUnit/lib/nunit.core.dll
      src/addins/NUnit/lib/nunit.framework.dll
  * New upstream (bugfix) release
  * debian/patches/bashism.dpatch:
     Use bash instead of sh in mdtool. (Closes: #468688)
  * debian/control:
     Removed unneeded build-dependency on libvte2.0-cil.

 -- Mirco Bauer <email address hidden> Sun, 24 Feb 2008 19:28:54 0100

monodevelop (0.19dfsg-1) unstable; urgency=low

  * DFSG version of MonoDevelop 0.19
    (deleted all pre-compiled binaries from the tarball)
     For the record here a list of the deleted files:
      src/addins/NUnit/lib/nunit.core.dll
      src/addins/NUnit/lib/nunit.framework.dll
  * New upstream (bugfix) release
  * debian/rules:
     Fix permissions of .mo files in install target.
     Using dh_clistrip now to handle (strip) .mdb files.
  * debian/control:
     Updated cli-common-dev build dependency to >= 0.5.4, as we need
      dh_clistrip from it now.
     Replaced mono-mcs dependecy with recommends mono-gmcs and suggests
      mono-mcs, as MonoDevelop uses by default the C# 2.0 compiler now.
     Updated various build-dep versions to match configure's expectation.
     Replaced libgecko2.0-cil build dependency with libxul-dev, as it's used
      directly.
     Added libxul0d binary dependency to monodevelop. (Closes: #461353)
  * debian/copyright:
     Updated author list.
     Added copyright info.

 -- Mirco Bauer <email address hidden> Sun, 24 Feb 2008 16:29:47 0100

Stefan Ebner (sebner)
Changed in monodevelop:
assignee: nobody → sebner
status: New → In Progress
Revision history for this message
Stefan Ebner (sebner) wrote :
Revision history for this message
Stefan Ebner (sebner) wrote :

Hmm it really seems that new upstream only fixes bugs. well motu-release folks have to decide.
Here the UpstreamChangelog. Additional files are comming later :)

Revision history for this message
Stefan Ebner (sebner) wrote :
Revision history for this message
Stefan Ebner (sebner) wrote :

hellboy@ubuntu:/var/cache/pbuilder/result$ sudo dpkg -i monod*

(Reading database ... 398467 files and directories currently installed.)
Preparing to replace monodevelop 0.18.1+dfsg-1ubuntu2 (using monodevelop_1.0+dfsg-1ubuntu1_all.deb) ...
Unpacking replacement monodevelop ...
Selecting previously deselected package monodevelop-nunit.
Unpacking monodevelop-nunit (from monodevelop-nunit_1.0+dfsg-1_all.deb) ...
Preparing to replace monodevelop-nunit 1.0+dfsg-1 (using monodevelop-nunit_1.0+dfsg-1ubuntu1_all.deb) ...
Unpacking replacement monodevelop-nunit ...
Selecting previously deselected package monodevelop-versioncontrol.
Unpacking monodevelop-versioncontrol (from monodevelop-versioncontrol_1.0+dfsg-1_all.deb) ...
Preparing to replace monodevelop-versioncontrol 1.0+dfsg-1 (using monodevelop-versioncontrol_1.0+dfsg-1ubuntu1_all.deb) ...
Unpacking replacement monodevelop-versioncontrol ...
Preparing to replace monodoc-gtk2.0-manual 2.12.0-2ubuntu1 (using monodoc-gtk2.0-manual_2.12.0-2ubuntu1_all.deb) ...
Unpacking replacement monodoc-gtk2.0-manual ...

Setting up monodevelop (1.0+dfsg-1ubuntu1) ...
Setting up monodevelop-versioncontrol (1.0+dfsg-1ubuntu1) ...
Setting up monodoc-gtk2.0-manual (2.12.0-2ubuntu1) ...
Setting up monodevelop-nunit (1.0+dfsg-1ubuntu1) ...

Revision history for this message
Stefan Ebner (sebner) wrote :
Revision history for this message
Stefan Ebner (sebner) wrote :

I installed it without problems. furthermore I tested several functions.
Including: Creating several Gtk# projects, console projects, function testing of the menu/options in MD.
I discovered no problem and I think it's really worth it upgrading to 1.0 final (since we still have beta2).

Thanks

Changed in monodevelop:
assignee: sebner → nobody
status: In Progress → Confirmed
Revision history for this message
Shane O'Connell (shaneoc) wrote :

I definitely agree with monodevelop 1.0 in hardy, I just had to build 1.0 from source because I have a monodevelop solution here that crashes 0.18.1 when I open it.

Revision history for this message
John Dong (jdong) wrote :

I don't think Confirmed is appropriate until this FFe is approved.

I've triaged this to Medium because personally I think this represents a huge improvement from our existing monodevelop version and is also a landmark release for upstream.

Changed in monodevelop:
importance: Undecided → Medium
status: Confirmed → New
Revision history for this message
Cesare Tirabassi (norsetto) wrote :

Can you check if this will close any of these bugs:

https://bugs.edge.launchpad.net/ubuntu/+source/monodevelop/

Revision history for this message
StefanPotyra (sistpoty) wrote :

hm... changelog and diffstat don't seem to correlate too good. However the diffstat is small, and lots of upstream known bugs seem to be fixed with it. I'm all for bringing a stable version in, as there also aren't any dependencies. ACK #1.

Revision history for this message
Stefan Ebner (sebner) wrote :

For example https://bugs.edge.launchpad.net/ubuntu/+source/monodevelop/+bug/197615 should be fixed now.
The problem is that I can't really discover what it fixes since I haven't had any problems with the gutsy version when I used gutsy.
For example there are many bug reports because of segfaults and sigsev.
UpstreamChangelog shows only that they fixed some of them (with no detailed description).
Nevertheless I think there a many many bugs fixed.

Revision history for this message
Cesare Tirabassi (norsetto) wrote :
Changed in monodevelop:
status: New → Confirmed
Revision history for this message
Stefan Ebner (sebner) wrote :

Ah. sry. totally missed the novell bugzilla. However /me is now looking for a sponsor ACK :)

Changed in monodevelop:
assignee: nobody → dktrkranz
status: Confirmed → In Progress
Revision history for this message
John Dong (jdong) wrote :

If nobody does before Friday night, I'll take a look at it then :) Go Mono!

Revision history for this message
Luca Falavigna (dktrkranz) wrote :

Too late, John :)

Changed in monodevelop:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package monodevelop - 1.0+dfsg-1ubuntu1

---------------
monodevelop (1.0+dfsg-1ubuntu1) hardy; urgency=low

  * Merge from Debian unstable. (LP: #209012) Remaining Ubuntu changes:
  + debian/control:
    - Build-dep on xulrunner-1.9-dev instead of firefox-dev
    - Depend on xulrunner-1.9 instead of firefox
  + don't do any MOZILLA_HOME/MOZILLA_FIVE_HOME business which isn't needed
    for xulrunner-1.9 using the standalone glue anymore (gecko gil uses
    standalone by default)
    - add debian/patches/use_xulrunner_1.9.dpatch
    - update debian/patches/00list
  * Remove build-dep on libxul-dev and the dep on libxul0d
    since we are using xulrunner1.9 instead.

monodevelop (1.0+dfsg-1) unstable; urgency=low

  * DFSG version of MonoDevelop 1.0
    (deleted all pre-compiled binaries from the tarball)
    + For the record here a list of the deleted files:
      src/addins/NUnit/lib/nunit.core.dll
      src/addins/NUnit/lib/nunit.framework.dll
  * New upstream (bugfix) release
  * debian/patches/bashism.dpatch:
    + Use bash instead of sh in mdtool. (Closes: #468688)
  * debian/control:
    + Removed unneeded build-dependency on libvte2.0-cil.

monodevelop (0.19+dfsg-1) unstable; urgency=low

  * DFSG version of MonoDevelop 0.19
    (deleted all pre-compiled binaries from the tarball)
    + For the record here a list of the deleted files:
      src/addins/NUnit/lib/nunit.core.dll
      src/addins/NUnit/lib/nunit.framework.dll
  * New upstream (bugfix) release
  * debian/rules:
    + Fix permissions of .mo files in install target.
    + Using dh_clistrip now to handle (strip) .mdb files.
  * debian/control:
    + Updated cli-common-dev build dependency to >= 0.5.4, as we need
      dh_clistrip from it now.
    + Replaced mono-mcs dependecy with recommends mono-gmcs and suggests
      mono-mcs, as MonoDevelop uses by default the C# 2.0 compiler now.
    + Updated various build-dep versions to match configure's expectation.
    + Replaced libgecko2.0-cil build dependency with libxul-dev, as it's used
      directly.
    + Added libxul0d binary dependency to monodevelop. (Closes: #461353)
  * debian/copyright:
    + Updated author list.
    + Added copyright info.

 -- Stefan Ebner <email address hidden> Sat, 29 Mar 2008 23:36:33 +0100

Changed in monodevelop:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers