openoffice.org FTBFS in maverick - /usr/include/mono-1.0/mono/metadata/assembly.h:4: fatal error: glib.h: No such file or directory

Bug #617782 reported by Loïc Minier
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mono
Fix Released
Critical
mono (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: openoffice.org

Hi

Latest openoffice.org failed to build on some architectures in maverick:
Name "main::name" used only once: possible typo at /build/buildd/openoffice.org-3.2.1/ooo-build-3-2-1-4/build/OOO320_m19/solenv/bin/deliver.pl line 1312.
Module 'mysqlc' delivered successfully. 2 files copied, 0 files unchanged

1 module(s):
 cli_ure
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making /build/buildd/openoffice.org-3.2.1/ooo-build-3-2-1-4/build/OOO320_m19/cli_ure/source/climaker

Attention: if you build and deliver the above module(s) you may prolongue your the build issuing command "build --from cli_ure"

rmdir /tmp/XAmyFQr7RL
make[1]: *** [stamp/build] Error 1

and earlier:
Compiling: rsc/source/parser/rscyacc.cxx
   embedding: /build/buildd/openoffice.org-3.2.1/ooo-build-3-2-1-4/build/OOO320_m19/cli_ure/unxlngx6.pro/bin/cli_basetypes.dll
Compiling:
as -o temp.o temp.s
Compiling: rsc/source/parser/rsclex.cxx
Compiling: rsc/source/parser/erscerr.cxx
x86_64-linux-gnu-gcc -ggdb -o ../../unxlngx6.pro/bin/climaker -Wall temp.c `pkg-config --cflags --libs mono` temp.o
In file included from temp.c:2:
/usr/include/mono-1.0/mono/metadata/assembly.h:4: fatal error: glib.h: No such file or directory
compilation terminated.
[Fail]
dmake: Error code 1, while making '../../unxlngx6.pro/bin/climaker'

Full build log: http://launchpadlibrarian.net/53637702/buildlog_ubuntu-maverick-amd64.openoffice.org_1%3A3.2.1-5ubuntu1_FAILEDTOBUILD.txt.gz

Bye,

Related branches

Revision history for this message
In , Pmladek (pmladek) wrote :

Sigh, it is even worse. The binary is created using the command gmcs and mkbundle2.

I have no idea how to pass the extra include and link flags there to point to glib.h, ...

=> it is a blocker from my point of view.

Here is the whole log:

--- cut ---
Entering /usr/src/packages/BUILD/ooo320-m17-ure/cli_ure/source/climaker
gmcs -debug -unsafe climaker_csharp.cs -reference:../../unxlngx6.pro/bin/cli_basetypes.dll -out:../../unxlngx6.pro/bin/climaker.exe
climaker_csharp.cs(2297,12): warning CS0414: The private field `UnoXInterfaceMethodTypeDescription.mExceptionTypesHandle' is assigned but its value is never used
Compilation succeeded - 1 warning(s)
mkbundle2 -L ../../unxlngx6.pro/lib --deps -o ../../unxlngx6.pro/bin/climaker ../../unxlngx6.pro/bin/climaker.exe ../../unxlngx6.pro/bin/cli_basetypes.dll
OS is: Linux
Sources: 2 Auto-dependencies: True
   embedding: /usr/src/packages/BUILD/ooo320-m17-ure/cli_ure/unxlngx6.pro/bin/climaker.exe
   embedding: /usr/lib/mono/2.0/mscorlib.dll
   embedding: /usr/src/packages/BUILD/ooo320-m17-ure/cli_ure/unxlngx6.pro/bin/cli_basetypes.dll
Compiling:
as -o temp.o temp.s
/opt/icecream/bin/gcc -ggdb -o ../../unxlngx6.pro/bin/climaker -Wall temp.c `pkg-config --cflags --libs mono` temp.o
In file included from temp.c:2:0:
/usr/lib64/pkgconfig/../../include/mono-1.0/mono/metadata/assembly.h:4:18: fatal error: glib.h: No such file or directory
compilation terminated.
[Fail]
dmake: Error code 1, while making '../../unxlngx6.pro/bin/climaker'

ERROR: Error 65280 occurred while making /usr/src/packages/BUILD/ooo320-m17-ure/cli_ure/source/climaker
rmdir /tmp/Vy_aB3Lo7L
--- cut ---

Revision history for this message
In , Ajorgensen (ajorgensen) wrote :

Reverted the change via patch for openSUSE. There is a more correct fix in trunk which will land in 2.8.

rq#39765

Revision history for this message
In , Pmladek (pmladek) wrote :

Hmm, the request #39765 is between Mono:Factory/mono-core(r48) and Mono/mono-core. It is pending there 6 days without any attention.

Andrew, could you please make sure that the fix is forwarded into Factory ASAP?

Revision history for this message
In , Ajorgensen (ajorgensen) wrote :

*** Bug 606240 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Ajorgensen (ajorgensen) wrote :

*** Bug 606376 has been marked as a duplicate of this bug. ***

Revision history for this message
Loïc Minier (lool) wrote :

Binary package hint: openoffice.org

Hi

Latest openoffice.org failed to build on some architectures in maverick:
Name "main::name" used only once: possible typo at /build/buildd/openoffice.org-3.2.1/ooo-build-3-2-1-4/build/OOO320_m19/solenv/bin/deliver.pl line 1312.
Module 'mysqlc' delivered successfully. 2 files copied, 0 files unchanged

1 module(s):
 cli_ure
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making /build/buildd/openoffice.org-3.2.1/ooo-build-3-2-1-4/build/OOO320_m19/cli_ure/source/climaker

Attention: if you build and deliver the above module(s) you may prolongue your the build issuing command "build --from cli_ure"

rmdir /tmp/XAmyFQr7RL
make[1]: *** [stamp/build] Error 1

and earlier:
Compiling: rsc/source/parser/rscyacc.cxx
   embedding: /build/buildd/openoffice.org-3.2.1/ooo-build-3-2-1-4/build/OOO320_m19/cli_ure/unxlngx6.pro/bin/cli_basetypes.dll
Compiling:
as -o temp.o temp.s
Compiling: rsc/source/parser/rsclex.cxx
Compiling: rsc/source/parser/erscerr.cxx
x86_64-linux-gnu-gcc -ggdb -o ../../unxlngx6.pro/bin/climaker -Wall temp.c `pkg-config --cflags --libs mono` temp.o
In file included from temp.c:2:
/usr/include/mono-1.0/mono/metadata/assembly.h:4: fatal error: glib.h: No such file or directory
compilation terminated.
[Fail]
dmake: Error code 1, while making '../../unxlngx6.pro/bin/climaker'

Full build log: http://launchpadlibrarian.net/53637702/buildlog_ubuntu-maverick-amd64.openoffice.org_1%3A3.2.1-5ubuntu1_FAILEDTOBUILD.txt.gz

Bye,

Revision history for this message
Loïc Minier (lool) wrote :

This is a regression in the mono .pc files; see https://bugzilla.novell.com/show_bug.cgi?id=604251

affects: openoffice.org (Ubuntu) → mono (Ubuntu)
Changed in mono (Ubuntu):
importance: Undecided → High
Revision history for this message
In , Loïc Minier (lool) wrote :

*** Bug 630000 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Loïc Minier (lool) wrote :

Also an issue in Ubuntu (and I guess Debian); we're reverting for the 2.6 branch; https://bugs.launchpad.net/ubuntu/+source/mono/+bug/617782

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mono - 2.6.7-1ubuntu2

---------------
mono (2.6.7-1ubuntu2) maverick; urgency=high

  * data/mono.pc.in: Revert upstream commit 59db1f55409d80fc93ed, which
    commented out the Requires line in mono.pc.in. This causes build
    failures because mono still includes the headers. (LP: #617782)
    References: https://bugzilla.novell.com/show_bug.cgi?id=604251
 -- Iain Lane <email address hidden> Sat, 14 Aug 2010 12:21:25 +0100

Changed in mono (Ubuntu):
status: New → Fix Released
Changed in mono:
status: Unknown → Fix Released
Revision history for this message
In , Iain Lane (laney) wrote :

Can this please be reverted or otherwise fixed on the 2.6 branch?

Changed in mono:
importance: Unknown → Critical
Revision history for this message
In , Bwiedemann (bwiedemann) wrote :

This is an autogenerated message for OBS integration:
This bug (604251) was mentioned in
https://build.opensuse.org/request/show/40130 Factory / OpenOffice_org
https://build.opensuse.org/request/show/40131 Factory / OpenOffice_org-artwork
https://build.opensuse.org/request/show/40132 Factory / OpenOffice_org-base
https://build.opensuse.org/request/show/40133 Factory / OpenOffice_org-bootstrap
https://build.opensuse.org/request/show/40134 Factory / OpenOffice_org-branding-upstream
https://build.opensuse.org/request/show/40135 Factory / OpenOffice_org-calc
https://build.opensuse.org/request/show/40136 Factory / OpenOffice_org-components
https://build.opensuse.org/request/show/40137 Factory / OpenOffice_org-extensions
https://build.opensuse.org/request/show/40138 Factory / OpenOffice_org-filters
https://build.opensuse.org/request/show/40139 Factory / OpenOffice_org-help-en-US
https://build.opensuse.org/request/show/40140 Factory / OpenOffice_org-icon-themes
https://build.opensuse.org/request/show/40141 Factory / OpenOffice_org-impress
https://build.opensuse.org/request/show/40142 Factory / OpenOffice_org-l10n
https://build.opensuse.org/request/show/40143 Factory / OpenOffice_org-l10n-extras
https://build.opensuse.org/request/show/40144 Factory / OpenOffice_org-libs-core
https://build.opensuse.org/request/show/40145 Factory / OpenOffice_org-libs-extern
https://build.opensuse.org/request/show/40146 Factory / OpenOffice_org-libs-gui
https://build.opensuse.org/request/show/40147 Factory / OpenOffice_org-ure
https://build.opensuse.org/request/show/40148 Factory / OpenOffice_org-writer
https://build.opensuse.org/request/show/40208 Factory / mono-core

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.