mono apps output byte order mark even on UTF-8 console

Bug #45702 reported by Steve Cheng on 2006-05-20
6
Affects Status Importance Assigned to Milestone
mono
Incomplete
Unknown
mono (Ubuntu)
Medium
Sebastian Dröge

Bug Description

Binary package hint: mono

In any binary that uses mono to run,
and outputs on a console,
the extraneous bytes for the “UTF-8 byte order mark” are output.
They should not be.

As an example,
examine the output of xsd.exe.

$ xsd |od -w16 -t x1c
0000000 ef bb bf 78 73 64 2e 65 78 65 20 2d 20 61 20 75
        357 273 277 x s d . e x e - a u

The first three strange numbers form the byte order mark.
Under gnome-terminal that byte order mark renders as a extra garbage character.

Apparently this bug should have been resolved a long time ago, according to this upstream bug report:

http://bugzilla.ximian.com/show_bug.cgi?id=52101

but I am still seeing the problem described therein.

Thanks for your concern,
// Steve Cheng

Sebastian Dröge (slomo) wrote :

I can confirm this behaviour here but it gnome-terminal doesn't display garbage anymore, only a space

Changed in mono:
assignee: nobody → slomo
status: Unconfirmed → Confirmed
Sebastian Dröge (slomo) wrote :

This should be fixed with 1.1.13.8-0ubuntu2 which was uploaded to edgy some seconds ago

Changed in mono:
status: Confirmed → Fix Released
Changed in mono:
status: Unknown → Confirmed
Changed in mono:
status: Confirmed → Needs Info
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.