ftbfs on s390x

Bug #1520033 reported by Dimitri John Ledkov on 2015-11-26
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mono (Ubuntu)
Undecided
Unassigned

Bug Description

ftbfs on s390x

Changed in mono (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed
assignee: nobody → Dimitri John Ledkov (xnox)
tags: added: s390x
Timotheus Pokorra (tpokorra) wrote :

Is this an ancient bug and should be closed? or is it ok to reuse this bug report?

It used to build for https://launchpad.net/ubuntu/+source/mono/5.18.0.240+dfsg-3/+build/17185141, but now it does not anymore: https://launchpad.net/ubuntu/+source/mono/5.18.0.240+dfsg-5/+build/17750817

One difference is gcc-8 vs gcc-9.

Dimitri John Ledkov (xnox) wrote :

I wonder if it will build by setting -march=z196

Timotheus Pokorra (tpokorra) wrote :

so can someone with permissions please drop support for s390x, so that Mono builds again for Ubuntu? Or anyone going to try the settings to make it build again for s390x?

Dimitri John Ledkov (xnox) wrote :

It fails to build in Debian too.

Dimitri John Ledkov (xnox) wrote :
Changed in mono (Ubuntu):
assignee: Dimitri John Ledkov (xnox) → nobody
Andres G. Aragoneses (knocte) wrote :

> It fails to build in Debian too.

@xnox hey Dimitri, the build breakage in Debian is not the same as the one in Ubuntu:
https://buildd.debian.org/status/package.php?p=mono&suite=unstable

In Debian, it builds fine with s390x, but doesn't for kfreebsd (and this latter arch is not supported by Ubuntu anyway, AFAIK).

So can we revisit dropping s390x arch for Ubuntu? Otherwise, if these latest fixes are not included in Ubuntu 20.04, nuget (the default package manager for .NET) will not work in the next LTS because of some runtime crash that these latest patches fix.

Dimitri John Ledkov (xnox) wrote :

mono (5.18.0.240+dfsg-3) unstable; urgency=high

  [ Jo Shields ]
  * [20a7dd0] Don't build docs on s390x, to work around a dumb issue

  [ Neale Ferguson ]
  * [3713407] Fix s390x Outarg_VT (#10632)
    * Fix outarg_vt processing. Fixes #10549
    * Cleanup unused bits and pieces
    * Correct the handling of structures being retuned from a call
    * Restore vtcopy code etc.
    (Closes: #921232)

 -- Jo Shields <email address hidden> Tue, 16 Apr 2019 15:41:50 -0400

Changed in mono (Ubuntu):
status: Confirmed → Fix Released
Timotheus Pokorra (timotheus-a) wrote :

As far as I can see, this is not fixed for https://launchpad.net/ubuntu/+source/mono/5.18.0.240+dfsg-5
The build for s390x still does not build?
Or do you want a new bug report for that release 5.18.0.240+dfsg-5

Jo Shields (directhex) wrote :

Sorry for dropping the ball on this.

We have 3 options:

1) Drop s390x for Focal

2) Backport a commit which, in testing, inexplicably appears to fix s390x, at least on Debian Sid - but there's a LOT of churn around it, so it's tough to backport (491a4d5da8e523d6191e6027ea7f3cee226d6ba8)

3) Update to at least Mono 6.8 (6.6 is definitely bad, 6.10 is definitely good, the relevant commit would _just_ have missed the 6.6 branch date so should be in 6.8)

Personally, I think option 3 is the best of the 3.

Andres G. Aragoneses (knocte) wrote :

> 1) Drop s390x for Focal

This is my preference ^

> 491a4d5da8e523d6191e6027ea7f3cee226d6ba8

https://github.com/mono/mono/commit/491a4d5da8e523d6191e6027ea7f3cee226d6ba8 ? doesn't look too bad, IMHO this is the 2nd best option.

> 3) Update to at least Mono 6.8 (6.6 is definitely bad, 6.10 is definitely good

Mmm, not sure I understand why you think this is the best option, given that:
a) Jump from 5.x to 6.x version is big, and the time window to test this is very short before the freeze or LTS release.
b) You claim that Mono 6.6 is bad, but it's what is marked as stable per upstream. The stable channel in mac has Mono 6.6, Microsoft's apt repositories have 6.6. IMO introducing bleeding edge 6.8 (or worse, 6.10) is too adventurous.

Jo Shields (directhex) wrote :

I think 2 is dead as an option.

That commit doesn't help on Ubuntu. Since there are no Ubuntu porterboxes, and the VM I requested from IBM hasn't materialised yet, I've got no scope for trying to bisect this on Ubuntu.

Travis has s390x support with Ubuntu bionic.

PPAs have s390x support (just tick in settings) and I have access to Ubuntu
mainframe.

What things should I be bisecting for?

I'd rather not do mono transition without Debian. Note we are on par with
Debian at the moment. Not sure when they are thinking to upgrade to
something newer.

On Wed, 19 Feb 2020, 17:04 Jo Shields, <email address hidden> wrote:

> I think 2 is dead as an option.
>
> That commit doesn't help on Ubuntu. Since there are no Ubuntu
> porterboxes, and the VM I requested from IBM hasn't materialised yet,
> I've got no scope for trying to bisect this on Ubuntu.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1520033
>
> Title:
> ftbfs on s390x
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/mono/+bug/1520033/+subscriptions
>

Jo Shields (directhex) wrote :

Bisecting just via speculative CI uploads is pretty horrible.

I threw an upstream 6.10 (December 2019 branch) tarball at a PPA, and it built, and previously had the same failures with a 6.6 tarball (August 2019 branch). So somewhere in that range, the issues with Focal were fixed.

Am still working on improving the CI story upstream with IBM, but that's not going to happen in time.

Andres G. Aragoneses (knocte) wrote :

> I'd rather not do mono transition without Debian.

I guess you mean that if Debian hasn't updated to 6.x yet, ubuntu shouldn't either. My 2cents: I agree.

> but that's not going to happen in time.

I guess Jo means that it will not happen before Focal's release date.

Given the above, are we all in agreement to proceed with the (a) option mentioned above?

Andres G. Aragoneses (knocte) wrote :

> the (a) option

Oops, I meant the "(1)" option: Drop s390x for Focal

Thanks to directhex, there is now Mono 6.8 in Focal, for all 5 architectures (amd64, arm64, armhf, ppc64el, s390x)!
https://packages.ubuntu.com/de/focal/mono-complete
I just tried it, it works indeed!

Thank you directhex, your work is much appreciated!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers