x11 dllmap points to unversioned library

Bug #1008212 reported by Julian Taylor on 2012-06-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mono (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

/etc/mono/config contains the dllmap for libX11 but it points to the .so
 <dllmap dll="libX11" target="libX11.so" os="!windows" />

the .so is only included in libx11-dev.
it should point to the versioned .so.6 contained in libx116

TEST CASE:
compile this with dmcs:

$ cat libx11.cs
using System;
using System.Runtime.InteropServices;
class X11Test
{
    [DllImport ("libX11")]
    static extern void XAllPlanes ();
    static void Main(string[] args)
    {
      XAllPlanes ();
    }

}

$ dmcs libx11.cs
$ ./libx11.exe

Unhandled Exception: System.DllNotFoundException: libX11.so
  at (wrapper managed-to-native) X11Test:XAllPlanes ()
  at X11Test.Main (System.String[] args) [0x00000] in <filename unknown>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.DllNotFoundException: libX11.so
  at (wrapper managed-to-native) X11Test:XAllPlanes ()
  at X11Test.Main (System.String[] args) [0x00000] in <filename unknown>:0

expected:
no backtrace

FIX: this is caused by the build not finding the multiarched library
it was fixed in -4:
   [ Jo Shields ]
   * [f77ef2f] Tweak build system to check multiarch library folder for
     libX11.so.

REGRESSION POTENTIAL:
the fix only adds a search path to configure.in which adds libX11.so.6 to etc/mono/config, it should not cause any regressions

Julian Taylor (jtaylor) on 2012-06-03
Changed in mono (Ubuntu):
status: New → Fix Released
description: updated
Julian Taylor (jtaylor) wrote :
description: updated
Iain Lane (laney) on 2012-06-03
Changed in mono (Ubuntu Precise):
status: New → Confirmed
Iain Lane (laney) wrote :

uploaded to precise-proposed/unapproved

Hello Julian, or anyone else affected,

Accepted mono into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in mono (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Stéphane Graber (stgraber) wrote :

fix confirmed

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mono - 2.10.8.1-1ubuntu2.1

---------------
mono (2.10.8.1-1ubuntu2.1) precise-proposed; urgency=low

  * configure.in: search multiarch paths for libX11 (LP: #1008212)
    changes the dllmap in /etc/mono/config to the versioned library
 -- Julian Taylor <email address hidden> Sun, 03 Jun 2012 22:46:30 +0200

Changed in mono (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers