monodoc crashes when show comments is true

Bug #60788 reported by Holger Bauer on 2006-09-16
2
Affects Status Importance Assigned to Milestone
mono-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Set show comments to true. On restart monodoc-browser crashes. You have to delete or edit the config in ~/.config/monodoc to get the browser back.
Note: It seems monodoc doesn't save this setting normally. I opened/closed the app many times before it was saved once. I have no clue what I did differently compared to the other sessions the setting was not saved.

monodoc 1.1.17-0ubuntu1
monodoc-base 1.1.17-0ubuntu1
monodoc-browser 1.1.11-4

Here is the output on console when it crashes:
Bookmark Manager init

Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object
  at Monodoc.Browser.OnCommentsActivate (System.Object o, System.EventArgs args) [0x00000]
  at (wrapper delegate-invoke) System.MulticastDelegate:invoke_void_object_EventArgs (object,System.EventArgs)
  at GLib.Signal.voidObjectCallback (IntPtr handle, IntPtr gch) [0x00000]
  at (wrapper native-to-managed) GLib.Signal:voidObjectCallback (intptr,intptr)
  at <0x00000> <unknown method>
  at (wrapper managed-to-native) Gtk.CheckMenuItem:gtk_check_menu_item_set_active (intptr,bool)
  at Gtk.CheckMenuItem.set_Active (Boolean value) [0x00000]
  at Monodoc.Browser..ctor (Boolean UseGecko) [0x00000]
  at Monodoc.Driver.Main (System.String[] args) [0x00000]

Paul Dufresne (paulduf) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in mono-tools:
assignee: nobody → dufresnep
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in mono-tools:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers